summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-19 20:31:51 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-19 23:22:25 -0800
commit78f6d47290474d6c144ceb1a6f2b5289c06e227a (patch)
tree0cb8cc575754406a317bafc943eb57e44068205e
parent635260e2f2ef3ab0189a244a925a55cec1bc9079 (diff)
downloadmeta-openembedded-78f6d47290474d6c144ceb1a6f2b5289c06e227a.tar.gz
python3-pytest-lazy-fixtures: add 1.0.5
Use your fixtures in @pytest.mark.parametrize. This project was inspired by pytest-lazy-fixture. Improvements that have been made in this project: 1. You can use fixtures in any data structures 2. You can access the attributes of fixtures 3. You can use functions in fixtures * Dependency for python3-prettytable ptest. (Not the same as python3-pytest-lazy-fixture without the s) * Upstream does not package tests/ in the sdist on pypi, so we do not try to enable ptest at this time (it would require using git fetcher instead of pypi.bbclass). * The ptest for the predecessor (python3-pytest-lazy-fixture without the s) was already in PTEST_PROBLEMS, meaning its ptests did not run cleanly. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb
new file mode 100644
index 000000000..dcf662a2c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Allows you to use fixtures in @pytest.mark.parametrize."
2DESCRIPTION = "Use your fixtures in @pytest.mark.parametrize. \
3\
4This project was inspired by pytest-lazy-fixture.\
5\
6Improvements that have been made in this project:\
7\
8* You can use fixtures in any data structures\
9* You can access the attributes of fixtures\
10* You can use functions in fixtures"
11HOMEPAGE = "https://github.com/dev-petrov/pytest-lazy-fixtures"
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=4475e66fcfabe27395e6764c8f69c876"
14
15SRC_URI[sha256sum] = "066b253a94c249e6d9cdfad465e2503d2219139fb468d8f687243dfde39ab9cb"
16
17inherit pypi python_poetry_core
18
19PYPI_PACKAGE = "pytest_lazy_fixtures"
20
21RDEPENDS:${PN} = "python3-pytest"