diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-16 16:15:19 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-16 16:42:35 -0800 |
commit | 7235412ef452e188b0ce1afaaa96e6fc34ea3524 (patch) | |
tree | abed57f2b38f5faefba35ee079912b8fcaea9070 | |
parent | 6ad70164f65763a7f8da0a102fe2f2a3cee5dfd5 (diff) | |
download | meta-openembedded-7235412ef452e188b0ce1afaaa96e6fc34ea3524.tar.gz |
python3-pyroute2: switch to pytest --automake
* Sort RDEPENDS for ptest alphabetically
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyroute2/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb | 3 |
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest index ea429ba21..f1c8729f0 100644 --- a/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest +++ b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest | |||
@@ -1,4 +1,4 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
4 | 4 | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb index 6b340a18c..740a6d7f7 100644 --- a/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb +++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb | |||
@@ -27,9 +27,10 @@ SRC_URI += " \ | |||
27 | " | 27 | " |
28 | 28 | ||
29 | RDEPENDS:${PN}-ptest += " \ | 29 | RDEPENDS:${PN}-ptest += " \ |
30 | python3-pytest \ | ||
31 | python3-fcntl \ | 30 | python3-fcntl \ |
31 | python3-pytest \ | ||
32 | python3-sqlite3 \ | 32 | python3-sqlite3 \ |
33 | python3-unittest-automake-output \ | ||
33 | " | 34 | " |
34 | 35 | ||
35 | do_install_ptest() { | 36 | do_install_ptest() { |