summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Fan Yu <yifan.yu@windriver.com>2021-04-16 11:36:48 -0400
committerKhem Raj <raj.khem@gmail.com>2021-04-17 07:43:10 -0700
commit6c626c0e12673b56ed2d7387465f8c2d88d956d2 (patch)
treeb95abc7550c29d442564ec59f6d1d12d1dedd58b
parent01d3f9daa0c320070269e9a27a5c88ba11b08aa7 (diff)
downloadmeta-openembedded-6c626c0e12673b56ed2d7387465f8c2d88d956d2.tar.gz
syslog-ng: remove CONFIG_TLS override for arm DEBUG_BUILD
when enabling DEBUG_BUILD, an assembler failure used to be seen. But this patch was in meta-oe c0ce7599, dating in 2014... Cannot reproduce the failure anymore with qemuarm. Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch63
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc5
2 files changed, 0 insertions, 68 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch b/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
deleted file mode 100644
index ff35fb157..000000000
--- a/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
+++ /dev/null
@@ -1,63 +0,0 @@
1From 15a90fd9ac1396015340e599e26d7cd193898fb8 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Tue, 12 Aug 2014 14:26:13 +0800
4Subject: [PATCH] configure.ac: add option --enable-thread-tls to manage thread
5 ssl support
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10The thread local storage caused arm-gcc broken while compiling │
11syslog-ng with option '-g -O'. │
12... │
13dnscache.s: Assembler messages: │
14dnscache.s:100: Error: invalid operands (.text and *UND* sections) for `-' │
15... │
16
17Add option --enable-thread-tls to manage the including of thread
18local storage, so we could explicitly disable it.
19
20Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
21
22change default to 'yes'
23Upstream-Status: Submitted [https://github.com/syslog-ng/syslog-ng/pull/3649]
24
25Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com>
26---
27 configure.ac | 16 ++++++++++------
28 1 file changed, 10 insertions(+), 6 deletions(-)
29
30diff --git a/configure.ac b/configure.ac
31index 1d67e81..7aad75f 100644
32--- a/configure.ac
33+++ b/configure.ac
34@@ -210,6 +210,8 @@ AC_ARG_WITH(sanitizer,
35 [ --with-sanitizer=[address/undefined/etc...]
36 Enables compiler sanitizer supports (default: no)]
37 ,,with_sanitizer="no")
38+AC_ARG_ENABLE(thread-tls,
39+ [ --enable-thread-tls Enable Thread Local Storage support (default: yes)],,enable_thread_tls="yes")
40
41 AC_ARG_ENABLE(dynamic-linking,
42 [ --enable-dynamic-linking Link everything dynamically.],,enable_dynamic_linking="auto")
43@@ -628,12 +630,14 @@ dnl ***************************************************************************
44 dnl Is the __thread keyword available?
45 dnl ***************************************************************************
46
47-AC_LINK_IFELSE([AC_LANG_PROGRAM(
48-[[#include <pthread.h>
49-__thread int a;
50-]],
51-[a=0;])],
52-[ac_cv_have_tls=yes; AC_DEFINE_UNQUOTED(HAVE_THREAD_KEYWORD, 1, "Whether Thread Local Storage is supported by the system")])
53+if test "x$enable_thread_tls" = "xyes"; then
54+ AC_LINK_IFELSE([AC_LANG_PROGRAM(
55+ [[#include <pthread.h>
56+ __thread int a;
57+ ]],
58+ [a=0;])],
59+ [ac_cv_have_tls=yes; AC_DEFINE_UNQUOTED(HAVE_THREAD_KEYWORD, 1, "Whether Thread Local Storage is supported by the system")])
60+fi
61
62 dnl ***************************************************************************
63 dnl How to do static linking?
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index ebb3eaf0f..e48e5d5e2 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -22,7 +22,6 @@ SRC_URI = "https://github.com/balabit/syslog-ng/releases/download/${BP}/${BP}.ta
22 file://syslog-ng.conf.sysvinit \ 22 file://syslog-ng.conf.sysvinit \
23 file://initscript \ 23 file://initscript \
24 file://volatiles.03_syslog-ng \ 24 file://volatiles.03_syslog-ng \
25 file://configure.ac-add-option-enable-thread-tls-to-manage-.patch \
26" 25"
27 26
28UPSTREAM_CHECK_URI = "https://github.com/balabit/syslog-ng/releases" 27UPSTREAM_CHECK_URI = "https://github.com/balabit/syslog-ng/releases"
@@ -42,12 +41,8 @@ EXTRA_OECONF = " \
42 --disable-python \ 41 --disable-python \
43 --disable-java --disable-java-modules \ 42 --disable-java --disable-java-modules \
44 --with-pidfile-dir=${localstatedir}/run/${BPN} \ 43 --with-pidfile-dir=${localstatedir}/run/${BPN} \
45 ${CONFIG_TLS} \
46" 44"
47 45
48CONFIG_TLS = "--enable-thread-tls"
49CONFIG_TLS_arm = "${@oe.utils.conditional( "DEBUG_BUILD", "1", " --disable-thread-tls", " --enable-thread-tls", d )}"
50
51PACKAGECONFIG ??= " \ 46PACKAGECONFIG ??= " \
52 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} \ 47 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} \
53" 48"