summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-02 21:21:56 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:35 -0700
commit649d69d5a2754bcd7d2803857306df4fce3f69c2 (patch)
tree22d9ca8bf5d368c1695815a55291800aa85f4e8c
parentab95949b78db9ea7e9c8a94bcc75a5ef1bf03195 (diff)
downloadmeta-openembedded-649d69d5a2754bcd7d2803857306df4fce3f69c2.tar.gz
cyrus-sasl: Fix time.h detection logic in configure
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/0001-Fix-time.h-check.patch61
-rw-r--r--meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl_2.1.28.bb1
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/0001-Fix-time.h-check.patch b/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/0001-Fix-time.h-check.patch
new file mode 100644
index 000000000..a6df213fe
--- /dev/null
+++ b/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/0001-Fix-time.h-check.patch
@@ -0,0 +1,61 @@
1From 266f0acf7f5e029afbb3e263437039e50cd6c262 Mon Sep 17 00:00:00 2001
2From: Sam James <sam@gentoo.org>
3Date: Wed, 23 Feb 2022 00:45:15 +0000
4Subject: [PATCH] Fix <time.h> check
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9We're conditionally including based on HAVE_TIME_H in a bunch of places,
10but we're not actually checking for time.h, so that's never going to be defined.
11
12While at it, add in a missing include in the cram plugin.
13
14This fixes a bunch of implicit declaration warnings:
15```
16 * cyrus-sasl-2.1.28/lib/saslutil.c:280:3: warning: implicit declaration of function ‘time’ [-Wimplicit-function-declaration]
17 * cyrus-sasl-2.1.28/lib/saslutil.c:364:41: warning: implicit declaration of function ‘clock’ [-Wimplicit-function-declaration]
18 * cyrus-sasl-2.1.28/plugins/cram.c:132:7: warning: implicit declaration of function ‘time’ [-Wimplicit-function-declaration]
19 * cyrus-sasl-2.1.28/lib/saslutil.c:280:3: warning: implicit declaration of function ‘time’ [-Wimplicit-function-declaration]
20 * cyrus-sasl-2.1.28/lib/saslutil.c:364:41: warning: implicit declaration of function ‘clock’ [-Wimplicit-function-declaration]
21 * cyrus-sasl-2.1.28/plugins/cram.c:132:7: warning: implicit declaration of function ‘time’ [-Wimplicit-function-declaration]
22```
23
24Upstream-Status: Backport [https://github.com/cyrusimap/cyrus-sasl/commit/266f0acf7f5e029afbb3e263437039e50cd6c262]
25Signed-off-by: Sam James <sam@gentoo.org>
26---
27 configure.ac | 2 +-
28 plugins/cram.c | 4 ++++
29 2 files changed, 5 insertions(+), 1 deletion(-)
30
31diff --git a/configure.ac b/configure.ac
32index e1bf53b6..ad781830 100644
33--- a/configure.ac
34+++ b/configure.ac
35@@ -1290,7 +1290,7 @@ AC_CHECK_HEADERS_ONCE([sys/time.h])
36
37 AC_HEADER_DIRENT
38 AC_HEADER_SYS_WAIT
39-AC_CHECK_HEADERS(crypt.h des.h dlfcn.h fcntl.h limits.h malloc.h paths.h strings.h sys/file.h sys/time.h syslog.h unistd.h inttypes.h sys/uio.h sys/param.h sysexits.h stdarg.h varargs.h krb5.h)
40+AC_CHECK_HEADERS(crypt.h des.h dlfcn.h fcntl.h limits.h malloc.h paths.h strings.h sys/file.h sys/time.h syslog.h time.h unistd.h inttypes.h sys/uio.h sys/param.h sysexits.h stdarg.h varargs.h krb5.h)
41
42 IPv6_CHECK_SS_FAMILY()
43 IPv6_CHECK_SA_LEN()
44diff --git a/plugins/cram.c b/plugins/cram.c
45index d02e9baa..695aaa91 100644
46--- a/plugins/cram.c
47+++ b/plugins/cram.c
48@@ -53,6 +53,10 @@
49 #endif
50 #include <fcntl.h>
51
52+#ifdef HAVE_TIME_H
53+#include <time.h>
54+#endif
55+
56 #include <sasl.h>
57 #include <saslplug.h>
58 #include <saslutil.h>
59--
602.37.3
61
diff --git a/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl_2.1.28.bb b/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl_2.1.28.bb
index e344733ef..3277fb109 100644
--- a/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl_2.1.28.bb
+++ b/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl_2.1.28.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://github.com/cyrusimap/cyrus-sasl;protocol=https;branch=cyrus-sas
15 file://saslauthd.conf \ 15 file://saslauthd.conf \
16 file://CVE-2019-19906.patch \ 16 file://CVE-2019-19906.patch \
17 file://CVE-2022-24407.patch \ 17 file://CVE-2022-24407.patch \
18 file://0001-Fix-time.h-check.patch \
18 " 19 "
19 20
20UPSTREAM_CHECK_URI = "https://github.com/cyrusimap/cyrus-sasl/archives" 21UPSTREAM_CHECK_URI = "https://github.com/cyrusimap/cyrus-sasl/archives"