summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-06-19 20:50:11 +0300
committerKhem Raj <raj.khem@gmail.com>2019-06-19 19:59:15 -0700
commit59277eadd8571c7dcd7d0d6b53e5b06694295ed2 (patch)
treeeda58e4bcad05c584d0c1a09c8f262c42e8550f9
parent22bfe06d15e07cac0df3f34566a9d33007663bae (diff)
downloadmeta-openembedded-59277eadd8571c7dcd7d0d6b53e5b06694295ed2.tar.gz
efibootmgr: Remove, was moved to oe-core
Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb28
-rw-r--r--meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch31
2 files changed, 0 insertions, 59 deletions
diff --git a/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb b/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb
deleted file mode 100644
index 4edb2e664..000000000
--- a/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb
+++ /dev/null
@@ -1,28 +0,0 @@
1DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhinstaller/efibootmgr"
4SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "pciutils zlib efivar"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
13SRCREV = "e067160ecef8208e1944002e5d50b275733211fb"
14SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
15 file://0001-remove-extra-decl.patch \
16 "
17S = "${WORKDIR}/git"
18
19inherit pkgconfig
20
21EXTRA_OEMAKE = "'EFIDIR=/' 'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar`'"
22
23CFLAGS_append_toolchain-clang = " -Wno-error"
24do_install () {
25 install -D -p -m0755 ${B}/src/efibootmgr ${D}/${sbindir}/efibootmgr
26}
27
28CLEANBROKEN = "1"
diff --git a/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch b/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch
deleted file mode 100644
index 42f3a8182..000000000
--- a/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 99b578501643377e0b1994b2a068b790d189d5ad Mon Sep 17 00:00:00 2001
2From: Peter Jones <pjones@redhat.com>
3Date: Wed, 13 Jun 2018 09:41:01 -0400
4Subject: [PATCH] remove extra decl
5
6Signed-off-by: Peter Jones <pjones@redhat.com>
7
8Upstream-Status: Backport [git://github.com/rhinstaller/efibootmgr.git]
9Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
10
11---
12 src/efibootmgr.c | 3 ---
13 1 file changed, 3 deletions(-)
14
15diff --git a/src/efibootmgr.c b/src/efibootmgr.c
16index de38f01..4e1a680 100644
17--- a/src/efibootmgr.c
18+++ b/src/efibootmgr.c
19@@ -1536,9 +1536,6 @@ parse_opts(int argc, char **argv)
20 "invalid numeric value %s\n",
21 optarg);
22 }
23- /* XXX efivar-36 accidentally doesn't have a public
24- * header for this */
25- extern int efi_set_verbose(int verbosity, FILE *errlog);
26 efi_set_verbose(opts.verbose - 2, stderr);
27 break;
28 case 'V':
29--
302.7.4
31