diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-02-22 19:50:43 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-24 09:08:00 -0800 |
commit | 58c91e724634293aa8ec6a5d1f9ed80095edc91b (patch) | |
tree | a711b0bbb8cd21e323f590c3a7073ec0b6d8ea9d | |
parent | f4ecc2239aea800609926938193ba4811ad8db03 (diff) | |
download | meta-openembedded-58c91e724634293aa8ec6a5d1f9ed80095edc91b.tar.gz |
python3-mpmath: Upgrade 1.1.0 -> 1.2.1
Upgrade to release 1.2.1:
- Support @ operator for matrix multiplication
- Add eta() implementing the Dedekind eta function
- Optimized the python_trailing function
- Implement unary plus for matrices
- Improved calculation of gram_index
- Fix a possible division by zero in shanks()
- Fixed indexing errors in deHoog, Knight & Stokes inverse laplace
transform algorithm
- Corrected branch cuts of the elliprj() function in some cases
- Fix initialization of iv.matrix from non-interval matrix
- Preserve function signatures in PrecisionManager
- Implemented float and complex conversions for ivmpf
- Fixed issue with scalar-matrix multiplication for interval
matrices
- Fix estimation of quadrature error with multiple subintervals
- Fixed a problem with the defun decorators
- Fix eigenvalue sorting by absolute value
License-Update: Alter the last clause to ensure that Github
recognizes the LICENSE as BSD
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb (renamed from meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb) | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb b/meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb index 7879a85cd..51a7c0584 100644 --- a/meta-python/recipes-devtools/python/python3-mpmath_1.1.0.bb +++ b/meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb | |||
@@ -4,13 +4,13 @@ | |||
4 | SUMMARY = "Python library for arbitrary-precision floating-point arithmetic" | 4 | SUMMARY = "Python library for arbitrary-precision floating-point arithmetic" |
5 | HOMEPAGE = "https://pypi.org/project/mpmath/" | 5 | HOMEPAGE = "https://pypi.org/project/mpmath/" |
6 | LICENSE = "BSD" | 6 | LICENSE = "BSD" |
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=efe9feb00df0b763941f2b1bbac7c402" | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71970bd3749eebe1bfef9f1efff5b37a" |
8 | 8 | ||
9 | SRC_URI[md5sum] = "acb1cdddf38e16084628065b174ddbfe" | 9 | SRC_URI[sha256sum] = "79ffb45cf9f4b101a807595bcb3e72e0396202e0b1d25d689134b48c4216a81a" |
10 | SRC_URI[sha256sum] = "fc17abe05fbab3382b61a123c398508183406fa132e0223874578e20946499f6" | ||
11 | 10 | ||
12 | inherit pypi setuptools3 | 11 | inherit pypi setuptools3 |
13 | 12 | ||
13 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
14 | RDEPENDS_${PN} += "python3-image" | 14 | RDEPENDS_${PN} += "python3-image" |
15 | 15 | ||
16 | BBCLASSEXTEND = "native nativesdk" | 16 | BBCLASSEXTEND = "native nativesdk" |