diff options
author | Bartosz Golaszewski <brgl@bgdev.pl> | 2022-05-12 10:41:44 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-05-14 08:17:25 -0700 |
commit | 56ab82fe23b8af40fe05d05249c7cfb81694dfc0 (patch) | |
tree | 72f641455d65344fecd0333289a464845236f480 | |
parent | 5ba8fdacdb7480f6f44d328294a7c7a3d034cc9c (diff) | |
download | meta-openembedded-56ab82fe23b8af40fe05d05249c7cfb81694dfc0.tar.gz |
python3-eth-keyfile: new package
Add a recipe for eth-keyfile: a library for handling the encrypted
keyfiles used to store ethereum private keys.
Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
3 files changed, 53 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb index 41bb24b32..5e41d92c1 100644 --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | |||
@@ -111,6 +111,7 @@ RDEPENDS:packagegroup-meta-python3 = "\ | |||
111 | python3-engineio \ | 111 | python3-engineio \ |
112 | python3-et-xmlfile \ | 112 | python3-et-xmlfile \ |
113 | python3-eth-hash \ | 113 | python3-eth-hash \ |
114 | python3-eth-keyfile \ | ||
114 | python3-eth-keys \ | 115 | python3-eth-keys \ |
115 | python3-eth-typing \ | 116 | python3-eth-typing \ |
116 | python3-eth-utils \ | 117 | python3-eth-utils \ |
diff --git a/meta-python/recipes-devtools/python/python3-eth-keyfile/0001-setup-don-t-use-setuptools-markdown.patch b/meta-python/recipes-devtools/python/python3-eth-keyfile/0001-setup-don-t-use-setuptools-markdown.patch new file mode 100644 index 000000000..7b8120380 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-eth-keyfile/0001-setup-don-t-use-setuptools-markdown.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 4348c72877e049804c7cdb7eec7a6bcd7ac2ea1d Mon Sep 17 00:00:00 2001 | ||
2 | From: Bartosz Golaszewski <brgl@bgdev.pl> | ||
3 | Date: Wed, 11 May 2022 13:21:30 +0200 | ||
4 | Subject: [PATCH] setup: don't use setuptools-markdown | ||
5 | |||
6 | This project is deprecated and irrelevant for the functionality of | ||
7 | eth-keyfile. We don't support it in meta-python so just drop it from | ||
8 | the dependencies. | ||
9 | |||
10 | Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> | ||
11 | --- | ||
12 | setup.py | 2 -- | ||
13 | 1 file changed, 2 deletions(-) | ||
14 | |||
15 | diff --git a/setup.py b/setup.py | ||
16 | index cbb7f4c..7702aa4 100644 | ||
17 | --- a/setup.py | ||
18 | +++ b/setup.py | ||
19 | @@ -51,14 +51,12 @@ setup( | ||
20 | "A library for handling the encrypted keyfiles used to store ethereum " | ||
21 | "private keys." | ||
22 | ), | ||
23 | - long_description_markdown_filename='README.md', | ||
24 | author='Piper Merriam', | ||
25 | author_email='pipermerriam@gmail.com', | ||
26 | url='https://github.com/ethereum/eth-keyfile', | ||
27 | include_package_data=True, | ||
28 | install_requires=install_requires, | ||
29 | extras_require=deps, | ||
30 | - setup_requires=['setuptools-markdown'], | ||
31 | py_modules=['eth_keyfile'], | ||
32 | license="MIT", | ||
33 | zip_safe=False, | ||
34 | -- | ||
35 | 2.34.1 | ||
36 | |||
diff --git a/meta-python/recipes-devtools/python/python3-eth-keyfile_0.6.0.bb b/meta-python/recipes-devtools/python/python3-eth-keyfile_0.6.0.bb new file mode 100644 index 000000000..9477632e2 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-eth-keyfile_0.6.0.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "A library for handling the encrypted keyfiles used to store ethereum private keys." | ||
2 | HOMEPAGE = "https://github.com/ethereum/eth-keyfile" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2beaef1b1764f4d6b46084c885b4bcad" | ||
6 | |||
7 | SRC_URI[sha256sum] = "d30597cdecb8ccd3b56bb275cd86fcdc7a279f86eafa92ddc49f66512f0bff67" | ||
8 | SRC_URI += "file://0001-setup-don-t-use-setuptools-markdown.patch" | ||
9 | |||
10 | inherit pypi setuptools3 | ||
11 | |||
12 | RDEPENDS:${PN} += " \ | ||
13 | python3-eth-keys \ | ||
14 | python3-pycryptodome \ | ||
15 | python3-setuptools \ | ||
16 | " | ||