diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2022-02-08 23:12:06 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-02-08 08:59:08 -0800 |
commit | 5668251a49839b6faece2387d9692886172f436e (patch) | |
tree | 9e3e7b7a2a48a0a3bf0c7c1a661a2f2d8b1cec07 | |
parent | ce1c406d6355ba0d312dce2cb60c089377d253cb (diff) | |
download | meta-openembedded-5668251a49839b6faece2387d9692886172f436e.tar.gz |
ndpi: upgrade 4.0 -> 4.2
refresh 0001-autogen.sh-not-generate-configure.patch
Changelog:
=========
New Features
-----------
Add a "confidence" field indicating the reliability of the classification
Add risk exceptions for services and domain names via ndpi_add_domain_risk_exceptions()
Add ability to report whether a protocol is encrypted
New Supported Protocols and Services
-----------------------------------
Add protocol detection for:
Badoo
Cassandra
EthernetIP
Improvements
------------
Significantly reduced memory footprint from 2.94 KB to 688 B per flow
Improve protocol detection for:
BitTorrent
ICloud Private Relay
IMAP, POP3, SMTP
Log4J/Log4Shell
Microsoft Azure
Pandora TV
RTP
RTSP
Salesforce
STUN
Whatsapp
QUICv2
Zoom
Add flow risk:
NDPI_CLEAR_TEXT_CREDENTIALS
NDPI_POSSIBLE_EXPLOIT (Log4J)
NDPI_TLS_FATAL_ALERT
NDPI_TLS_CERTIFICATE_ABOUT_TO_EXPIRE
Update WhatsAPP and Instagram addresses
Update the list of default ports for QUIC
Update WindowsUpdate URLs
Add support for the .goog Google TLD
Add googletagmanager.com
Add bitmaps and API for handling compressed bitmaps
Add JA3 in risk exceptions
Add entropy calculation to check for suspicious (encrypted) payload
Add extraction of hostname in SMTP
Add RDP over UDP dissection
Add support for TLS over IPV6 in Subject Alt Names field
Improve JSON and CSV serialization
Improve IPv6 support for almost all dissectors
Improve CI and unit tests, add arm64, armhf and s390x as part of CI
Improve WHOIS detection, reduce false positives
Improve DGA detection for skipping potential DGAs of known/popular domain names
Improve user agent analysis
Reworked HTTP protocol dissection including HTTP proxy and HTTP connect
Changes
--------
TLS obsolete protocol is set when TLS < 1.2 (used to be 1.1)
Numeric IPs are not considered for DGA checks
Differentiate between standard Amazon stuff (i.e market) and AWS
Remove Playstation VUE protocol
Remove pandora.tv from Pandora protocol
Remove outdated SoulSeek dissector
Fixes
-----
Fix race conditions
Fix dissectors to be big-endian friendly
Fix heap overflow in realloc wrapper
Fix errors in Kerberos, TLS, H323, Netbios, CSGO, Bittorrent
Fix wrong tuple comparison
Fix ndpi_serialize_string_int64
Fix Grease values parsing
Fix certificate mismatch check
Fix null-dereference read for Zattoo with IPv6
Fix dissectors initialization for XBox, Diameter
Fix confidence for STUN classifications
Fix FreeBSD support
Fix old GQUIC versions on big-endian machines
Fix aho-corasick on big-endian machines
Fix DGA false positive
Fix integer overflow for QUIC
Fix HTTP false positives
Fix SonarCloud-CI support
Fix clashes setting the hostname on similar protocols (FTP, SMTP)
Fix some invalid TLS guesses
Fix crash on ARM (Raspberry)
Fix DNS (including fragmented DNS) dissection
Fix parsing of IPv6 packets with extension headers
Fix extraction of Realm attribute in STUN
Fix support for START-TLS sessions in FTP
Fix TCP retransmissions for multiple dissectors
Fix DES initialisation
Fix Git protocol dissection
Fix certificate mismatch for TLS flows with no client hello observed
Fix old versions of GQUIC on big-endian machines
Misc
----
Add tool for generating automatically the Azure IP list
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-networking/recipes-support/ntopng/files/0001-autogen.sh-not-generate-configure.patch | 18 | ||||
-rw-r--r-- | meta-networking/recipes-support/ntopng/ndpi_4.2.bb (renamed from meta-networking/recipes-support/ntopng/ndpi_4.0.bb) | 6 |
2 files changed, 11 insertions, 13 deletions
diff --git a/meta-networking/recipes-support/ntopng/files/0001-autogen.sh-not-generate-configure.patch b/meta-networking/recipes-support/ntopng/files/0001-autogen.sh-not-generate-configure.patch index 1cbf059ef..d5c7f5f1c 100644 --- a/meta-networking/recipes-support/ntopng/files/0001-autogen.sh-not-generate-configure.patch +++ b/meta-networking/recipes-support/ntopng/files/0001-autogen.sh-not-generate-configure.patch | |||
@@ -12,26 +12,24 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | |||
12 | refresh patch to 4.0 | 12 | refresh patch to 4.0 |
13 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | 13 | Signed-off-by: Changqing Li <changqing.li@windriver.com> |
14 | --- | 14 | --- |
15 | autogen.sh | 9 --------- | 15 | autogen.sh | 7 ------- |
16 | 1 file changed, 9 deletions(-) | 16 | 1 file changed, 7 deletions(-) |
17 | 17 | ||
18 | diff --git a/autogen.sh b/autogen.sh | 18 | diff --git a/autogen.sh b/autogen.sh |
19 | index cf5d7057..cb73cf9d 100755 | 19 | index 0aa7507..36e0423 100755 |
20 | --- a/autogen.sh | 20 | --- a/autogen.sh |
21 | +++ b/autogen.sh | 21 | +++ b/autogen.sh |
22 | @@ -52,12 +52,3 @@ cat configure.seed | sed \ | 22 | @@ -33,10 +33,3 @@ if test -z $PKG_CONFIG; then |
23 | -e "s/@NDPI_VERSION_SHORT@/$NDPI_VERSION_SHORT/g" \ | 23 | echo "pkg-config is missing: please install it (apt-get install pkg-config) and try again" |
24 | -e "s/@FUZZY@/$FUZZY/g" \ | 24 | exit |
25 | > configure.ac | 25 | fi |
26 | - | 26 | - |
27 | -autoreconf -ivf | 27 | -autoreconf -ivf |
28 | -cat configure | sed "s/#define PACKAGE/#define NDPI_PACKAGE/g" | sed "s/#define VERSION/#define NDPI_VERSION/g" > configure.tmp | ||
29 | -cat configure.tmp > configure | ||
30 | - | 28 | - |
31 | -echo "./configure $@" | 29 | -echo "./configure $@" |
32 | -chmod +x configure | 30 | -chmod +x configure |
33 | -./configure $@ | 31 | -./configure $@ |
34 | - | 32 | - |
35 | -- | 33 | -- |
36 | 2.17.1 | 34 | 2.25.1 |
37 | 35 | ||
diff --git a/meta-networking/recipes-support/ntopng/ndpi_4.0.bb b/meta-networking/recipes-support/ntopng/ndpi_4.2.bb index 960c4c201..352d2d242 100644 --- a/meta-networking/recipes-support/ntopng/ndpi_4.0.bb +++ b/meta-networking/recipes-support/ntopng/ndpi_4.2.bb | |||
@@ -8,10 +8,10 @@ RDEPENDS:${PN} += " libpcap" | |||
8 | LICENSE = "GPLv3" | 8 | LICENSE = "GPLv3" |
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=b52f2d57d10c4f7ee67a7eb9615d5d24" | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=b52f2d57d10c4f7ee67a7eb9615d5d24" |
10 | 10 | ||
11 | SRCREV = "dabab0e9515c2e6a71a91bdc807453e416f831ca" | 11 | SRCREV = "8b5c6af71b562549f8416b31803daae223e09f46" |
12 | SRC_URI = "git://github.com/ntop/nDPI.git;branch=4.0-stable;protocol=https \ | 12 | SRC_URI = "git://github.com/ntop/nDPI.git;branch=4.2-stable;protocol=https \ |
13 | file://0001-autogen.sh-not-generate-configure.patch \ | 13 | file://0001-autogen.sh-not-generate-configure.patch \ |
14 | " | 14 | " |
15 | 15 | ||
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | 17 | ||