diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-09-01 13:03:53 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-05 22:49:34 -0700 |
commit | 51f257ab99b43193056f6e893b01d60f30f7f5f1 (patch) | |
tree | 65d2d613aeb44304a8b62294ed2a1bdd12e2cdb1 | |
parent | f4c9e27b32e419ffdbe4e89df6741fe102f7a3d3 (diff) | |
download | meta-openembedded-51f257ab99b43193056f6e893b01d60f30f7f5f1.tar.gz |
epeg: Fix AC_CHECK_LIB for libjpeg and libexif
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/epeg/epeg/0001-configure-Fix-checks-for-libjpeg-and-libexif.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-support/epeg/epeg_git.bb | 4 |
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/epeg/epeg/0001-configure-Fix-checks-for-libjpeg-and-libexif.patch b/meta-oe/recipes-support/epeg/epeg/0001-configure-Fix-checks-for-libjpeg-and-libexif.patch new file mode 100644 index 000000000..1568fe96e --- /dev/null +++ b/meta-oe/recipes-support/epeg/epeg/0001-configure-Fix-checks-for-libjpeg-and-libexif.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 4e0c62634b0db6dbad0d41377bb71a8012abd75b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 1 Sep 2022 12:56:54 -0700 | ||
4 | Subject: [PATCH] configure: Fix checks for libjpeg and libexif | ||
5 | |||
6 | Use the functions from the respective library instead of using main | ||
7 | function which is not part of library | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/mattes/epeg/pull/27] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | configure.ac | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/configure.ac b/configure.ac | ||
16 | index a4f6ebd..e474b1d 100644 | ||
17 | --- a/configure.ac | ||
18 | +++ b/configure.ac | ||
19 | @@ -31,8 +31,8 @@ AC_SUBST(version_info) | ||
20 | dnl AC_CHECK_FUNCS(fmemopen) | ||
21 | dnl AC_CHECK_FUNCS(open_memstream) | ||
22 | |||
23 | -AC_CHECK_LIB([jpeg], [main], [], [echo "libjpeg library not found. Please install it before proceeding"; exit -1]) | ||
24 | -AC_CHECK_LIB([exif], [main], [], [echo "libexif library not found. Please install it before proceeding"; exit -1]) | ||
25 | +AC_CHECK_LIB([jpeg], [jpeg_simple_progression], [], [echo "libjpeg library not found. Please install it before proceeding"; exit -1]) | ||
26 | +AC_CHECK_LIB([exif], [exif_data_new_from_file], [], [echo "libexif library not found. Please install it before proceeding"; exit -1]) | ||
27 | |||
28 | my_includes="" | ||
29 | my_libs="-ljpeg -lexif" | ||
30 | -- | ||
31 | 2.37.3 | ||
32 | |||
diff --git a/meta-oe/recipes-support/epeg/epeg_git.bb b/meta-oe/recipes-support/epeg/epeg_git.bb index bdffe4ba7..e5277b157 100644 --- a/meta-oe/recipes-support/epeg/epeg_git.bb +++ b/meta-oe/recipes-support/epeg/epeg_git.bb | |||
@@ -5,7 +5,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e7732a9290ea1e4b034fdc15cf49968d \ | |||
5 | file://COPYING-PLAIN;md5=f59cacc08235a546b0c34a5422133035" | 5 | file://COPYING-PLAIN;md5=f59cacc08235a546b0c34a5422133035" |
6 | DEPENDS = "jpeg libexif" | 6 | DEPENDS = "jpeg libexif" |
7 | 7 | ||
8 | SRC_URI = "git://github.com/mattes/epeg.git;branch=master;protocol=https" | 8 | SRC_URI = "git://github.com/mattes/epeg.git;branch=master;protocol=https \ |
9 | file://0001-configure-Fix-checks-for-libjpeg-and-libexif.patch \ | ||
10 | " | ||
9 | SRCREV = "9a175cd67eaa61fe45413d8da82da72936567047" | 11 | SRCREV = "9a175cd67eaa61fe45413d8da82da72936567047" |
10 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
11 | 13 | ||