summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuðni Már Gilbert <gudnimar@noxmedical.com>2024-04-22 21:00:12 +0000
committerKhem Raj <raj.khem@gmail.com>2024-04-22 22:59:32 -0700
commit48eba8d03f74c15f11fd6fcb24d9d8313e4c5ba9 (patch)
tree75b277eb4afb233c5f6f036cc90bd9e573b45f4d
parente64e959875bc9bc20e63368901ef905831c368fe (diff)
downloadmeta-openembedded-48eba8d03f74c15f11fd6fcb24d9d8313e4c5ba9.tar.gz
python3-twisted: upgrade 22.10.0 -> 24.3.0
Changelogs between 22.10.0 and 24.3.0 can be found here: https://github.com/twisted/twisted/releases/tag/twisted-24.3.0 https://github.com/twisted/twisted/releases/tag/twisted-23.10.0 https://github.com/twisted/twisted/releases/tag/twisted-23.8.0 Summary of changes relevant for the Yocto build: - Brings official support for Python 3.11 and 3.12, only Python 3.8 and above supported. - python3-twisted-conch: python3-pyasn1 is no longer a runtime dependency (23.8.0) - build backend changed from setuptools.build_meta to hatchling.build Signed-off-by: Guðni Már Gilbert <gudnimar@noxmedical.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_24.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-twisted_22.10.0.bb)21
1 files changed, 7 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twisted_22.10.0.bb b/meta-python/recipes-devtools/python/python3-twisted_24.3.0.bb
index 20b9ce254..e5223ccd6 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_22.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_24.3.0.bb
@@ -1,16 +1,14 @@
1DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \ 1DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \ 2Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more." 3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4HOMEPAGE = "http://www.twistedmatrix.com" 4HOMEPAGE = "https://twisted.org"
5 5
6LICENSE = "MIT" 6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=0f8d67f84b6e178c92d471011b2245fc" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=c1c5d2c2493b848f83864bdedd67bbf5"
8 8
9SRC_URI[sha256sum] = "32acbd40a94f5f46e7b42c109bfae2b302250945561783a8b7a059048f2d4d31" 9SRC_URI[sha256sum] = "6b38b6ece7296b5e122c9eb17da2eeab3d98a198f50ca9efd00fb03e5b4fd4ae"
10 10
11PYPI_PACKAGE = "Twisted" 11inherit pypi python_hatchling
12
13inherit pypi python_setuptools_build_meta
14 12
15do_install:append() { 13do_install:append() {
16 # remove some useless files before packaging 14 # remove some useless files before packaging
@@ -34,6 +32,7 @@ PACKAGES += "\
34" 32"
35 33
36DEPENDS += " \ 34DEPENDS += " \
35 python3-hatch-fancy-pypi-readme-native \
37 python3-incremental-native \ 36 python3-incremental-native \
38" 37"
39 38
@@ -58,14 +57,13 @@ RDEPENDS:${PN}-core = "python3-appdirs \
58 python3-debugger \ 57 python3-debugger \
59 python3-hyperlink \ 58 python3-hyperlink \
60 python3-incremental \ 59 python3-incremental \
61 python3-pyhamcrest \
62 python3-pyserial \ 60 python3-pyserial \
63 python3-typing-extensions \ 61 python3-typing-extensions \
64 python3-unixadmin \ 62 python3-unixadmin \
65 python3-zopeinterface \ 63 python3-zopeinterface \
66" 64"
67RDEPENDS:${PN}-test = "${PN}" 65RDEPENDS:${PN}-test = "${PN} python3-pyhamcrest"
68RDEPENDS:${PN}-conch = "${PN}-core ${PN}-protocols python3-bcrypt python3-cryptography python3-pyasn1 python3-pickle" 66RDEPENDS:${PN}-conch = "${PN}-core ${PN}-protocols python3-bcrypt python3-cryptography python3-pickle"
69RDEPENDS:${PN}-mail = "${PN}-core ${PN}-protocols" 67RDEPENDS:${PN}-mail = "${PN}-core ${PN}-protocols"
70RDEPENDS:${PN}-names = "${PN}-core" 68RDEPENDS:${PN}-names = "${PN}-core"
71RDEPENDS:${PN}-news = "${PN}-core ${PN}-protocols" 69RDEPENDS:${PN}-news = "${PN}-core ${PN}-protocols"
@@ -75,8 +73,6 @@ RDEPENDS:${PN}-words += "${PN}-core"
75RDEPENDS:${PN}-flow += "${PN}-core" 73RDEPENDS:${PN}-flow += "${PN}-core"
76RDEPENDS:${PN}-pair += "${PN}-core" 74RDEPENDS:${PN}-pair += "${PN}-core"
77 75
78FILES:${PN} = "${PYTHON_SITEPACKAGES_DIR}/${PYPI_PACKAGE}-${PV}.dist-info/*"
79
80FILES:${PN}-test = " \ 76FILES:${PN}-test = " \
81 ${PYTHON_SITEPACKAGES_DIR}/twisted/test \ 77 ${PYTHON_SITEPACKAGES_DIR}/twisted/test \
82 ${PYTHON_SITEPACKAGES_DIR}/twisted/*/test \ 78 ${PYTHON_SITEPACKAGES_DIR}/twisted/*/test \
@@ -85,8 +81,6 @@ FILES:${PN}-test = " \
85 81
86FILES:${PN}-protocols = " \ 82FILES:${PN}-protocols = " \
87 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/*.py* \ 83 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/*.py* \
88 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/gps/ \
89 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/mice/ \
90 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/haproxy \ 84 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/haproxy \
91 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/__pycache__/*pyc \ 85 ${PYTHON_SITEPACKAGES_DIR}/twisted/protocols/__pycache__/*pyc \
92" 86"
@@ -124,7 +118,6 @@ FILES:${PN}-core = " \
124 ${PYTHON_SITEPACKAGES_DIR}/twisted/*.py* \ 118 ${PYTHON_SITEPACKAGES_DIR}/twisted/*.py* \
125 ${PYTHON_SITEPACKAGES_DIR}/twisted/python/*.py* \ 119 ${PYTHON_SITEPACKAGES_DIR}/twisted/python/*.py* \
126 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/*.py* \ 120 ${PYTHON_SITEPACKAGES_DIR}/twisted/plugins/*.py* \
127 ${PYTHON_SITEPACKAGES_DIR}/Twisted*egg-info \
128 ${PYTHON_SITEPACKAGES_DIR}/twisted/logger \ 121 ${PYTHON_SITEPACKAGES_DIR}/twisted/logger \
129 ${PYTHON_SITEPACKAGES_DIR}/twisted/_threads \ 122 ${PYTHON_SITEPACKAGES_DIR}/twisted/_threads \
130 ${PYTHON_SITEPACKAGES_DIR}/twisted/positioning \ 123 ${PYTHON_SITEPACKAGES_DIR}/twisted/positioning \