diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-12-31 19:28:04 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-02 09:40:24 -0800 |
commit | 48d782ed033b93748d916cd1839460fdd8a112f2 (patch) | |
tree | 0ab0221e2132abd6ab622401b4df8353b34d6be6 | |
parent | ea69b5d5bbf660fc12cd727a05f030d4473d7d5d (diff) | |
download | meta-openembedded-48d782ed033b93748d916cd1839460fdd8a112f2.tar.gz |
hddtemp: Fix build with latest gettext 0.20.x
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/hddtemp/hddtemp/0001-configure.ac-Rename-to-configure.ac-and-use-external.patch | 703 | ||||
-rw-r--r-- | meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb | 1 |
2 files changed, 704 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/hddtemp/hddtemp/0001-configure.ac-Rename-to-configure.ac-and-use-external.patch b/meta-oe/recipes-support/hddtemp/hddtemp/0001-configure.ac-Rename-to-configure.ac-and-use-external.patch new file mode 100644 index 000000000..d2de0bbe6 --- /dev/null +++ b/meta-oe/recipes-support/hddtemp/hddtemp/0001-configure.ac-Rename-to-configure.ac-and-use-external.patch | |||
@@ -0,0 +1,703 @@ | |||
1 | From d7e6fe2ac69333c2d943a4b8eb139373d1fb2ce2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 31 Dec 2019 18:08:09 -0800 | ||
4 | Subject: [PATCH] configure.ac: Rename to configure.ac and use external gettext | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | configure.ac | 81 ++++++++++++++++++++++++++++++++++++++++++++++++++++ | ||
10 | 1 file changed, 81 insertions(+) | ||
11 | create mode 100644 configure.ac | ||
12 | |||
13 | --- /dev/null | ||
14 | +++ b/configure.ac | ||
15 | @@ -0,0 +1,81 @@ | ||
16 | +dnl Process this file with autoconf to produce a configure script. | ||
17 | + | ||
18 | +# Initialization | ||
19 | +AC_INIT | ||
20 | +AC_CONFIG_SRCDIR([Makefile.am]) | ||
21 | +AC_CONFIG_HEADERS([config.h]) | ||
22 | + | ||
23 | +# Determine the host and build type. The target is always a PIC. | ||
24 | +AC_CANONICAL_HOST | ||
25 | + | ||
26 | +AM_INIT_AUTOMAKE(hddtemp, 0.3-beta15) | ||
27 | + | ||
28 | +dnl Checks for programs. | ||
29 | +AC_PROG_CC | ||
30 | +AC_PROG_INSTALL | ||
31 | + | ||
32 | +# append the host alias to the tools for cross compiling | ||
33 | +AC_HEADER_STDC | ||
34 | +AC_CHECK_HEADERS(fcntl.h) | ||
35 | +AC_CHECK_HEADERS(iconv.h) | ||
36 | +AC_CHECK_HEADERS(netinet/in.h) | ||
37 | +AC_CHECK_TYPE(in_addr_t, ,[AC_DEFINE_UNQUOTED([in_addr_t], [uint32_t], [Define to 'uint32_t' if <netinet/in.h> does not define.])], [#include <netinet/in.h>]) | ||
38 | + | ||
39 | +# Checks for typedefs, structures, and compiler characteristics. | ||
40 | +AC_C_CONST | ||
41 | +AC_STRUCT_TM | ||
42 | + | ||
43 | +dnl internationalization macros | ||
44 | +AM_GNU_GETTEXT([external]) | ||
45 | + | ||
46 | +AC_CHECK_FUNCS([bindtextdomain textdomain iconv]) | ||
47 | + | ||
48 | +dnl reasonable guesses for where stuff is installed | ||
49 | +dnl if we don't do that now, the config.h will use ${prefix} | ||
50 | +dnl for DEFAULT_DATABASE_PATH. | ||
51 | +if test "x$prefix" = "xNONE"; then | ||
52 | + prefix="/usr/local" | ||
53 | +fi | ||
54 | +if test "x$exec_prefix" = "xNONE"; then | ||
55 | + exec_prefix=$prefix | ||
56 | +fi | ||
57 | + | ||
58 | +AC_MSG_CHECKING([Location of hddtemp.db]) | ||
59 | +DEFAULT_DATABASE_PATH= | ||
60 | +#db_path=\"`eval echo ${datadir}`/misc/hddtemp.db\" | ||
61 | +db_path=\"/usr/share/misc/hddtemp.db\" | ||
62 | +AC_ARG_WITH(db_path, | ||
63 | + [ --with-db-path=PATH \ | ||
64 | + Default location of hddtemp.db file [/usr/share/misc/hddtemp.db]], | ||
65 | + [ if test -d "$withval"; then | ||
66 | + AC_MSG_FAILURE([new file name for db-path]) | ||
67 | + fi | ||
68 | + DEFAULT_DATABASE_PATH="\"$withval\"" | ||
69 | + ], | ||
70 | + [ DEFAULT_DATABASE_PATH="$db_path" ]) | ||
71 | +AC_MSG_RESULT($DEFAULT_DATABASE_PATH) | ||
72 | +AC_DEFINE_UNQUOTED([DEFAULT_DATABASE_PATH], [$DEFAULT_DATABASE_PATH], [Default location of drive info database]) | ||
73 | + | ||
74 | +#CFLAGS="$CFLAGS -Wall -fomit-frame-pointer -Wcast-align" | ||
75 | +CFLAGS="$CFLAGS -Wall -W -Wcast-align" | ||
76 | + | ||
77 | +# Substitute configuration variables | ||
78 | +AC_CONFIG_FILES([Makefile \ | ||
79 | +po/Makefile.in \ | ||
80 | +m4/Makefile \ | ||
81 | +src/Makefile \ | ||
82 | +doc/Makefile \ | ||
83 | +]) | ||
84 | +AC_OUTPUT | ||
85 | + | ||
86 | +AC_MSG_RESULT([ | ||
87 | + | ||
88 | +hddtemp-$VERSION is now configured for $canonical_host_type | ||
89 | + | ||
90 | + Build: $build | ||
91 | + Host: $host | ||
92 | + Source directory: $srcdir | ||
93 | + Installation prefix: $prefix | ||
94 | + C compiler: $CC $CFLAGS | ||
95 | + | ||
96 | +]) | ||
97 | --- a/Makefile.am | ||
98 | +++ b/Makefile.am | ||
99 | @@ -12,7 +12,7 @@ EXTRA_DIST = config.rpath autogen.sh \ | ||
100 | README \ | ||
101 | TODO | ||
102 | |||
103 | -SUBDIRS = intl po m4 src doc | ||
104 | +SUBDIRS = po m4 src doc | ||
105 | |||
106 | CLEANFILES = *~ | ||
107 | |||
108 | --- a/configure.in | ||
109 | +++ /dev/null | ||
110 | @@ -1,83 +0,0 @@ | ||
111 | -dnl Process this file with autoconf to produce a configure script. | ||
112 | - | ||
113 | -# Initialization | ||
114 | -AC_INIT | ||
115 | -AC_CONFIG_SRCDIR([Makefile.am]) | ||
116 | -AC_CONFIG_HEADERS([config.h]) | ||
117 | - | ||
118 | -# Determine the host and build type. The target is always a PIC. | ||
119 | -AC_CANONICAL_HOST | ||
120 | - | ||
121 | -AM_INIT_AUTOMAKE(hddtemp, 0.3-beta15) | ||
122 | - | ||
123 | -dnl Checks for programs. | ||
124 | -AC_PROG_CC | ||
125 | -AC_PROG_INSTALL | ||
126 | - | ||
127 | -# append the host alias to the tools for cross compiling | ||
128 | -AC_HEADER_STDC | ||
129 | -AC_CHECK_HEADERS(fcntl.h) | ||
130 | -AC_CHECK_HEADERS(iconv.h) | ||
131 | -AC_CHECK_HEADERS(netinet/in.h) | ||
132 | -AC_CHECK_TYPE(in_addr_t, ,[AC_DEFINE_UNQUOTED([in_addr_t], [uint32_t], [Define to 'uint32_t' if <netinet/in.h> does not define.])], [#include <netinet/in.h>]) | ||
133 | - | ||
134 | -# Checks for typedefs, structures, and compiler characteristics. | ||
135 | -AC_C_CONST | ||
136 | -AC_STRUCT_TM | ||
137 | - | ||
138 | -dnl internationalization macros | ||
139 | -AM_GNU_GETTEXT_VERSION | ||
140 | -AM_GNU_GETTEXT | ||
141 | -#AM_GNU_GETTEXT([external]) | ||
142 | - | ||
143 | -AC_CHECK_FUNCS([bindtextdomain textdomain iconv]) | ||
144 | - | ||
145 | -dnl reasonable guesses for where stuff is installed | ||
146 | -dnl if we don't do that now, the config.h will use ${prefix} | ||
147 | -dnl for DEFAULT_DATABASE_PATH. | ||
148 | -if test "x$prefix" = "xNONE"; then | ||
149 | - prefix="/usr/local" | ||
150 | -fi | ||
151 | -if test "x$exec_prefix" = "xNONE"; then | ||
152 | - exec_prefix=$prefix | ||
153 | -fi | ||
154 | - | ||
155 | -AC_MSG_CHECKING([Location of hddtemp.db]) | ||
156 | -DEFAULT_DATABASE_PATH= | ||
157 | -#db_path=\"`eval echo ${datadir}`/misc/hddtemp.db\" | ||
158 | -db_path=\"/usr/share/misc/hddtemp.db\" | ||
159 | -AC_ARG_WITH(db_path, | ||
160 | - [ --with-db-path=PATH \ | ||
161 | - Default location of hddtemp.db file [/usr/share/misc/hddtemp.db]], | ||
162 | - [ if test -d "$withval"; then | ||
163 | - AC_MSG_FAILURE([new file name for db-path]) | ||
164 | - fi | ||
165 | - DEFAULT_DATABASE_PATH="\"$withval\"" | ||
166 | - ], | ||
167 | - [ DEFAULT_DATABASE_PATH="$db_path" ]) | ||
168 | -AC_MSG_RESULT($DEFAULT_DATABASE_PATH) | ||
169 | -AC_DEFINE_UNQUOTED([DEFAULT_DATABASE_PATH], [$DEFAULT_DATABASE_PATH], [Default location of drive info database]) | ||
170 | - | ||
171 | -#CFLAGS="$CFLAGS -Wall -fomit-frame-pointer -Wcast-align" | ||
172 | -CFLAGS="$CFLAGS -Wall -W -Wcast-align" | ||
173 | - | ||
174 | -# Substitute configuration variables | ||
175 | -AC_CONFIG_FILES([Makefile intl/Makefile \ | ||
176 | -po/Makefile.in \ | ||
177 | -m4/Makefile \ | ||
178 | -src/Makefile \ | ||
179 | -doc/Makefile \ | ||
180 | -]) | ||
181 | -AC_OUTPUT | ||
182 | - | ||
183 | -AC_MSG_RESULT([ | ||
184 | - | ||
185 | -hddtemp-$VERSION is now configured for $canonical_host_type | ||
186 | - | ||
187 | - Build: $build | ||
188 | - Host: $host | ||
189 | - Source directory: $srcdir | ||
190 | - Installation prefix: $prefix | ||
191 | - C compiler: $CC $CFLAGS | ||
192 | - | ||
193 | -]) | ||
194 | --- a/intl/ChangeLog | ||
195 | +++ /dev/null | ||
196 | @@ -1,4 +0,0 @@ | ||
197 | -2005-02-24 GNU <bug-gnu-gettext@gnu.org> | ||
198 | - | ||
199 | - * Version 0.14.2 released. | ||
200 | - | ||
201 | --- a/intl/Makefile.in | ||
202 | +++ /dev/null | ||
203 | @@ -1,500 +0,0 @@ | ||
204 | -# Makefile for directory with message catalog handling library of GNU gettext | ||
205 | -# Copyright (C) 1995-1998, 2000-2005 Free Software Foundation, Inc. | ||
206 | -# | ||
207 | -# This program is free software; you can redistribute it and/or modify it | ||
208 | -# under the terms of the GNU Library General Public License as published | ||
209 | -# by the Free Software Foundation; either version 2, or (at your option) | ||
210 | -# any later version. | ||
211 | -# | ||
212 | -# This program is distributed in the hope that it will be useful, | ||
213 | -# but WITHOUT ANY WARRANTY; without even the implied warranty of | ||
214 | -# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU | ||
215 | -# Library General Public License for more details. | ||
216 | -# | ||
217 | -# You should have received a copy of the GNU Library General Public | ||
218 | -# License along with this program; if not, write to the Free Software | ||
219 | -# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, | ||
220 | -# USA. | ||
221 | - | ||
222 | -PACKAGE = @PACKAGE@ | ||
223 | -VERSION = @VERSION@ | ||
224 | - | ||
225 | -SHELL = /bin/sh | ||
226 | - | ||
227 | -srcdir = @srcdir@ | ||
228 | -top_srcdir = @top_srcdir@ | ||
229 | -top_builddir = .. | ||
230 | -VPATH = $(srcdir) | ||
231 | - | ||
232 | -prefix = @prefix@ | ||
233 | -exec_prefix = @exec_prefix@ | ||
234 | -transform = @program_transform_name@ | ||
235 | -libdir = @libdir@ | ||
236 | -includedir = @includedir@ | ||
237 | -datadir = @datadir@ | ||
238 | -localedir = $(datadir)/locale | ||
239 | -gettextsrcdir = $(datadir)/gettext/intl | ||
240 | -aliaspath = $(localedir) | ||
241 | -subdir = intl | ||
242 | - | ||
243 | -INSTALL = @INSTALL@ | ||
244 | -INSTALL_DATA = @INSTALL_DATA@ | ||
245 | -MKINSTALLDIRS = @MKINSTALLDIRS@ | ||
246 | -mkinstalldirs = $(SHELL) $(MKINSTALLDIRS) | ||
247 | - | ||
248 | -l = @INTL_LIBTOOL_SUFFIX_PREFIX@ | ||
249 | - | ||
250 | -AR = ar | ||
251 | -CC = @CC@ | ||
252 | -LIBTOOL = @LIBTOOL@ | ||
253 | -RANLIB = @RANLIB@ | ||
254 | -YACC = @INTLBISON@ -y -d | ||
255 | -YFLAGS = --name-prefix=__gettext | ||
256 | - | ||
257 | -DEFS = -DLOCALEDIR=\"$(localedir)\" -DLOCALE_ALIAS_PATH=\"$(aliaspath)\" \ | ||
258 | --DLIBDIR=\"$(libdir)\" -DIN_LIBINTL \ | ||
259 | --DENABLE_RELOCATABLE=1 -DIN_LIBRARY -DINSTALLDIR=\"$(libdir)\" -DNO_XMALLOC \ | ||
260 | --Dset_relocation_prefix=libintl_set_relocation_prefix \ | ||
261 | --Drelocate=libintl_relocate \ | ||
262 | --DDEPENDS_ON_LIBICONV=1 @DEFS@ | ||
263 | -CPPFLAGS = @CPPFLAGS@ | ||
264 | -CFLAGS = @CFLAGS@ | ||
265 | -LDFLAGS = @LDFLAGS@ | ||
266 | -LIBS = @LIBS@ | ||
267 | - | ||
268 | -COMPILE = $(CC) -c $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS) | ||
269 | - | ||
270 | -HEADERS = \ | ||
271 | - gmo.h \ | ||
272 | - gettextP.h \ | ||
273 | - hash-string.h \ | ||
274 | - loadinfo.h \ | ||
275 | - plural-exp.h \ | ||
276 | - eval-plural.h \ | ||
277 | - localcharset.h \ | ||
278 | - relocatable.h \ | ||
279 | - xsize.h \ | ||
280 | - printf-args.h printf-args.c \ | ||
281 | - printf-parse.h wprintf-parse.h printf-parse.c \ | ||
282 | - vasnprintf.h vasnwprintf.h vasnprintf.c \ | ||
283 | - os2compat.h \ | ||
284 | - libgnuintl.h.in | ||
285 | -SOURCES = \ | ||
286 | - bindtextdom.c \ | ||
287 | - dcgettext.c \ | ||
288 | - dgettext.c \ | ||
289 | - gettext.c \ | ||
290 | - finddomain.c \ | ||
291 | - loadmsgcat.c \ | ||
292 | - localealias.c \ | ||
293 | - textdomain.c \ | ||
294 | - l10nflist.c \ | ||
295 | - explodename.c \ | ||
296 | - dcigettext.c \ | ||
297 | - dcngettext.c \ | ||
298 | - dngettext.c \ | ||
299 | - ngettext.c \ | ||
300 | - plural.y \ | ||
301 | - plural-exp.c \ | ||
302 | - localcharset.c \ | ||
303 | - relocatable.c \ | ||
304 | - langprefs.c \ | ||
305 | - localename.c \ | ||
306 | - log.c \ | ||
307 | - printf.c \ | ||
308 | - osdep.c \ | ||
309 | - os2compat.c \ | ||
310 | - intl-compat.c | ||
311 | -OBJECTS = \ | ||
312 | - bindtextdom.$lo \ | ||
313 | - dcgettext.$lo \ | ||
314 | - dgettext.$lo \ | ||
315 | - gettext.$lo \ | ||
316 | - finddomain.$lo \ | ||
317 | - loadmsgcat.$lo \ | ||
318 | - localealias.$lo \ | ||
319 | - textdomain.$lo \ | ||
320 | - l10nflist.$lo \ | ||
321 | - explodename.$lo \ | ||
322 | - dcigettext.$lo \ | ||
323 | - dcngettext.$lo \ | ||
324 | - dngettext.$lo \ | ||
325 | - ngettext.$lo \ | ||
326 | - plural.$lo \ | ||
327 | - plural-exp.$lo \ | ||
328 | - localcharset.$lo \ | ||
329 | - relocatable.$lo \ | ||
330 | - langprefs.$lo \ | ||
331 | - localename.$lo \ | ||
332 | - log.$lo \ | ||
333 | - printf.$lo \ | ||
334 | - osdep.$lo \ | ||
335 | - intl-compat.$lo | ||
336 | -DISTFILES.common = Makefile.in \ | ||
337 | -config.charset locale.alias ref-add.sin ref-del.sin $(HEADERS) $(SOURCES) | ||
338 | -DISTFILES.generated = plural.c | ||
339 | -DISTFILES.normal = VERSION | ||
340 | -DISTFILES.gettext = COPYING.LIB-2.0 COPYING.LIB-2.1 libintl.glibc \ | ||
341 | -libgnuintl.h_vms Makefile.vms \ | ||
342 | -libgnuintl.h.msvc-static libgnuintl.h.msvc-shared README.woe32 Makefile.msvc | ||
343 | -DISTFILES.obsolete = xopen-msg.sed linux-msg.sed po2tbl.sed.in cat-compat.c \ | ||
344 | -COPYING.LIB-2 gettext.h libgettext.h plural-eval.c libgnuintl.h | ||
345 | - | ||
346 | -all: all-@USE_INCLUDED_LIBINTL@ | ||
347 | -all-yes: libintl.$la libintl.h charset.alias ref-add.sed ref-del.sed | ||
348 | -all-no: all-no-@BUILD_INCLUDED_LIBINTL@ | ||
349 | -all-no-yes: libgnuintl.$la | ||
350 | -all-no-no: | ||
351 | - | ||
352 | -libintl.a libgnuintl.a: $(OBJECTS) | ||
353 | - rm -f $@ | ||
354 | - $(AR) cru $@ $(OBJECTS) | ||
355 | - $(RANLIB) $@ | ||
356 | - | ||
357 | -libintl.la libgnuintl.la: $(OBJECTS) | ||
358 | - $(LIBTOOL) --mode=link \ | ||
359 | - $(CC) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS) $(LDFLAGS) -o $@ \ | ||
360 | - $(OBJECTS) @LTLIBICONV@ @INTL_MACOSX_LIBS@ $(LIBS) -lc \ | ||
361 | - -version-info $(LTV_CURRENT):$(LTV_REVISION):$(LTV_AGE) \ | ||
362 | - -rpath $(libdir) \ | ||
363 | - -no-undefined | ||
364 | - | ||
365 | -# Libtool's library version information for libintl. | ||
366 | -# Before making a gettext release, the gettext maintainer must change this | ||
367 | -# according to the libtool documentation, section "Library interface versions". | ||
368 | -# Maintainers of other packages that include the intl directory must *not* | ||
369 | -# change these values. | ||
370 | -LTV_CURRENT=7 | ||
371 | -LTV_REVISION=1 | ||
372 | -LTV_AGE=4 | ||
373 | - | ||
374 | -.SUFFIXES: | ||
375 | -.SUFFIXES: .c .y .o .lo .sin .sed | ||
376 | - | ||
377 | -.c.o: | ||
378 | - $(COMPILE) $< | ||
379 | - | ||
380 | -.y.c: | ||
381 | - $(YACC) $(YFLAGS) --output $@ $< | ||
382 | - rm -f $*.h | ||
383 | - | ||
384 | -bindtextdom.lo: $(srcdir)/bindtextdom.c | ||
385 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/bindtextdom.c | ||
386 | -dcgettext.lo: $(srcdir)/dcgettext.c | ||
387 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dcgettext.c | ||
388 | -dgettext.lo: $(srcdir)/dgettext.c | ||
389 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dgettext.c | ||
390 | -gettext.lo: $(srcdir)/gettext.c | ||
391 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/gettext.c | ||
392 | -finddomain.lo: $(srcdir)/finddomain.c | ||
393 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/finddomain.c | ||
394 | -loadmsgcat.lo: $(srcdir)/loadmsgcat.c | ||
395 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/loadmsgcat.c | ||
396 | -localealias.lo: $(srcdir)/localealias.c | ||
397 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/localealias.c | ||
398 | -textdomain.lo: $(srcdir)/textdomain.c | ||
399 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/textdomain.c | ||
400 | -l10nflist.lo: $(srcdir)/l10nflist.c | ||
401 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/l10nflist.c | ||
402 | -explodename.lo: $(srcdir)/explodename.c | ||
403 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/explodename.c | ||
404 | -dcigettext.lo: $(srcdir)/dcigettext.c | ||
405 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dcigettext.c | ||
406 | -dcngettext.lo: $(srcdir)/dcngettext.c | ||
407 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dcngettext.c | ||
408 | -dngettext.lo: $(srcdir)/dngettext.c | ||
409 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dngettext.c | ||
410 | -ngettext.lo: $(srcdir)/ngettext.c | ||
411 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/ngettext.c | ||
412 | -plural.lo: $(srcdir)/plural.c | ||
413 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/plural.c | ||
414 | -plural-exp.lo: $(srcdir)/plural-exp.c | ||
415 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/plural-exp.c | ||
416 | -localcharset.lo: $(srcdir)/localcharset.c | ||
417 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/localcharset.c | ||
418 | -relocatable.lo: $(srcdir)/relocatable.c | ||
419 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/relocatable.c | ||
420 | -langprefs.lo: $(srcdir)/langprefs.c | ||
421 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/langprefs.c | ||
422 | -localename.lo: $(srcdir)/localename.c | ||
423 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/localename.c | ||
424 | -log.lo: $(srcdir)/log.c | ||
425 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/log.c | ||
426 | -printf.lo: $(srcdir)/printf.c | ||
427 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/printf.c | ||
428 | -osdep.lo: $(srcdir)/osdep.c | ||
429 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/osdep.c | ||
430 | -intl-compat.lo: $(srcdir)/intl-compat.c | ||
431 | - $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/intl-compat.c | ||
432 | - | ||
433 | -ref-add.sed: $(srcdir)/ref-add.sin | ||
434 | - sed -e '/^#/d' -e 's/@''PACKAGE''@/@PACKAGE@/g' $(srcdir)/ref-add.sin > t-ref-add.sed | ||
435 | - mv t-ref-add.sed ref-add.sed | ||
436 | -ref-del.sed: $(srcdir)/ref-del.sin | ||
437 | - sed -e '/^#/d' -e 's/@''PACKAGE''@/@PACKAGE@/g' $(srcdir)/ref-del.sin > t-ref-del.sed | ||
438 | - mv t-ref-del.sed ref-del.sed | ||
439 | - | ||
440 | -INCLUDES = -I. -I$(srcdir) -I.. | ||
441 | - | ||
442 | -libgnuintl.h: $(srcdir)/libgnuintl.h.in | ||
443 | - sed -e 's,@''HAVE_POSIX_PRINTF''@,@HAVE_POSIX_PRINTF@,g' \ | ||
444 | - -e 's,@''HAVE_ASPRINTF''@,@HAVE_ASPRINTF@,g' \ | ||
445 | - -e 's,@''HAVE_SNPRINTF''@,@HAVE_SNPRINTF@,g' \ | ||
446 | - -e 's,@''HAVE_WPRINTF''@,@HAVE_WPRINTF@,g' \ | ||
447 | - < $(srcdir)/libgnuintl.h.in > libgnuintl.h | ||
448 | - | ||
449 | -libintl.h: libgnuintl.h | ||
450 | - cp libgnuintl.h libintl.h | ||
451 | - | ||
452 | -charset.alias: $(srcdir)/config.charset | ||
453 | - $(SHELL) $(srcdir)/config.charset '@host@' > t-$@ | ||
454 | - mv t-$@ $@ | ||
455 | - | ||
456 | -check: all | ||
457 | - | ||
458 | -# We must not install the libintl.h/libintl.a files if we are on a | ||
459 | -# system which has the GNU gettext() function in its C library or in a | ||
460 | -# separate library. | ||
461 | -# If you want to use the one which comes with this version of the | ||
462 | -# package, you have to use `configure --with-included-gettext'. | ||
463 | -install: install-exec install-data | ||
464 | -install-exec: all | ||
465 | - if { test "$(PACKAGE)" = "gettext-runtime" || test "$(PACKAGE)" = "gettext-tools"; } \ | ||
466 | - && test '@USE_INCLUDED_LIBINTL@' = yes; then \ | ||
467 | - $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir); \ | ||
468 | - $(INSTALL_DATA) libintl.h $(DESTDIR)$(includedir)/libintl.h; \ | ||
469 | - $(LIBTOOL) --mode=install \ | ||
470 | - $(INSTALL_DATA) libintl.$la $(DESTDIR)$(libdir)/libintl.$la; \ | ||
471 | - if test "@RELOCATABLE@" = yes; then \ | ||
472 | - dependencies=`sed -n -e 's,^dependency_libs=\(.*\),\1,p' < $(DESTDIR)$(libdir)/libintl.la | sed -e "s,^',," -e "s,'\$$,,"`; \ | ||
473 | - if test -n "$$dependencies"; then \ | ||
474 | - rm -f $(DESTDIR)$(libdir)/libintl.la; \ | ||
475 | - fi; \ | ||
476 | - fi; \ | ||
477 | - else \ | ||
478 | - : ; \ | ||
479 | - fi | ||
480 | - if test "$(PACKAGE)" = "gettext-tools" \ | ||
481 | - && test '@USE_INCLUDED_LIBINTL@' = no \ | ||
482 | - && test @GLIBC2@ != no; then \ | ||
483 | - $(mkinstalldirs) $(DESTDIR)$(libdir); \ | ||
484 | - $(LIBTOOL) --mode=install \ | ||
485 | - $(INSTALL_DATA) libgnuintl.$la $(DESTDIR)$(libdir)/libgnuintl.$la; \ | ||
486 | - rm -f $(DESTDIR)$(libdir)/preloadable_libintl.so; \ | ||
487 | - $(INSTALL_DATA) $(DESTDIR)$(libdir)/libgnuintl.so $(DESTDIR)$(libdir)/preloadable_libintl.so; \ | ||
488 | - $(LIBTOOL) --mode=uninstall \ | ||
489 | - rm -f $(DESTDIR)$(libdir)/libgnuintl.$la; \ | ||
490 | - else \ | ||
491 | - : ; \ | ||
492 | - fi | ||
493 | - if test '@USE_INCLUDED_LIBINTL@' = yes; then \ | ||
494 | - test @GLIBC21@ != no || $(mkinstalldirs) $(DESTDIR)$(libdir); \ | ||
495 | - temp=$(DESTDIR)$(libdir)/t-charset.alias; \ | ||
496 | - dest=$(DESTDIR)$(libdir)/charset.alias; \ | ||
497 | - if test -f $(DESTDIR)$(libdir)/charset.alias; then \ | ||
498 | - orig=$(DESTDIR)$(libdir)/charset.alias; \ | ||
499 | - sed -f ref-add.sed $$orig > $$temp; \ | ||
500 | - $(INSTALL_DATA) $$temp $$dest; \ | ||
501 | - rm -f $$temp; \ | ||
502 | - else \ | ||
503 | - if test @GLIBC21@ = no; then \ | ||
504 | - orig=charset.alias; \ | ||
505 | - sed -f ref-add.sed $$orig > $$temp; \ | ||
506 | - $(INSTALL_DATA) $$temp $$dest; \ | ||
507 | - rm -f $$temp; \ | ||
508 | - fi; \ | ||
509 | - fi; \ | ||
510 | - $(mkinstalldirs) $(DESTDIR)$(localedir); \ | ||
511 | - test -f $(DESTDIR)$(localedir)/locale.alias \ | ||
512 | - && orig=$(DESTDIR)$(localedir)/locale.alias \ | ||
513 | - || orig=$(srcdir)/locale.alias; \ | ||
514 | - temp=$(DESTDIR)$(localedir)/t-locale.alias; \ | ||
515 | - dest=$(DESTDIR)$(localedir)/locale.alias; \ | ||
516 | - sed -f ref-add.sed $$orig > $$temp; \ | ||
517 | - $(INSTALL_DATA) $$temp $$dest; \ | ||
518 | - rm -f $$temp; \ | ||
519 | - else \ | ||
520 | - : ; \ | ||
521 | - fi | ||
522 | -install-data: all | ||
523 | - if test "$(PACKAGE)" = "gettext-tools"; then \ | ||
524 | - $(mkinstalldirs) $(DESTDIR)$(gettextsrcdir); \ | ||
525 | - $(INSTALL_DATA) VERSION $(DESTDIR)$(gettextsrcdir)/VERSION; \ | ||
526 | - $(INSTALL_DATA) ChangeLog.inst $(DESTDIR)$(gettextsrcdir)/ChangeLog; \ | ||
527 | - dists="COPYING.LIB-2.0 COPYING.LIB-2.1 $(DISTFILES.common)"; \ | ||
528 | - for file in $$dists; do \ | ||
529 | - $(INSTALL_DATA) $(srcdir)/$$file \ | ||
530 | - $(DESTDIR)$(gettextsrcdir)/$$file; \ | ||
531 | - done; \ | ||
532 | - chmod a+x $(DESTDIR)$(gettextsrcdir)/config.charset; \ | ||
533 | - dists="$(DISTFILES.generated)"; \ | ||
534 | - for file in $$dists; do \ | ||
535 | - if test -f $$file; then dir=.; else dir=$(srcdir); fi; \ | ||
536 | - $(INSTALL_DATA) $$dir/$$file \ | ||
537 | - $(DESTDIR)$(gettextsrcdir)/$$file; \ | ||
538 | - done; \ | ||
539 | - dists="$(DISTFILES.obsolete)"; \ | ||
540 | - for file in $$dists; do \ | ||
541 | - rm -f $(DESTDIR)$(gettextsrcdir)/$$file; \ | ||
542 | - done; \ | ||
543 | - else \ | ||
544 | - : ; \ | ||
545 | - fi | ||
546 | - | ||
547 | -install-strip: install | ||
548 | - | ||
549 | -installdirs: | ||
550 | - if { test "$(PACKAGE)" = "gettext-runtime" || test "$(PACKAGE)" = "gettext-tools"; } \ | ||
551 | - && test '@USE_INCLUDED_LIBINTL@' = yes; then \ | ||
552 | - $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir); \ | ||
553 | - else \ | ||
554 | - : ; \ | ||
555 | - fi | ||
556 | - if test "$(PACKAGE)" = "gettext-tools" \ | ||
557 | - && test '@USE_INCLUDED_LIBINTL@' = no \ | ||
558 | - && test @GLIBC2@ != no; then \ | ||
559 | - $(mkinstalldirs) $(DESTDIR)$(libdir); \ | ||
560 | - else \ | ||
561 | - : ; \ | ||
562 | - fi | ||
563 | - if test '@USE_INCLUDED_LIBINTL@' = yes; then \ | ||
564 | - test @GLIBC21@ != no || $(mkinstalldirs) $(DESTDIR)$(libdir); \ | ||
565 | - $(mkinstalldirs) $(DESTDIR)$(localedir); \ | ||
566 | - else \ | ||
567 | - : ; \ | ||
568 | - fi | ||
569 | - if test "$(PACKAGE)" = "gettext-tools"; then \ | ||
570 | - $(mkinstalldirs) $(DESTDIR)$(gettextsrcdir); \ | ||
571 | - else \ | ||
572 | - : ; \ | ||
573 | - fi | ||
574 | - | ||
575 | -# Define this as empty until I found a useful application. | ||
576 | -installcheck: | ||
577 | - | ||
578 | -uninstall: | ||
579 | - if { test "$(PACKAGE)" = "gettext-runtime" || test "$(PACKAGE)" = "gettext-tools"; } \ | ||
580 | - && test '@USE_INCLUDED_LIBINTL@' = yes; then \ | ||
581 | - rm -f $(DESTDIR)$(includedir)/libintl.h; \ | ||
582 | - $(LIBTOOL) --mode=uninstall \ | ||
583 | - rm -f $(DESTDIR)$(libdir)/libintl.$la; \ | ||
584 | - else \ | ||
585 | - : ; \ | ||
586 | - fi | ||
587 | - if test "$(PACKAGE)" = "gettext-tools" \ | ||
588 | - && test '@USE_INCLUDED_LIBINTL@' = no \ | ||
589 | - && test @GLIBC2@ != no; then \ | ||
590 | - rm -f $(DESTDIR)$(libdir)/preloadable_libintl.so; \ | ||
591 | - else \ | ||
592 | - : ; \ | ||
593 | - fi | ||
594 | - if test '@USE_INCLUDED_LIBINTL@' = yes; then \ | ||
595 | - if test -f $(DESTDIR)$(libdir)/charset.alias; then \ | ||
596 | - temp=$(DESTDIR)$(libdir)/t-charset.alias; \ | ||
597 | - dest=$(DESTDIR)$(libdir)/charset.alias; \ | ||
598 | - sed -f ref-del.sed $$dest > $$temp; \ | ||
599 | - if grep '^# Packages using this file: $$' $$temp > /dev/null; then \ | ||
600 | - rm -f $$dest; \ | ||
601 | - else \ | ||
602 | - $(INSTALL_DATA) $$temp $$dest; \ | ||
603 | - fi; \ | ||
604 | - rm -f $$temp; \ | ||
605 | - fi; \ | ||
606 | - if test -f $(DESTDIR)$(localedir)/locale.alias; then \ | ||
607 | - temp=$(DESTDIR)$(localedir)/t-locale.alias; \ | ||
608 | - dest=$(DESTDIR)$(localedir)/locale.alias; \ | ||
609 | - sed -f ref-del.sed $$dest > $$temp; \ | ||
610 | - if grep '^# Packages using this file: $$' $$temp > /dev/null; then \ | ||
611 | - rm -f $$dest; \ | ||
612 | - else \ | ||
613 | - $(INSTALL_DATA) $$temp $$dest; \ | ||
614 | - fi; \ | ||
615 | - rm -f $$temp; \ | ||
616 | - fi; \ | ||
617 | - else \ | ||
618 | - : ; \ | ||
619 | - fi | ||
620 | - if test "$(PACKAGE)" = "gettext-tools"; then \ | ||
621 | - for file in VERSION ChangeLog COPYING.LIB-2.0 COPYING.LIB-2.1 $(DISTFILES.common) $(DISTFILES.generated); do \ | ||
622 | - rm -f $(DESTDIR)$(gettextsrcdir)/$$file; \ | ||
623 | - done; \ | ||
624 | - else \ | ||
625 | - : ; \ | ||
626 | - fi | ||
627 | - | ||
628 | -info dvi ps pdf html: | ||
629 | - | ||
630 | -$(OBJECTS): ../config.h libgnuintl.h | ||
631 | -bindtextdom.$lo dcgettext.$lo dcigettext.$lo dcngettext.$lo dgettext.$lo dngettext.$lo finddomain.$lo gettext.$lo intl-compat.$lo loadmsgcat.$lo localealias.$lo ngettext.$lo textdomain.$lo: $(srcdir)/gettextP.h $(srcdir)/gmo.h $(srcdir)/loadinfo.h | ||
632 | -dcigettext.$lo loadmsgcat.$lo: $(srcdir)/hash-string.h | ||
633 | -explodename.$lo l10nflist.$lo: $(srcdir)/loadinfo.h | ||
634 | -dcigettext.$lo loadmsgcat.$lo plural.$lo plural-exp.$lo: $(srcdir)/plural-exp.h | ||
635 | -dcigettext.$lo: $(srcdir)/eval-plural.h | ||
636 | -localcharset.$lo: $(srcdir)/localcharset.h | ||
637 | -localealias.$lo localcharset.$lo relocatable.$lo: $(srcdir)/relocatable.h | ||
638 | -printf.$lo: $(srcdir)/printf-args.h $(srcdir)/printf-args.c $(srcdir)/printf-parse.h $(srcdir)/wprintf-parse.h $(srcdir)/xsize.h $(srcdir)/printf-parse.c $(srcdir)/vasnprintf.h $(srcdir)/vasnwprintf.h $(srcdir)/vasnprintf.c | ||
639 | - | ||
640 | -tags: TAGS | ||
641 | - | ||
642 | -TAGS: $(HEADERS) $(SOURCES) | ||
643 | - here=`pwd`; cd $(srcdir) && etags -o $$here/TAGS $(HEADERS) $(SOURCES) | ||
644 | - | ||
645 | -ctags: CTAGS | ||
646 | - | ||
647 | -CTAGS: $(HEADERS) $(SOURCES) | ||
648 | - here=`pwd`; cd $(srcdir) && ctags -o $$here/CTAGS $(HEADERS) $(SOURCES) | ||
649 | - | ||
650 | -id: ID | ||
651 | - | ||
652 | -ID: $(HEADERS) $(SOURCES) | ||
653 | - here=`pwd`; cd $(srcdir) && mkid -f$$here/ID $(HEADERS) $(SOURCES) | ||
654 | - | ||
655 | - | ||
656 | -mostlyclean: | ||
657 | - rm -f *.a *.la *.o *.obj *.lo core core.* | ||
658 | - rm -f libgnuintl.h libintl.h charset.alias ref-add.sed ref-del.sed | ||
659 | - rm -f -r .libs _libs | ||
660 | - | ||
661 | -clean: mostlyclean | ||
662 | - | ||
663 | -distclean: clean | ||
664 | - rm -f Makefile ID TAGS | ||
665 | - if test "$(PACKAGE)" = "gettext-runtime" || test "$(PACKAGE)" = "gettext-tools"; then \ | ||
666 | - rm -f ChangeLog.inst $(DISTFILES.normal); \ | ||
667 | - else \ | ||
668 | - : ; \ | ||
669 | - fi | ||
670 | - | ||
671 | -maintainer-clean: distclean | ||
672 | - @echo "This command is intended for maintainers to use;" | ||
673 | - @echo "it deletes files that may require special tools to rebuild." | ||
674 | - | ||
675 | - | ||
676 | -# GNU gettext needs not contain the file `VERSION' but contains some | ||
677 | -# other files which should not be distributed in other packages. | ||
678 | -distdir = ../$(PACKAGE)-$(VERSION)/$(subdir) | ||
679 | -dist distdir: Makefile | ||
680 | - if test "$(PACKAGE)" = "gettext-tools"; then \ | ||
681 | - : ; \ | ||
682 | - else \ | ||
683 | - if test "$(PACKAGE)" = "gettext-runtime"; then \ | ||
684 | - additional="$(DISTFILES.gettext)"; \ | ||
685 | - else \ | ||
686 | - additional="$(DISTFILES.normal)"; \ | ||
687 | - fi; \ | ||
688 | - $(MAKE) $(DISTFILES.common) $(DISTFILES.generated) $$additional; \ | ||
689 | - for file in ChangeLog $(DISTFILES.common) $(DISTFILES.generated) $$additional; do \ | ||
690 | - if test -f $$file; then dir=.; else dir=$(srcdir); fi; \ | ||
691 | - cp -p $$dir/$$file $(distdir); \ | ||
692 | - done; \ | ||
693 | - fi | ||
694 | - | ||
695 | -Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status | ||
696 | - cd $(top_builddir) && $(SHELL) ./config.status | ||
697 | -# This would be more efficient, but doesn't work any more with autoconf-2.57, | ||
698 | -# when AC_CONFIG_FILES([intl/Makefile:somedir/Makefile.in]) is used. | ||
699 | -# cd $(top_builddir) && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status | ||
700 | - | ||
701 | -# Tell versions [3.59,3.63) of GNU make not to export all variables. | ||
702 | -# Otherwise a system limit (for SysV at least) may be exceeded. | ||
703 | -.NOEXPORT: | ||
diff --git a/meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb b/meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb index 4a871bf4f..d5da2b688 100644 --- a/meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb +++ b/meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb | |||
@@ -9,6 +9,7 @@ SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/hddtemp/hddtemp-0.3-beta15.tar.bz2 \ | |||
9 | file://hddtemp_0.3-beta15-52.diff \ | 9 | file://hddtemp_0.3-beta15-52.diff \ |
10 | file://hddtemp-0.3-beta15-autodetect-717479.patch \ | 10 | file://hddtemp-0.3-beta15-autodetect-717479.patch \ |
11 | file://0001-backtrace-Replace-struct-ucontext-with-ucontext_t.patch \ | 11 | file://0001-backtrace-Replace-struct-ucontext-with-ucontext_t.patch \ |
12 | file://0001-configure.ac-Rename-to-configure.ac-and-use-external.patch \ | ||
12 | file://hddtemp.db \ | 13 | file://hddtemp.db \ |
13 | file://init \ | 14 | file://init \ |
14 | " | 15 | " |