diff options
author | Fabio Berton <fabio.berton@ossystems.com.br> | 2016-08-22 16:01:15 -0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-09-05 13:27:35 +0200 |
commit | 445e595c9dc01d475df8d9ffd8b6823c1d2c4d6a (patch) | |
tree | 553a24d9751ea9b1cd06236db3320592c6664963 | |
parent | 90eedcc9fec081d597e73c31119fe2c493cac8a4 (diff) | |
download | meta-openembedded-445e595c9dc01d475df8d9ffd8b6823c1d2c4d6a.tar.gz |
python-cffi: Extend recipe to support Python 3
- Add Python 3 recipe
- Add native and nativesdk to BBCLASSEXTEND
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
3 files changed, 12 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-cffi.inc b/meta-python/recipes-devtools/python/python-cffi.inc new file mode 100644 index 000000000..7038d90a9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-cffi.inc | |||
@@ -0,0 +1,9 @@ | |||
1 | SUMMARY = "Foreign Function Interface for Python calling C code" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf" | ||
4 | DEPENDS = "libffi ${PYTHON_PN}-pycparser" | ||
5 | |||
6 | SRC_URI[md5sum] = "34122a545060cee58bab88feab57006d" | ||
7 | SRC_URI[sha256sum] = "6ed5dd6afd8361f34819c68aaebf9e8fc12b5a5893f91f50c9e50c8886bb60df" | ||
8 | |||
9 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-cffi_1.7.0.bb b/meta-python/recipes-devtools/python/python-cffi_1.7.0.bb index 6f4d77a4e..1d2d2416a 100644 --- a/meta-python/recipes-devtools/python/python-cffi_1.7.0.bb +++ b/meta-python/recipes-devtools/python/python-cffi_1.7.0.bb | |||
@@ -1,11 +1,2 @@ | |||
1 | SUMMARY = "Foreign Function Interface for Python calling C code" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf" | ||
4 | DEPENDS = "libffi python-pycparser" | ||
5 | |||
6 | SRC_URI[md5sum] = "34122a545060cee58bab88feab57006d" | ||
7 | SRC_URI[sha256sum] = "6ed5dd6afd8361f34819c68aaebf9e8fc12b5a5893f91f50c9e50c8886bb60df" | ||
8 | |||
9 | inherit pypi setuptools | 1 | inherit pypi setuptools |
10 | 2 | require python-cffi.inc | |
11 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-python/recipes-devtools/python/python3-cffi_1.7.0.bb b/meta-python/recipes-devtools/python/python3-cffi_1.7.0.bb new file mode 100644 index 000000000..e88808434 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-cffi_1.7.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi setuptools3 | ||
2 | require python-cffi.inc | ||