diff options
author | Peter Kjellerstedt <peter.kjellerstedt@axis.com> | 2021-06-23 18:38:04 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-06-23 10:46:54 -0700 |
commit | 411c981ef01b9965c22b7c35549dc95023169ea7 (patch) | |
tree | 46778a5f86409b5d8a89f07d3e769b899f3b5e6d | |
parent | 500ce4d46d8878a5dc43e932db6c133288584d19 (diff) | |
download | meta-openembedded-411c981ef01b9965c22b7c35549dc95023169ea7.tar.gz |
net-snmp: A little clean up
* Remove the explicit dependency on libnl as the libnl PACKAGECONFIG
depends on it as necessary.
* Add a PACKAGECONFIG for systemd to replace modifying EXTRA_OECONF
directly.
* Sort the PACKAGECONFIGs.
* Some whitespace clean up.
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb | 35 |
1 files changed, 16 insertions, 19 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb index 1d48a8598..c96ada80d 100644 --- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb +++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb | |||
@@ -5,7 +5,7 @@ LICENSE = "BSD & MIT" | |||
5 | 5 | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=9d100a395a38584f2ec18a8275261687" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=9d100a395a38584f2ec18a8275261687" |
7 | 7 | ||
8 | DEPENDS = "openssl libnl pciutils" | 8 | DEPENDS = "openssl pciutils" |
9 | 9 | ||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz \ | 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz \ |
11 | file://init \ | 11 | file://init \ |
@@ -41,24 +41,23 @@ CCACHE = "" | |||
41 | 41 | ||
42 | TARGET_CC_ARCH += "${LDFLAGS}" | 42 | TARGET_CC_ARCH += "${LDFLAGS}" |
43 | 43 | ||
44 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} des smux" | 44 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} des smux" |
45 | PACKAGECONFIG[des] = "--enable-des, --disable-des" | ||
45 | PACKAGECONFIG[elfutils] = "--with-elf, --without-elf, elfutils" | 46 | PACKAGECONFIG[elfutils] = "--with-elf, --without-elf, elfutils" |
47 | PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6" | ||
46 | PACKAGECONFIG[libnl] = "--with-nl, --without-nl, libnl" | 48 | PACKAGECONFIG[libnl] = "--with-nl, --without-nl, libnl" |
47 | 49 | PACKAGECONFIG[perl] = "--enable-embedded-perl --with-perl-modules=yes, --disable-embedded-perl --with-perl-modules=no, perl" | |
48 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,," | ||
49 | |||
50 | PACKAGECONFIG[perl] = "--enable-embedded-perl --with-perl-modules=yes, --disable-embedded-perl --with-perl-modules=no,\ | ||
51 | perl," | ||
52 | PACKAGECONFIG[des] = "--enable-des,--disable-des" | ||
53 | PACKAGECONFIG[smux] = "" | 50 | PACKAGECONFIG[smux] = "" |
54 | 51 | PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd" | |
55 | EXTRA_OECONF = "--enable-shared \ | 52 | |
56 | --disable-manuals \ | 53 | EXTRA_OECONF = " \ |
57 | --with-defaults \ | 54 | --enable-shared \ |
58 | --with-install-prefix=${D} \ | 55 | --disable-manuals \ |
59 | --with-persistent-directory=${localstatedir}/lib/net-snmp \ | 56 | --with-defaults \ |
60 | ${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', '--with-endianness=little', '--with-endianness=big', d)} \ | 57 | --with-install-prefix=${D} \ |
61 | --with-mib-modules='${MIB_MODULES}' \ | 58 | --with-persistent-directory=${localstatedir}/lib/net-snmp \ |
59 | --with-endianness=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \ | ||
60 | --with-mib-modules='${MIB_MODULES}' \ | ||
62 | " | 61 | " |
63 | 62 | ||
64 | MIB_MODULES = "" | 63 | MIB_MODULES = "" |
@@ -117,7 +116,7 @@ do_install_append() { | |||
117 | install -d ${D}${systemd_unitdir}/system | 116 | install -d ${D}${systemd_unitdir}/system |
118 | install -m 0644 ${WORKDIR}/snmpd.service ${D}${systemd_unitdir}/system | 117 | install -m 0644 ${WORKDIR}/snmpd.service ${D}${systemd_unitdir}/system |
119 | install -m 0644 ${WORKDIR}/snmptrapd.service ${D}${systemd_unitdir}/system | 118 | install -m 0644 ${WORKDIR}/snmptrapd.service ${D}${systemd_unitdir}/system |
120 | sed -e "s@^NSC_SRCDIR=.*@NSC_SRCDIR=.@g" \ | 119 | sed -e "s@^NSC_SRCDIR=.*@NSC_SRCDIR=.@g" \ |
121 | -i ${D}${bindir}/net-snmp-create-v3-user | 120 | -i ${D}${bindir}/net-snmp-create-v3-user |
122 | sed -e 's@^NSC_SRCDIR=.*@NSC_SRCDIR=.@g' \ | 121 | sed -e 's@^NSC_SRCDIR=.*@NSC_SRCDIR=.@g' \ |
123 | -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \ | 122 | -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \ |
@@ -234,8 +233,6 @@ INITSCRIPT_PACKAGES = "${PN}-server-snmpd" | |||
234 | INITSCRIPT_NAME_${PN}-server-snmpd = "snmpd" | 233 | INITSCRIPT_NAME_${PN}-server-snmpd = "snmpd" |
235 | INITSCRIPT_PARAMS_${PN}-server-snmpd = "start 90 2 3 4 5 . stop 60 0 1 6 ." | 234 | INITSCRIPT_PARAMS_${PN}-server-snmpd = "start 90 2 3 4 5 . stop 60 0 1 6 ." |
236 | 235 | ||
237 | EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemd', '--without-systemd', d)}" | ||
238 | |||
239 | SYSTEMD_PACKAGES = "${PN}-server-snmpd \ | 236 | SYSTEMD_PACKAGES = "${PN}-server-snmpd \ |
240 | ${PN}-server-snmptrapd" | 237 | ${PN}-server-snmptrapd" |
241 | 238 | ||