diff options
author | Derek Straka <derek@asterius.io> | 2020-02-14 14:47:39 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-15 08:05:07 -0800 |
commit | 401bd658536396dd2504de0a401c0aa74fd8c477 (patch) | |
tree | a941d6bfd618441df2aaba3d94d30aeb065c4a29 | |
parent | 82eafcc41c11694474d8e7f6829d2d4c24842feb (diff) | |
download | meta-openembedded-401bd658536396dd2504de0a401c0aa74fd8c477.tar.gz |
python3-cachetools: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python-cachetools.inc | 16 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb | 18 |
2 files changed, 16 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-cachetools.inc b/meta-python/recipes-devtools/python/python-cachetools.inc deleted file mode 100644 index f3d3bc6bc..000000000 --- a/meta-python/recipes-devtools/python/python-cachetools.inc +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | SUMMARY = "Extensible memoizing collections and decorators" | ||
2 | HOMEPAGE = "https://github.com/tkem/cachetools" | ||
3 | DESCRIPTION = "This module provides various memoizing \ | ||
4 | collections and decorators, including variants of the \ | ||
5 | Python 3 Standard Library @lru_cache function decorator." | ||
6 | SECTION = "devel/python" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=27f7518eb6f7dc686d0f953b2f28dae5" | ||
10 | |||
11 | inherit pypi | ||
12 | |||
13 | SRC_URI[md5sum] = "6a88df13467e80eb61dd2bedad19b83c" | ||
14 | SRC_URI[sha256sum] = "9a52dd97a85f257f4e4127f15818e71a0c7899f121b34591fcc1173ea79a0198" | ||
15 | |||
16 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb b/meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb index 76b2f6785..50d0f2573 100644 --- a/meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb +++ b/meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb | |||
@@ -1,2 +1,16 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "Extensible memoizing collections and decorators" |
2 | require python-cachetools.inc | 2 | HOMEPAGE = "https://github.com/tkem/cachetools" |
3 | DESCRIPTION = "This module provides various memoizing \ | ||
4 | collections and decorators, including variants of the \ | ||
5 | Python 3 Standard Library @lru_cache function decorator." | ||
6 | SECTION = "devel/python" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=27f7518eb6f7dc686d0f953b2f28dae5" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | SRC_URI[md5sum] = "6a88df13467e80eb61dd2bedad19b83c" | ||
14 | SRC_URI[sha256sum] = "9a52dd97a85f257f4e4127f15818e71a0c7899f121b34591fcc1173ea79a0198" | ||
15 | |||
16 | BBCLASSEXTEND = "native nativesdk" | ||