summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 14:47:39 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commit401bd658536396dd2504de0a401c0aa74fd8c477 (patch)
treea941d6bfd618441df2aaba3d94d30aeb065c4a29
parent82eafcc41c11694474d8e7f6829d2d4c24842feb (diff)
downloadmeta-openembedded-401bd658536396dd2504de0a401c0aa74fd8c477.tar.gz
python3-cachetools: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-cachetools.inc16
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb18
2 files changed, 16 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-cachetools.inc b/meta-python/recipes-devtools/python/python-cachetools.inc
deleted file mode 100644
index f3d3bc6bc..000000000
--- a/meta-python/recipes-devtools/python/python-cachetools.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1SUMMARY = "Extensible memoizing collections and decorators"
2HOMEPAGE = "https://github.com/tkem/cachetools"
3DESCRIPTION = "This module provides various memoizing \
4collections and decorators, including variants of the \
5Python 3 Standard Library @lru_cache function decorator."
6SECTION = "devel/python"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=27f7518eb6f7dc686d0f953b2f28dae5"
10
11inherit pypi
12
13SRC_URI[md5sum] = "6a88df13467e80eb61dd2bedad19b83c"
14SRC_URI[sha256sum] = "9a52dd97a85f257f4e4127f15818e71a0c7899f121b34591fcc1173ea79a0198"
15
16BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb b/meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb
index 76b2f6785..50d0f2573 100644
--- a/meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cachetools_4.0.0.bb
@@ -1,2 +1,16 @@
1inherit setuptools3 1SUMMARY = "Extensible memoizing collections and decorators"
2require python-cachetools.inc 2HOMEPAGE = "https://github.com/tkem/cachetools"
3DESCRIPTION = "This module provides various memoizing \
4collections and decorators, including variants of the \
5Python 3 Standard Library @lru_cache function decorator."
6SECTION = "devel/python"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=27f7518eb6f7dc686d0f953b2f28dae5"
10
11inherit pypi setuptools3
12
13SRC_URI[md5sum] = "6a88df13467e80eb61dd2bedad19b83c"
14SRC_URI[sha256sum] = "9a52dd97a85f257f4e4127f15818e71a0c7899f121b34591fcc1173ea79a0198"
15
16BBCLASSEXTEND = "native nativesdk"