diff options
author | Moritz Fischer <moritz.fischer@ettus.com> | 2016-01-07 12:17:34 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-27 12:36:31 +0100 |
commit | 341253bd5729032844edb8cd1e6c4b512e1ae0cc (patch) | |
tree | 5501110f3059b27400c8c0df52c74626ef5c6971 | |
parent | dc51449c479ec117715455640b4730f188611f41 (diff) | |
download | meta-openembedded-341253bd5729032844edb8cd1e6c4b512e1ae0cc.tar.gz |
gpsd: Add patch to fix broken ACTIVATE hook.
This patch is already in mainline gpsd. It fixes a
bug where the ACTIVATE hook for a device never gets
called.
Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch | 35 | ||||
-rw-r--r-- | meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb | 1 |
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch new file mode 100644 index 000000000..7a0679505 --- /dev/null +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 6ff099b1ba8de74df9ddeb61e3825264b96ef692 Mon Sep 17 00:00:00 2001 | ||
2 | From: Moritz Fischer <moritz.fischer@ettus.com> | ||
3 | Date: Tue, 22 Dec 2015 19:38:31 -0800 | ||
4 | Subject: [PATCH] libgpsd-core: Fix issue with ACTIVATE hook not being called. | ||
5 | |||
6 | In the current system session->mode seemed to ignore the | ||
7 | O_OPTIMIZE flag, leading to the ACTIVATE hook being ignored. | ||
8 | |||
9 | Another way to fix this would be to keep the session->mode | ||
10 | condition pull up the check for O_CONTINUE. | ||
11 | |||
12 | Upstream-Status: Backported | ||
13 | This patch is in upstream git | ||
14 | |||
15 | Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> | ||
16 | --- | ||
17 | libgpsd_core.c | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/libgpsd_core.c b/libgpsd_core.c | ||
21 | index 31fec2a..a84e85f 100644 | ||
22 | --- a/libgpsd_core.c | ||
23 | +++ b/libgpsd_core.c | ||
24 | @@ -543,7 +543,7 @@ int gpsd_open(struct gps_device_t *session) | ||
25 | int gpsd_activate(struct gps_device_t *session, const int mode) | ||
26 | /* acquire a connection to the GPS device */ | ||
27 | { | ||
28 | - if (session->mode == O_OPTIMIZE) | ||
29 | + if (mode == O_OPTIMIZE) | ||
30 | gpsd_run_device_hook(&session->context->errout, | ||
31 | session->gpsdata.dev.path, "ACTIVATE"); | ||
32 | session->gpsdata.gps_fd = gpsd_open(session); | ||
33 | -- | ||
34 | 2.4.3 | ||
35 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb index f444ffce1..ff268b35e 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb +++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb | |||
@@ -16,6 +16,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \ | |||
16 | file://0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch \ | 16 | file://0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch \ |
17 | file://0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch \ | 17 | file://0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch \ |
18 | file://0001-Include-stdatomic.h-only-in-C-mode.patch \ | 18 | file://0001-Include-stdatomic.h-only-in-C-mode.patch \ |
19 | file://0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch \ | ||
19 | file://gpsd-default \ | 20 | file://gpsd-default \ |
20 | file://gpsd \ | 21 | file://gpsd \ |
21 | file://60-gpsd.rules \ | 22 | file://60-gpsd.rules \ |