diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-01-26 17:24:32 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-26 21:52:26 -0800 |
commit | 3210d3523fcd211a15a082ae7a3ca7be2a5c2905 (patch) | |
tree | 0e1b49158c600641293e8cfbe7f9f7d21405176e | |
parent | cc396c8e9a507e86c9fe2a040d1df80f8c8c93b5 (diff) | |
download | meta-openembedded-3210d3523fcd211a15a082ae7a3ca7be2a5c2905.tar.gz |
v4l-utils: Fix build with gcc13
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-media-info-Include-missing-cstdint-for-uintptr_t.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.23.0.bb | 1 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-media-info-Include-missing-cstdint-for-uintptr_t.patch b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-media-info-Include-missing-cstdint-for-uintptr_t.patch new file mode 100644 index 000000000..032bf00c7 --- /dev/null +++ b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-media-info-Include-missing-cstdint-for-uintptr_t.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 1d9ce7cd799770981043f656373cbd1bf7558b9a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 26 Jan 2023 17:00:00 -0800 | ||
4 | Subject: [PATCH] media-info: Include missing <cstdint> for uintptr_t | ||
5 | |||
6 | gcc 13 moved some includes around and as a result <cstdint> is no longer | ||
7 | transitively included [1]. Explicitly include it. | ||
8 | |||
9 | [1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes | ||
10 | |||
11 | Upstream-Status: Submitted [https://lore.kernel.org/linux-media/20230127010741.3883339-1-raj.khem@gmail.com/] | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | utils/common/media-info.cpp | 1 + | ||
15 | 1 file changed, 1 insertion(+) | ||
16 | |||
17 | diff --git a/utils/common/media-info.cpp b/utils/common/media-info.cpp | ||
18 | index 53e132f5..1a25a4b6 100644 | ||
19 | --- a/utils/common/media-info.cpp | ||
20 | +++ b/utils/common/media-info.cpp | ||
21 | @@ -3,6 +3,7 @@ | ||
22 | * Copyright 2018 Cisco Systems, Inc. and/or its affiliates. All rights reserved. | ||
23 | */ | ||
24 | |||
25 | +#include <cstdint> | ||
26 | #include <cstring> | ||
27 | #include <fstream> | ||
28 | #include <iostream> | ||
29 | -- | ||
30 | 2.39.1 | ||
31 | |||
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.23.0.bb b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.23.0.bb index 383be4a54..b42300f09 100644 --- a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.23.0.bb +++ b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.23.0.bb | |||
@@ -32,6 +32,7 @@ SRC_URI = "\ | |||
32 | file://0003-original-patch-export-mediactl-headers.patch \ | 32 | file://0003-original-patch-export-mediactl-headers.patch \ |
33 | file://0004-Do-not-use-getsubopt.patch \ | 33 | file://0004-Do-not-use-getsubopt.patch \ |
34 | file://0005-configure.ac-Makefile.am-Support-building-without-NL.patch \ | 34 | file://0005-configure.ac-Makefile.am-Support-building-without-NL.patch \ |
35 | file://0001-media-info-Include-missing-cstdint-for-uintptr_t.patch \ | ||
35 | " | 36 | " |
36 | 37 | ||
37 | SRCREV = "fd544473800d02e90bc289434cc44e5aa8fadd0f" | 38 | SRCREV = "fd544473800d02e90bc289434cc44e5aa8fadd0f" |