diff options
author | Jussi Kukkonen <jussi.kukkonen@intel.com> | 2016-11-15 13:44:07 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-12-02 09:16:19 +0100 |
commit | 2f6e45baba961629bfe023599144be6cfcd45728 (patch) | |
tree | 377debbe8b9bc0d5c2bb3cb888371339791d0ac0 | |
parent | 877e52fd75c7d3b88add94691df3beb5e0c54529 (diff) | |
download | meta-openembedded-2f6e45baba961629bfe023599144be6cfcd45728.tar.gz |
xserver-common: Don't install some Xsession files
The goal is that the graphical_init_manager (xserver-nodm-init)
provides Xsession (and some basic scripts) and that xserver-common
can then provide additional Xsession scripts. Remove the Xsession
files that xserver-nodm-init installs.
Bump PR so xserver-nodm-init can RCONFLICT with old one.
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
5 files changed, 32 insertions, 82 deletions
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0001-Don-t-install-Xsession-or-Xserver.patch b/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0001-Don-t-install-Xsession-or-Xserver.patch new file mode 100644 index 000000000..26288d6d1 --- /dev/null +++ b/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0001-Don-t-install-Xsession-or-Xserver.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From c92ce6a4b3622874f820b5ec487a2b63f519826c Mon Sep 17 00:00:00 2001 | ||
2 | From: Jussi Kukkonen <jussi.kukkonen@intel.com> | ||
3 | Date: Thu, 10 Nov 2016 14:33:05 +0200 | ||
4 | Subject: [PATCH] Don't install Xsession or Xserver | ||
5 | |||
6 | The goal is to use Xsession and Xserver from xserver-nodm-init. | ||
7 | Xsession scripts and xserver-common from this recipe will still | ||
8 | be used as before. | ||
9 | |||
10 | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> | ||
11 | --- | ||
12 | Makefile | 1 - | ||
13 | 1 file changed, 1 deletion(-) | ||
14 | |||
15 | diff --git a/Makefile b/Makefile | ||
16 | index caa5de1..7e36bbc 100644 | ||
17 | --- a/Makefile | ||
18 | +++ b/Makefile | ||
19 | @@ -20,7 +20,5 @@ install-program: | ||
20 | install -m 755 run-calibrate.sh $(DESTDIR)$(PREFIX)/bin/run-calibrate.sh | ||
21 | install -m 644 X11/Xdefaults $(DESTDIR)/etc/X11/Xdefaults | ||
22 | install -m 755 X11/Xinit $(DESTDIR)/etc/X11/Xinit | ||
23 | - install -m 755 X11/Xserver $(DESTDIR)/etc/X11/Xserver | ||
24 | - install -m 755 X11/Xsession $(DESTDIR)/etc/X11/Xsession | ||
25 | install -m 755 X11/xserver-common $(DESTDIR)/etc/X11/xserver-common | ||
26 | install -m 755 X11/functions $(DESTDIR)/etc/X11/functions | ||
27 | install -d $(DESTDIR)/etc/X11/xmodmap | ||
28 | -- | ||
29 | 2.1.4 | ||
30 | |||
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0003-add-89xdgautostart-Xsession.d-script.patch b/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0003-add-89xdgautostart-Xsession.d-script.patch deleted file mode 100644 index bf806a991..000000000 --- a/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0003-add-89xdgautostart-Xsession.d-script.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From a93a86c2ff1ca5eb35615f4e1568409ff342aa7f Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Wed, 11 Apr 2012 14:29:41 +0200 | ||
4 | Subject: [PATCH 03/12] add 89xdgautostart Xsession.d script | ||
5 | |||
6 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
7 | --- | ||
8 | X11/Xsession.d/89xdgautostart | 9 +++++++++ | ||
9 | 1 files changed, 9 insertions(+), 0 deletions(-) | ||
10 | create mode 100644 X11/Xsession.d/89xdgautostart | ||
11 | |||
12 | diff --git a/X11/Xsession.d/89xdgautostart b/X11/Xsession.d/89xdgautostart | ||
13 | new file mode 100644 | ||
14 | index 0000000..9886f9f | ||
15 | --- /dev/null | ||
16 | +++ b/X11/Xsession.d/89xdgautostart | ||
17 | @@ -0,0 +1,9 @@ | ||
18 | +#!/bin/sh | ||
19 | + | ||
20 | +XDGAUTOSTART=/etc/xdg/autostart | ||
21 | +if [ -d $XDGAUTOSTART ] ; then | ||
22 | + for SCRIPT in $XDGAUTOSTART/*; do | ||
23 | + CMD=`grep ^Exec= $SCRIPT | cut -d '=' -f 2` | ||
24 | + $CMD & | ||
25 | + done | ||
26 | +fi | ||
27 | -- | ||
28 | 1.7.8.5 | ||
29 | |||
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0005-add-XWindowManager-Xsession.d-script.patch b/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0005-add-XWindowManager-Xsession.d-script.patch deleted file mode 100644 index 1782665b2..000000000 --- a/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0005-add-XWindowManager-Xsession.d-script.patch +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | From b01a532ebb525552e23d7169a2aeb55c42b3ec99 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Wed, 11 Apr 2012 14:32:13 +0200 | ||
4 | Subject: [PATCH 05/12] add XWindowManager Xsession.d script | ||
5 | |||
6 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
7 | --- | ||
8 | X11/Xsession.d/90xXWindowManager | 6 ++++++ | ||
9 | 1 files changed, 6 insertions(+), 0 deletions(-) | ||
10 | create mode 100644 X11/Xsession.d/90xXWindowManager | ||
11 | |||
12 | Index: xserver-common-1.34/X11/Xsession.d/90xXWindowManager | ||
13 | =================================================================== | ||
14 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
15 | +++ xserver-common-1.34/X11/Xsession.d/90xXWindowManager 2012-06-28 15:02:22.010521773 +0200 | ||
16 | @@ -0,0 +1,7 @@ | ||
17 | +if [ -x $HOME/.Xsession ]; then | ||
18 | + exec $HOME/.Xsession | ||
19 | +elif [ -x /usr/bin/x-session-manager ]; then | ||
20 | + exec /usr/bin/x-session-manager | ||
21 | +else | ||
22 | + exec /usr/bin/x-window-manager | ||
23 | +fi | ||
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0014-Xserver-Start-Xsession-like-x11-common-does.patch b/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0014-Xserver-Start-Xsession-like-x11-common-does.patch deleted file mode 100644 index 5a759640c..000000000 --- a/meta-oe/recipes-graphics/xserver-common/xserver-common-1.34/0014-Xserver-Start-Xsession-like-x11-common-does.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 8171f89944969a081be1ac193b2a59016e39a345 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Tue, 29 Oct 2013 17:07:21 +0100 | ||
4 | Subject: [PATCH 14/14] Xserver: Start Xsession like x11-common does | ||
5 | |||
6 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
7 | --- | ||
8 | X11/Xserver | 4 ++-- | ||
9 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/X11/Xserver b/X11/Xserver | ||
12 | index 559f059..4b88637 100755 | ||
13 | --- a/X11/Xserver | ||
14 | +++ b/X11/Xserver | ||
15 | @@ -4,6 +4,6 @@ | ||
16 | . /etc/X11/xserver-common | ||
17 | |||
18 | echo "tslib: $TSLIB_TSDEVICE" | ||
19 | -echo "exec $XSERVER $ARGS -dpi $DPI $*" | ||
20 | -exec $XSERVER $ARGS -dpi $DPI $* | ||
21 | +echo "exec xinit /etc/X11/Xsession -- $BINDIR/$XSERVER $ARGS -dpi $DPI $*" | ||
22 | |||
23 | +exec xinit /etc/X11/Xsession -- $BINDIR/$XSERVER $ARGS -dpi $DPI $* | ||
24 | -- | ||
25 | 1.8.4.2 | ||
26 | |||
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb index 0315ed7d6..cc3054184 100644 --- a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb +++ b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb | |||
@@ -2,7 +2,7 @@ SUMMARY = "Common X11 scripts and support files" | |||
2 | LICENSE = "GPLv2" | 2 | LICENSE = "GPLv2" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
4 | 4 | ||
5 | PR = "r8" | 5 | PR = "r9" |
6 | 6 | ||
7 | # we are using a gpe-style Makefile | 7 | # we are using a gpe-style Makefile |
8 | inherit gpe | 8 | inherit gpe |
@@ -13,8 +13,6 @@ SRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166c | |||
13 | SRC_URI_append = " \ | 13 | SRC_URI_append = " \ |
14 | file://0001-COPYING-add-GPLv2-license-file.patch \ | 14 | file://0001-COPYING-add-GPLv2-license-file.patch \ |
15 | file://0002-add-setdpi-Xinit.d-script.patch \ | 15 | file://0002-add-setdpi-Xinit.d-script.patch \ |
16 | file://0003-add-89xdgautostart-Xsession.d-script.patch \ | ||
17 | file://0005-add-XWindowManager-Xsession.d-script.patch \ | ||
18 | file://0006-add-support-for-etc-X11-xserver-system.patch \ | 16 | file://0006-add-support-for-etc-X11-xserver-system.patch \ |
19 | file://0007-use-own-functions-file-instead-etc-init.d-functions.patch \ | 17 | file://0007-use-own-functions-file-instead-etc-init.d-functions.patch \ |
20 | file://0008-xserver-common-add-dpi-and-nocursor-params-for-gta01.patch \ | 18 | file://0008-xserver-common-add-dpi-and-nocursor-params-for-gta01.patch \ |
@@ -23,8 +21,8 @@ SRC_URI_append = " \ | |||
23 | file://0011-xserver-common-add-support-for-nexus-one-alias-mahim.patch \ | 21 | file://0011-xserver-common-add-support-for-nexus-one-alias-mahim.patch \ |
24 | file://0012-xserver-common-add-support-for-gta04-alias-OpenPhoen.patch \ | 22 | file://0012-xserver-common-add-support-for-gta04-alias-OpenPhoen.patch \ |
25 | file://0013-xserver-common-add-support-for-tuna-alias-Galaxy-Nex.patch \ | 23 | file://0013-xserver-common-add-support-for-tuna-alias-Galaxy-Nex.patch \ |
26 | file://0014-Xserver-Start-Xsession-like-x11-common-does.patch \ | ||
27 | file://0015-xserver-common-disable-TCP-connections.patch \ | 24 | file://0015-xserver-common-disable-TCP-connections.patch \ |
25 | file://0001-Don-t-install-Xsession-or-Xserver.patch \ | ||
28 | " | 26 | " |
29 | 27 | ||
30 | do_install_append() { | 28 | do_install_append() { |