diff options
author | Ross Burton <ross.burton@arm.com> | 2022-02-25 11:06:27 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-02-28 08:39:26 -0800 |
commit | 272f2083d46a5a023d0d18dcd3e8540a7c5c1cc8 (patch) | |
tree | 9b2786776df9e2aff8e0c9edbcbdd8ba808401d0 | |
parent | ba34834fdd8785faa5cdfa9ea7fb2425b2efdc27 (diff) | |
download | meta-openembedded-272f2083d46a5a023d0d18dcd3e8540a7c5c1cc8.tar.gz |
layer.conf: change layer priority to match oe-core
Layer priority is the ultimate decider of what recipe is used: if layer
A has recipe foo_1 and layer B has recipe foo_2, if layer A's priority
is higher than B then foo_1 will be used, even though the version in B
is higher, and even if PREFERRED_VERSION_foo is set to 2.
This complicates recipes moving between layers, for example when a newer
version of a recipe (say, python3-wheel) is taken from a layer with a
higher priority (say, meta-python) and moved to a layer with a lower
priority (say, oe-core) then it has to be removed before it is added:
there is no way to have it in both layers and work correctly.
Higher priorities are useful in distribution layers where you may want
to override specific recipes without any other fuss. However as all of
the layers in meta-oe simply add more recipes in defined areas, there's
no need to have a higher layer priority.
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-filesystems/conf/layer.conf | 2 | ||||
-rw-r--r-- | meta-gnome/conf/layer.conf | 2 | ||||
-rw-r--r-- | meta-initramfs/conf/layer.conf | 2 | ||||
-rw-r--r-- | meta-multimedia/conf/layer.conf | 2 | ||||
-rw-r--r-- | meta-oe/conf/layer.conf | 2 | ||||
-rw-r--r-- | meta-perl/conf/layer.conf | 2 | ||||
-rw-r--r-- | meta-python/conf/layer.conf | 2 | ||||
-rw-r--r-- | meta-webserver/conf/layer.conf | 2 | ||||
-rw-r--r-- | meta-xfce/conf/layer.conf | 2 |
9 files changed, 9 insertions, 9 deletions
diff --git a/meta-filesystems/conf/layer.conf b/meta-filesystems/conf/layer.conf index b5f59d9ba..75a27d665 100644 --- a/meta-filesystems/conf/layer.conf +++ b/meta-filesystems/conf/layer.conf | |||
@@ -7,7 +7,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \ | |||
7 | 7 | ||
8 | BBFILE_COLLECTIONS += "filesystems-layer" | 8 | BBFILE_COLLECTIONS += "filesystems-layer" |
9 | BBFILE_PATTERN_filesystems-layer = "^${LAYERDIR}/" | 9 | BBFILE_PATTERN_filesystems-layer = "^${LAYERDIR}/" |
10 | BBFILE_PRIORITY_filesystems-layer = "6" | 10 | BBFILE_PRIORITY_filesystems-layer = "5" |
11 | 11 | ||
12 | # This should only be incremented on significant changes that will | 12 | # This should only be incremented on significant changes that will |
13 | # cause compatibility issues with other layers | 13 | # cause compatibility issues with other layers |
diff --git a/meta-gnome/conf/layer.conf b/meta-gnome/conf/layer.conf index 3f6b4f7b7..2fb348515 100644 --- a/meta-gnome/conf/layer.conf +++ b/meta-gnome/conf/layer.conf | |||
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" | |||
6 | 6 | ||
7 | BBFILE_COLLECTIONS += "gnome-layer" | 7 | BBFILE_COLLECTIONS += "gnome-layer" |
8 | BBFILE_PATTERN_gnome-layer := "^${LAYERDIR}/" | 8 | BBFILE_PATTERN_gnome-layer := "^${LAYERDIR}/" |
9 | BBFILE_PRIORITY_gnome-layer = "7" | 9 | BBFILE_PRIORITY_gnome-layer = "5" |
10 | 10 | ||
11 | # auto-pack gnome help files | 11 | # auto-pack gnome help files |
12 | IMAGE_LINGUAS_COMPLEMENTARY:append = " ${@bb.utils.contains('DISTRO_FEATURES','helpfiles','*-help-%s','',d)}" | 12 | IMAGE_LINGUAS_COMPLEMENTARY:append = " ${@bb.utils.contains('DISTRO_FEATURES','helpfiles','*-help-%s','',d)}" |
diff --git a/meta-initramfs/conf/layer.conf b/meta-initramfs/conf/layer.conf index 33e61d333..c63383faf 100644 --- a/meta-initramfs/conf/layer.conf +++ b/meta-initramfs/conf/layer.conf | |||
@@ -13,7 +13,7 @@ BBFILE_PATTERN_meta-initramfs := "^${LAYERDIR}/" | |||
13 | # choosing carefully how this layer interacts with all of the | 13 | # choosing carefully how this layer interacts with all of the |
14 | # other layers. | 14 | # other layers. |
15 | 15 | ||
16 | BBFILE_PRIORITY_meta-initramfs = "8" | 16 | BBFILE_PRIORITY_meta-initramfs = "5" |
17 | LAYERDEPENDS_meta-initramfs = "core" | 17 | LAYERDEPENDS_meta-initramfs = "core" |
18 | 18 | ||
19 | LAYERSERIES_COMPAT_meta-initramfs = "kirkstone" | 19 | LAYERSERIES_COMPAT_meta-initramfs = "kirkstone" |
diff --git a/meta-multimedia/conf/layer.conf b/meta-multimedia/conf/layer.conf index 1fe9c8033..b5120bb53 100644 --- a/meta-multimedia/conf/layer.conf +++ b/meta-multimedia/conf/layer.conf | |||
@@ -23,7 +23,7 @@ LICENSE_PATH += "${LAYERDIR}/licenses" | |||
23 | # choosing carefully how this layer interacts with all of the | 23 | # choosing carefully how this layer interacts with all of the |
24 | # other layers. | 24 | # other layers. |
25 | 25 | ||
26 | BBFILE_PRIORITY_multimedia-layer = "6" | 26 | BBFILE_PRIORITY_multimedia-layer = "5" |
27 | 27 | ||
28 | # This should only be incremented on significant changes that will | 28 | # This should only be incremented on significant changes that will |
29 | # cause compatibility issues with other layers | 29 | # cause compatibility issues with other layers |
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf index 93f3dc580..88715d5e8 100644 --- a/meta-oe/conf/layer.conf +++ b/meta-oe/conf/layer.conf | |||
@@ -21,7 +21,7 @@ BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/" | |||
21 | # choosing carefully how this layer interacts with all of the | 21 | # choosing carefully how this layer interacts with all of the |
22 | # other layers. | 22 | # other layers. |
23 | 23 | ||
24 | BBFILE_PRIORITY_openembedded-layer = "6" | 24 | BBFILE_PRIORITY_openembedded-layer = "5" |
25 | 25 | ||
26 | # only activates content when identified layers are present, | 26 | # only activates content when identified layers are present, |
27 | # to ensure yocto compatibility check pass | 27 | # to ensure yocto compatibility check pass |
diff --git a/meta-perl/conf/layer.conf b/meta-perl/conf/layer.conf index 4f075e9a9..3cb9571d4 100644 --- a/meta-perl/conf/layer.conf +++ b/meta-perl/conf/layer.conf | |||
@@ -7,7 +7,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \ | |||
7 | 7 | ||
8 | BBFILE_COLLECTIONS += "perl-layer" | 8 | BBFILE_COLLECTIONS += "perl-layer" |
9 | BBFILE_PATTERN_perl-layer := "^${LAYERDIR}/" | 9 | BBFILE_PATTERN_perl-layer := "^${LAYERDIR}/" |
10 | BBFILE_PRIORITY_perl-layer = "6" | 10 | BBFILE_PRIORITY_perl-layer = "5" |
11 | 11 | ||
12 | # This should only be incremented on significant changes that will | 12 | # This should only be incremented on significant changes that will |
13 | # cause compatibility issues with other layers | 13 | # cause compatibility issues with other layers |
diff --git a/meta-python/conf/layer.conf b/meta-python/conf/layer.conf index 98f734152..e444498ff 100644 --- a/meta-python/conf/layer.conf +++ b/meta-python/conf/layer.conf | |||
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend" | |||
6 | 6 | ||
7 | BBFILE_COLLECTIONS += "meta-python" | 7 | BBFILE_COLLECTIONS += "meta-python" |
8 | BBFILE_PATTERN_meta-python := "^${LAYERDIR}/" | 8 | BBFILE_PATTERN_meta-python := "^${LAYERDIR}/" |
9 | BBFILE_PRIORITY_meta-python = "7" | 9 | BBFILE_PRIORITY_meta-python = "5" |
10 | 10 | ||
11 | # This should only be incremented on significant changes that will | 11 | # This should only be incremented on significant changes that will |
12 | # cause compatibility issues with other layers | 12 | # cause compatibility issues with other layers |
diff --git a/meta-webserver/conf/layer.conf b/meta-webserver/conf/layer.conf index 312c39b3b..5ae5e796a 100644 --- a/meta-webserver/conf/layer.conf +++ b/meta-webserver/conf/layer.conf | |||
@@ -9,7 +9,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" | |||
9 | 9 | ||
10 | BBFILE_COLLECTIONS += "webserver" | 10 | BBFILE_COLLECTIONS += "webserver" |
11 | BBFILE_PATTERN_webserver := "^${LAYERDIR}/" | 11 | BBFILE_PATTERN_webserver := "^${LAYERDIR}/" |
12 | BBFILE_PRIORITY_webserver = "6" | 12 | BBFILE_PRIORITY_webserver = "5" |
13 | 13 | ||
14 | # This should only be incremented on significant changes that will | 14 | # This should only be incremented on significant changes that will |
15 | # cause compatibility issues with other layers | 15 | # cause compatibility issues with other layers |
diff --git a/meta-xfce/conf/layer.conf b/meta-xfce/conf/layer.conf index be5870867..28dfc5b34 100644 --- a/meta-xfce/conf/layer.conf +++ b/meta-xfce/conf/layer.conf | |||
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" | |||
6 | 6 | ||
7 | BBFILE_COLLECTIONS += "xfce-layer" | 7 | BBFILE_COLLECTIONS += "xfce-layer" |
8 | BBFILE_PATTERN_xfce-layer := "^${LAYERDIR}/" | 8 | BBFILE_PATTERN_xfce-layer := "^${LAYERDIR}/" |
9 | BBFILE_PRIORITY_xfce-layer = "7" | 9 | BBFILE_PRIORITY_xfce-layer = "5" |
10 | 10 | ||
11 | # This should only be incremented on significant changes that will | 11 | # This should only be incremented on significant changes that will |
12 | # cause compatibility issues with other layers | 12 | # cause compatibility issues with other layers |