diff options
author | Christopher Larson <chris_larson@mentor.com> | 2016-05-31 12:36:28 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-06-08 14:55:25 +0200 |
commit | 240e2ebe4371f15fad37b31bd3db83aa0ab42522 (patch) | |
tree | 3f5eb7c6c1e8cc47061f80d4f405b35e90cfb302 | |
parent | 852cd67b916cdbe9f91d5323fe2a6cc790a7a0eb (diff) | |
download | meta-openembedded-240e2ebe4371f15fad37b31bd3db83aa0ab42522.tar.gz |
plymouth: allow disabling the dracut dep
Add a 'initrd' PACKAGECONFIG to disable emission of the plymouth-initrd
package which includes initramfs files for use by dracut. Disabling this will
avoid the runtime dependency on dracut, which is useful if one doesn't need or
want dracut and doesn't want to pull in meta-initramfs.
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb | 18 |
1 files changed, 11 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb index 9ca850281..de23dcd5b 100644 --- a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb +++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb | |||
@@ -24,29 +24,33 @@ EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-docum | |||
24 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \ | 24 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \ |
25 | " | 25 | " |
26 | 26 | ||
27 | PACKAGECONFIG ??= "pango initrd" | ||
28 | PACKAGECONFIG_append_x86 = " drm" | ||
29 | PACKAGECONFIG_append_x86-64 = " drm" | ||
30 | |||
27 | PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm" | 31 | PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm" |
28 | PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango" | 32 | PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango" |
29 | PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+" | 33 | PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+" |
30 | 34 | PACKAGECONFIG[initrd] = ",,," | |
31 | PACKAGECONFIG ??= "pango" | ||
32 | 35 | ||
33 | LOGO ??= "${datadir}/plymouth/bizcom.png" | 36 | LOGO ??= "${datadir}/plymouth/bizcom.png" |
34 | 37 | ||
35 | PACKAGECONFIG_append_x86 = " drm" | ||
36 | PACKAGECONFIG_append_x86-64 = " drm" | ||
37 | |||
38 | inherit autotools pkgconfig systemd | 38 | inherit autotools pkgconfig systemd |
39 | 39 | ||
40 | |||
41 | do_install_append() { | 40 | do_install_append() { |
42 | install -d ${D}${systemd_unitdir}/system | 41 | install -d ${D}${systemd_unitdir}/system |
43 | install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system | 42 | install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system |
44 | install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system | 43 | install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system |
45 | # Remove /var/run from package as plymouth will populate it on startup | 44 | # Remove /var/run from package as plymouth will populate it on startup |
46 | rm -fr "${D}${localstatedir}/run" | 45 | rm -fr "${D}${localstatedir}/run" |
46 | |||
47 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then | ||
48 | rm -rf "${D}${libexecdir}" | ||
49 | fi | ||
47 | } | 50 | } |
48 | 51 | ||
49 | PACKAGES =+ "${PN}-initrd ${PN}-set-default-theme" | 52 | PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}" |
53 | PACKAGES =+ "${PN}-set-default-theme" | ||
50 | 54 | ||
51 | FILES_${PN}-initrd = "${libexecdir}/plymouth/*" | 55 | FILES_${PN}-initrd = "${libexecdir}/plymouth/*" |
52 | FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme" | 56 | FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme" |