diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2019-08-16 10:39:55 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-08-17 01:42:54 -0700 |
commit | 19dd354c28a0d6fc8b132023f1638f1b6f1dd7cd (patch) | |
tree | 982c03fc43e79ec56ad963e391cf6de7260f5fd2 | |
parent | 803dd59f72a7cfe12e8ca8d5c8e34b1530edac0c (diff) | |
download | meta-openembedded-19dd354c28a0d6fc8b132023f1638f1b6f1dd7cd.tar.gz |
dnf-plugin-tui: add runtime dependency on bash
* fixes:
ERROR: QA Issue: /usr/lib/python3.7/site-packages/dnf-plugins/dnf-host contained in package dnf-plugin-tui requires /bin/bash, but no providers found in RDEPENDS_dnf-plugin-tui? [file-rdeps]
* fix the indentation as well
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb | 25 |
1 files changed, 13 insertions, 12 deletions
diff --git a/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb b/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb index e891868cd..a8367b5d9 100644 --- a/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb +++ b/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb | |||
@@ -14,25 +14,26 @@ inherit distutils3-base | |||
14 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
15 | 15 | ||
16 | do_install_append() { | 16 | do_install_append() { |
17 | install -d ${D}${datadir}/dnf | 17 | install -d ${D}${datadir}/dnf |
18 | install -m 0755 ${S}/samples/* ${D}${datadir}/dnf | 18 | install -m 0755 ${S}/samples/* ${D}${datadir}/dnf |
19 | install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg | 19 | install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg |
20 | install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg | 20 | install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg |
21 | for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do | 21 | for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do |
22 | install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins | 22 | install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins |
23 | done | 23 | done |
24 | } | 24 | } |
25 | 25 | ||
26 | do_install_append_class-target() { | 26 | do_install_append_class-target() { |
27 | install -d ${D}${sysconfdir}/yum.repos.d | 27 | install -d ${D}${sysconfdir}/yum.repos.d |
28 | install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d | 28 | install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d |
29 | } | 29 | } |
30 | 30 | ||
31 | FILES_${PN} += "${datadir}/dnf" | 31 | FILES_${PN} += "${datadir}/dnf" |
32 | 32 | ||
33 | RDEPENDS_${PN} += " \ | 33 | RDEPENDS_${PN} += " \ |
34 | dnf \ | 34 | bash \ |
35 | libnewt-python \ | 35 | dnf \ |
36 | " | 36 | libnewt-python \ |
37 | " | ||
37 | 38 | ||
38 | BBCLASSEXTEND = "nativesdk" | 39 | BBCLASSEXTEND = "nativesdk" |