diff options
author | Wenzong Fan <wenzong.fan@windriver.com> | 2015-09-07 23:16:07 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-09-23 15:34:26 +0200 |
commit | 18225da7505bfc5b43a700706e548bdba54e84bd (patch) | |
tree | 13ed118bc341098279a28bc3cc1f9e88c914d552 | |
parent | 9b3b58bb3ac3591891b927954da1fbbfa3a2349c (diff) | |
download | meta-openembedded-18225da7505bfc5b43a700706e548bdba54e84bd.tar.gz |
imagemagick: add alternatives for binaries/docs
The binaries/docs that generated by imagemagick has suffix '.im6',
use update-alternatives to add alternatives for them.
Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb | 45 |
1 files changed, 44 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb b/meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb index 2ef3e75da..12604c057 100644 --- a/meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb +++ b/meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb | |||
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "07a2de28f7f9ab888ef47c02eb7e10cc3e0dd0e9797c5d71d6e71d19f8 | |||
16 | 16 | ||
17 | S = "${WORKDIR}/ImageMagick-${PV}-${PATCHSET}" | 17 | S = "${WORKDIR}/ImageMagick-${PV}-${PATCHSET}" |
18 | 18 | ||
19 | inherit autotools pkgconfig | 19 | inherit autotools pkgconfig update-alternatives |
20 | 20 | ||
21 | # xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2 | 21 | # xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2 |
22 | # if someone needs xml support then fix it first | 22 | # if someone needs xml support then fix it first |
@@ -43,3 +43,46 @@ FILES_${PN}-dev += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.a" | |||
43 | FILES_${PN}-dbg += "${libdir}/ImageMagick-${PV}/modules-Q16/*/.debug/*" | 43 | FILES_${PN}-dbg += "${libdir}/ImageMagick-${PV}/modules-Q16/*/.debug/*" |
44 | 44 | ||
45 | BBCLASSEXTEND = "native" | 45 | BBCLASSEXTEND = "native" |
46 | |||
47 | ALTERNATIVE_PRIORITY = "100" | ||
48 | |||
49 | ALTERNATIVE_${PN} = "animate compare composite conjure convert display \ | ||
50 | identify import mogrify montage stream" | ||
51 | |||
52 | ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im6" | ||
53 | ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im6" | ||
54 | ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im6" | ||
55 | ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im6" | ||
56 | ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im6" | ||
57 | ALTERNATIVE_TARGET[display] = "${bindir}/display.im6" | ||
58 | ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im6" | ||
59 | ALTERNATIVE_TARGET[import] = "${bindir}/import.im6" | ||
60 | ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im6" | ||
61 | ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im6" | ||
62 | ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im6" | ||
63 | |||
64 | ALTERNATIVE_${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \ | ||
65 | convert.1 display.1 identify.1 import.1 mogrify.1 montage.1 stream.1" | ||
66 | |||
67 | ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1" | ||
68 | ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im6.1" | ||
69 | ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1" | ||
70 | ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im6.1" | ||
71 | ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1" | ||
72 | ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im6.1" | ||
73 | ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1" | ||
74 | ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im6.1" | ||
75 | ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1" | ||
76 | ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im6.1" | ||
77 | ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1" | ||
78 | ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im6.1" | ||
79 | ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1" | ||
80 | ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im6.1" | ||
81 | ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1" | ||
82 | ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im6.1" | ||
83 | ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1" | ||
84 | ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im6.1" | ||
85 | ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1" | ||
86 | ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im6.1" | ||
87 | ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1" | ||
88 | ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im6.1" | ||