summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-15 12:51:19 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-16 12:52:19 -0800
commit1544ca4eb7590fbd11a74c1bb9396e0fec3448d8 (patch)
treef707212a36e4bbb71fb767375320cbb12687d42f
parent9f709be1083ef6d36bb8f6950b978ab209319670 (diff)
downloadmeta-openembedded-1544ca4eb7590fbd11a74c1bb9396e0fec3448d8.tar.gz
python3-crcmod: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-crcmod.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-crcmod_1.7.bb16
2 files changed, 14 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-crcmod.inc b/meta-python/recipes-devtools/python/python-crcmod.inc
deleted file mode 100644
index 85da7cb3c..000000000
--- a/meta-python/recipes-devtools/python/python-crcmod.inc
+++ /dev/null
@@ -1,14 +0,0 @@
1SUMMARY = "A Python module for generating objects that compute the Cyclic Redundancy Check."
2HOMEPAGE = "https://pypi.org/project/crcmod"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a19291627cad2d1dfbfcf3c9fb85c2"
6
7SRC_URI[md5sum] = "2d5b92117d958dcead94f9e17f54cd32"
8SRC_URI[sha256sum] = "dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e"
9
10inherit pypi
11
12RDEPENDS_${PN} += "${PYTHON_PN}-unittest"
13
14BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb b/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb
index 6996b13d0..14a344f76 100644
--- a/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb
+++ b/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb
@@ -1,2 +1,14 @@
1inherit setuptools3 1SUMMARY = "A Python module for generating objects that compute the Cyclic Redundancy Check."
2require python-crcmod.inc 2HOMEPAGE = "https://pypi.org/project/crcmod"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a19291627cad2d1dfbfcf3c9fb85c2"
6
7SRC_URI[md5sum] = "2d5b92117d958dcead94f9e17f54cd32"
8SRC_URI[sha256sum] = "dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e"
9
10inherit pypi setuptools3
11
12RDEPENDS_${PN} += "${PYTHON_PN}-unittest"
13
14BBCLASSEXTEND = "native nativesdk"