diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-06-22 20:25:50 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-06-24 12:54:18 -0700 |
commit | 13fadb1d03085322d317fdcce22ba5bb22bbe76c (patch) | |
tree | 056aae850ed3613ed6fe2949389cc0ef5b5425cc | |
parent | 806bd77a505b37abe9c173cdd554cc6486406a35 (diff) | |
download | meta-openembedded-13fadb1d03085322d317fdcce22ba5bb22bbe76c.tar.gz |
python3-process-tests: Add recipe
Needed by ptests of other modules
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r-- | meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | 1 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb | 15 |
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb index 090b9802d..9c44d38ce 100644 --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | |||
@@ -278,6 +278,7 @@ RDEPENDS_packagegroup-meta-python3 = "\ | |||
278 | python3-pretend \ | 278 | python3-pretend \ |
279 | python3-prettytable \ | 279 | python3-prettytable \ |
280 | python3-priority \ | 280 | python3-priority \ |
281 | python3-process-tests \ | ||
281 | python3-progress \ | 282 | python3-progress \ |
282 | python3-prompt-toolkit \ | 283 | python3-prompt-toolkit \ |
283 | python3-protobuf \ | 284 | python3-protobuf \ |
diff --git a/meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb b/meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb new file mode 100644 index 000000000..dccdeb7a0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Tools for testing processes." | ||
5 | HOMEPAGE = "https://github.com/ionelmc/python-process-tests" | ||
6 | LICENSE = "BSD-2-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=37031056aff37e4b3310872a9a3d0b1e" | ||
8 | |||
9 | SRC_URI[sha256sum] = "a3747ad947bdfc93e5c986bdb17a6d718f3f26e8577a0807a00962f29e26deba" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | RDEPENDS_${PN} += "python3-core" | ||
14 | |||
15 | BBCLASSEXTEND = "native nativesdk" | ||