summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:52 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commit103354c765b833958c3fffc4887d0e49768b1d35 (patch)
tree63320dbcbfee621884269f1e4919c5bd06ce225d
parentd7458db05456fb21be0204cda70fc137a6ff8957 (diff)
downloadmeta-openembedded-103354c765b833958c3fffc4887d0e49768b1d35.tar.gz
python3-web3: new package
Add a recipe for web3: a library for interacting with Ethereum. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-web3_5.29.0.bb20
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 2bf26fc69..d08908939 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -443,6 +443,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
443 python3-visitor \ 443 python3-visitor \
444 python3-waitress \ 444 python3-waitress \
445 python3-watchdog \ 445 python3-watchdog \
446 python3-web3 \
446 python3-webcolors \ 447 python3-webcolors \
447 python3-webencodings \ 448 python3-webencodings \
448 python3-websocket-client \ 449 python3-websocket-client \
diff --git a/meta-python/recipes-devtools/python/python3-web3_5.29.0.bb b/meta-python/recipes-devtools/python/python3-web3_5.29.0.bb
new file mode 100644
index 000000000..660d4f6f0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-web3_5.29.0.bb
@@ -0,0 +1,20 @@
1SUMMARY = "A Python library for interacting with Ethereum."
2HOMEPAGE = "https://github.com/ethereum/web3.py"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dc2732bdc5e50382737979791cbb3b7"
6
7SRC_URI[sha256sum] = "a78acc0f0150013755398ae185c8c7063d9db0777aa09733de22242a746bd30c"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-aiohttp \
13 python3-distutils \
14 python3-eth-account \
15 python3-idna \
16 python3-lru-dict \
17 python3-requests \
18 python3-setuptools \
19 python3-websockets \
20"