summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2022-03-16 22:02:13 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-17 08:18:31 -0700
commit0dd33989a83b411b9aebcac45feec0738faed430 (patch)
tree1a835630c1dd4e1231324d2bf524040fe6fa8460
parentb4b29dd6a7a648735c4d43b19a2e838e138b033d (diff)
downloadmeta-openembedded-0dd33989a83b411b9aebcac45feec0738faed430.tar.gz
netplan: fix parallel build failure
Backport a patch to fix the parallel build failure: src/dbus.c:17:10: fatal error: _features.h: No such file or directory Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch44
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan_0.104.bb1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch
new file mode 100644
index 000000000..2149ee30c
--- /dev/null
+++ b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch
@@ -0,0 +1,44 @@
1From 2e84550b47b475d830622f41576992a1d45d6af0 Mon Sep 17 00:00:00 2001
2From: Zhao Yi <38274519+yizhao1@users.noreply.github.com>
3Date: Tue, 15 Mar 2022 19:28:26 +0800
4Subject: [PATCH] Makefile: fix parallel build failure (#267)
5
6* Makefile: fix parallel build failure
7
8Add src/_features.h as dependency for dbus.o to fix the parallel build
9failure:
10src/dbus.c:17:10: fatal error: _features.h: No such file or directory
11
12Upstream-Status: Backport
13[https://github.com/canonical/netplan/commit/2e84550b47b475d830622f41576992a1d45d6af0]
14
15Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
16---
17 Makefile | 4 ++--
18 1 file changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/Makefile b/Makefile
21index 0368e41..8ac7432 100644
22--- a/Makefile
23+++ b/Makefile
24@@ -52,7 +52,7 @@ NOSETESTS3 ?= $(shell command -v nosetests-3 || command -v nosetests3 || echo tr
25
26 default: netplan/_features.py generate netplan-dbus dbus/io.netplan.Netplan.service doc/netplan.html doc/netplan.5 doc/netplan-generate.8 doc/netplan-apply.8 doc/netplan-try.8 doc/netplan-dbus.8 doc/netplan-get.8 doc/netplan-set.8
27
28-%.o: src/%.c
29+%.o: src/%.c src/_features.h
30 $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -c $^ `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
31
32 libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds
33@@ -62,7 +62,7 @@ libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds
34 generate: libnetplan.so.$(NETPLAN_SOVER) generate.o
35 $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$^) -L. -lnetplan `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
36
37-netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) src/_features.h dbus.o
38+netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) dbus.o
39 $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$(patsubst %.h,,$^)) -L. -lnetplan `pkg-config --cflags --libs libsystemd glib-2.0 gio-2.0 yaml-0.1 uuid`
40
41 src/_features.h: src/[^_]*.[hc]
42--
432.25.1
44
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
index e19fceb4a..ea944fa9d 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
+++ b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
@@ -16,6 +16,7 @@ PV = "0.104"
16 16
17SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \ 17SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \
18 file://0001-Makefile-do-not-use-Werror.patch \ 18 file://0001-Makefile-do-not-use-Werror.patch \
19 file://0001-Makefile-fix-parallel-build-failure.patch \
19 " 20 "
20 21
21SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch" 22SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch"