diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-08-24 13:22:16 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-08-25 23:08:11 -0700 |
commit | 0d8fbade0bb3c725c8fa0ac5657de5220a75b6b6 (patch) | |
tree | a949ef225bfbfdb887673a65b95228723ca6dc34 | |
parent | 03b66442a5bd2928d84a222d0e949bbaca3304c8 (diff) | |
download | meta-openembedded-0d8fbade0bb3c725c8fa0ac5657de5220a75b6b6.tar.gz |
neon: Upgrade to 0.32.2
Drop libxml2-config patch, its not needed anymore
Do not install documentation, it does not cross build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/neon/neon/0001-Disable-installing-documentation.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-support/neon/neon/fix-package-check-for-libxml2.patch | 50 | ||||
-rw-r--r-- | meta-oe/recipes-support/neon/neon_0.32.2.bb (renamed from meta-oe/recipes-support/neon/neon_0.30.2.bb) | 29 |
3 files changed, 48 insertions, 59 deletions
diff --git a/meta-oe/recipes-support/neon/neon/0001-Disable-installing-documentation.patch b/meta-oe/recipes-support/neon/neon/0001-Disable-installing-documentation.patch new file mode 100644 index 000000000..1f63df27a --- /dev/null +++ b/meta-oe/recipes-support/neon/neon/0001-Disable-installing-documentation.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From f477408f1c24ce6e5589e5a99d369279916c7c6e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 24 Aug 2022 13:11:12 -0700 | ||
4 | Subject: [PATCH] Disable installing documentation | ||
5 | |||
6 | It does not build | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | Makefile.in | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/Makefile.in b/Makefile.in | ||
14 | index ed87a69..c32405c 100644 | ||
15 | --- a/Makefile.in | ||
16 | +++ b/Makefile.in | ||
17 | @@ -125,7 +125,7 @@ Makefile: $(srcdir)/Makefile.in | ||
18 | neon-config: $(srcdir)/neon-config.in | ||
19 | @./config.status neon-config | ||
20 | |||
21 | -install-docs: install-man install-html | ||
22 | +install-docs: | ||
23 | |||
24 | install-html: | ||
25 | $(INSTALL) -d $(DESTDIR)$(docdir)/html | ||
26 | -- | ||
27 | 2.37.2 | ||
28 | |||
diff --git a/meta-oe/recipes-support/neon/neon/fix-package-check-for-libxml2.patch b/meta-oe/recipes-support/neon/neon/fix-package-check-for-libxml2.patch deleted file mode 100644 index 92a05c0ef..000000000 --- a/meta-oe/recipes-support/neon/neon/fix-package-check-for-libxml2.patch +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | neon: Change the neon configure to use pkg-config instead of xml2-config | ||
2 | |||
3 | xml2-config is broken for neon | ||
4 | if packageconfig libxml2, webdav, zlib is enabled for neon | ||
5 | we get the following configure error in the yocto build | ||
6 | |||
7 | | configure: WebDAV support is enabled | ||
8 | | checking for xml2-config... xml2-config | ||
9 | | ERROR: /usr/bin/xml2-config should not be used, use an alternative such as pkg-config | ||
10 | | ERROR: /usr/bin/xml2-config should not be used, use an alternative such as pkg-config | ||
11 | | ERROR: /usr/bin/xml2-config should not be used, use an alternative such as pkg-config | ||
12 | | checking libxml/xmlversion.h usability... no | ||
13 | | checking libxml/xmlversion.h presence... no | ||
14 | | checking for libxml/xmlversion.h... no | ||
15 | | configure: error: could not find parser.h, libxml installation problem? | ||
16 | | WARNING: exit code 1 from a shell command. | ||
17 | |||
18 | The patch lets configure use pkg-config | ||
19 | |||
20 | Upstream-Status: inappropriate | ||
21 | (Upstream suggests to use latest 0.31 as per the discussion | ||
22 | https://github.com/notroj/neon/discussions/47) | ||
23 | |||
24 | Signed-off-by: Nisha Parrakat <Nisha.Parrakat@kpit.com> | ||
25 | --- a/macros/neon-xml-parser.m4 2008-07-19 23:52:35.000000000 +0200 | ||
26 | +++ b/macros/neon-xml-parser.m4 2021-02-15 23:56:59.202751257 +0100 | ||
27 | @@ -44,17 +44,17 @@ | ||
28 | |||
29 | dnl Find libxml2: run $1 if found, else $2 | ||
30 | AC_DEFUN([NE_XML_LIBXML2], [ | ||
31 | -AC_CHECK_PROG(XML2_CONFIG, xml2-config, xml2-config) | ||
32 | +AC_CHECK_PROG(XML2_CONFIG, pkg-config, pkg-config) | ||
33 | if test -n "$XML2_CONFIG"; then | ||
34 | - neon_xml_parser_message="libxml `$XML2_CONFIG --version`" | ||
35 | AC_DEFINE(HAVE_LIBXML, 1, [Define if you have libxml]) | ||
36 | - # xml2-config in some versions erroneously includes -I/include | ||
37 | - # in the --cflags output. | ||
38 | - CPPFLAGS="$CPPFLAGS `$XML2_CONFIG --cflags | sed 's| -I/include||g'`" | ||
39 | - NEON_LIBS="$NEON_LIBS `$XML2_CONFIG --libs | sed 's|-L/usr/lib ||g'`" | ||
40 | + PKG_CHECK_MODULES(XML, libxml-2.0 >= 2.4) | ||
41 | + AC_MSG_NOTICE([libxmlfound CFlags : , ${XML_CFLAGS}]) | ||
42 | + CPPFLAGS="$CPPFLAGS ${XML_CFLAGS}" | ||
43 | + NEON_LIBS="$NEON_LIBS ${XML_LIBS}" | ||
44 | AC_CHECK_HEADERS(libxml/xmlversion.h libxml/parser.h,,[ | ||
45 | AC_MSG_ERROR([could not find parser.h, libxml installation problem?])]) | ||
46 | neon_xml_parser=libxml2 | ||
47 | + neon_xml_parser_message="libxml2" | ||
48 | else | ||
49 | $1 | ||
50 | fi | ||
diff --git a/meta-oe/recipes-support/neon/neon_0.30.2.bb b/meta-oe/recipes-support/neon/neon_0.32.2.bb index 646a9eca1..0f4e97198 100644 --- a/meta-oe/recipes-support/neon/neon_0.30.2.bb +++ b/meta-oe/recipes-support/neon/neon_0.32.2.bb | |||
@@ -3,35 +3,46 @@ HOMEPAGE = "http://www.webdav.org/neon/" | |||
3 | SECTION = "libs" | 3 | SECTION = "libs" |
4 | LICENSE = "LGPL-2.0-or-later" | 4 | LICENSE = "LGPL-2.0-or-later" |
5 | LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \ | 5 | LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \ |
6 | file://src/ne_utils.h;beginline=1;endline=20;md5=2caca609538eddaa6f6adf120a218037" | 6 | file://src/ne_utils.h;beginline=1;endline=20;md5=34c8e338bfa0237561e68d30c3c71133" |
7 | 7 | ||
8 | SRC_URI = "${DEBIAN_MIRROR}/main/n/neon27/neon27_${PV}.orig.tar.gz \ | 8 | SRC_URI = "${DEBIAN_MIRROR}/main/n/neon27/neon27_${PV}.orig.tar.gz \ |
9 | file://pkgconfig.patch \ | 9 | file://pkgconfig.patch \ |
10 | file://fix-package-check-for-libxml2.patch \ | 10 | file://0001-Disable-installing-documentation.patch \ |
11 | file://run-ptest \ | 11 | file://run-ptest \ |
12 | " | 12 | " |
13 | 13 | ||
14 | SRC_URI[md5sum] = "e28d77bf14032d7f5046b3930704ef41" | 14 | SRC_URI[sha256sum] = "7a25ba2c9223676b9aaec22a585a0ca118127bad71deed0b9ed6cd960fe5c353" |
15 | SRC_URI[sha256sum] = "db0bd8cdec329b48f53a6f00199c92d5ba40b0f015b153718d1b15d3d967fbca" | ||
16 | 15 | ||
17 | inherit autotools binconfig-disabled lib_package pkgconfig ptest | 16 | inherit autotools-brokensep binconfig-disabled lib_package pkgconfig ptest |
18 | 17 | ||
19 | # Enable gnutls or openssl, not both | 18 | # Enable gnutls or openssl, not both |
20 | PACKAGECONFIG ?= "expat gnutls libproxy webdav zlib" | 19 | PACKAGECONFIG ?= "expat gnutls libproxy webdav zlib nls" |
21 | PACKAGECONFIG:class-native = "expat gnutls webdav zlib" | 20 | PACKAGECONFIG:class-native = "expat gnutls webdav zlib nls" |
21 | PACKAGECONFIG:remove:libc-musl = "nls" | ||
22 | 22 | ||
23 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat" | 23 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat" |
24 | PACKAGECONFIG[gnutls] = "--with-ssl=gnutls,,gnutls" | 24 | PACKAGECONFIG[gnutls] = "--with-ssl=gnutls,,gnutls" |
25 | PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5" | 25 | PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5" |
26 | PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy" | 26 | PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy" |
27 | PACKAGECONFIG[libxml2] = "--with-libxml2,--without-libxml2,libxml2" | 27 | PACKAGECONFIG[libxml2] = "--with-libxml2,--without-libxml2,libxml2" |
28 | PACKAGECONFIG[nls] = ",--disable-nls,gettext-native" | ||
28 | PACKAGECONFIG[openssl] = "--with-ssl=openssl,,openssl" | 29 | PACKAGECONFIG[openssl] = "--with-ssl=openssl,,openssl" |
29 | PACKAGECONFIG[webdav] = "--enable-webdav,--disable-webdav," | 30 | PACKAGECONFIG[webdav] = "--enable-webdav,--disable-webdav," |
30 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib" | 31 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib" |
31 | 32 | ||
32 | EXTRA_OECONF += "--enable-shared" | 33 | EXTRA_OECONF += "--enable-shared --enable-threadsafe-ssl=posix" |
34 | |||
35 | # Do not install into /usr/local | ||
36 | EXTRA_OEMAKE:append:class-native = "prefix=${prefix_native}" | ||
37 | |||
38 | do_configure:prepend() { | ||
39 | echo "${PV}" > ${S}/.version | ||
40 | } | ||
33 | 41 | ||
34 | do_compile:append() { | 42 | do_compile:append() { |
43 | if ${@bb.utils.contains('PACKAGECONFIG', 'nls', 'true', 'false', d)}; then | ||
44 | oe_runmake compile-gmo | ||
45 | fi | ||
35 | oe_runmake -C test | 46 | oe_runmake -C test |
36 | } | 47 | } |
37 | 48 | ||