diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2020-08-28 21:01:34 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-28 17:16:57 -0700 |
commit | 00bd5ad72f3fef26127b1579d9870cd681725893 (patch) | |
tree | b3aeb185873ca85f813b199a1177039a03ef4983 | |
parent | 3bc89dc7b3acf0c6c349d929f0e69e889b1eb1c8 (diff) | |
download | meta-openembedded-00bd5ad72f3fef26127b1579d9870cd681725893.tar.gz |
nss: fix postinst in do_rootfs for target
Partially revert "nss: fix postinst script for nativesdk build"
This reverts commit 31552510b15c1c97aa6cbe180c2bb53d139efbcc.
When running in do_rootfs we need to run shlibsign provided
by nss-native, otherwise it fails when /usr/bin/shlibsign
doesn't exist on host builder:
do_rootfs: Postinstall scriptlets of ['nss'] have failed. If the intention is to defer them to first boot,
then please place them into pkg_postinst_ontarget_${PN} ().
Deferring to first boot via 'exit 1' is no longer supported.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/nss/nss_3.56.bb | 27 |
1 files changed, 14 insertions, 13 deletions
diff --git a/meta-oe/recipes-support/nss/nss_3.56.bb b/meta-oe/recipes-support/nss/nss_3.56.bb index 4aa5d29ec..107b0a015 100644 --- a/meta-oe/recipes-support/nss/nss_3.56.bb +++ b/meta-oe/recipes-support/nss/nss_3.56.bb | |||
@@ -238,20 +238,21 @@ do_install_append_class-target() { | |||
238 | } | 238 | } |
239 | 239 | ||
240 | PACKAGE_WRITE_DEPS += "nss-native" | 240 | PACKAGE_WRITE_DEPS += "nss-native" |
241 | |||
241 | pkg_postinst_${PN} () { | 242 | pkg_postinst_${PN} () { |
242 | if [ -n "$D" ]; then | 243 | for I in $D${libdir}/lib*.chk; do |
243 | for I in $D${libdir}/lib*.chk; do | 244 | DN=`dirname $I` |
244 | DN=`dirname $I` | 245 | BN=`basename $I .chk` |
245 | BN=`basename $I .chk` | 246 | FN=$DN/$BN.so |
246 | FN=$DN/$BN.so | 247 | shlibsign -i $FN |
247 | ${bindir}/shlibsign -i $FN | 248 | if [ $? -ne 0 ]; then |
248 | if [ $? -ne 0 ]; then | 249 | echo "shlibsign -i $FN failed" |
249 | exit 1 | 250 | fi |
250 | fi | 251 | done |
251 | done | 252 | } |
252 | else | 253 | |
253 | ${bindir}/signlibs.sh | 254 | pkg_postinst_ontarget_${PN} () { |
254 | fi | 255 | ${bindir}/signlibs.sh |
255 | } | 256 | } |
256 | 257 | ||
257 | PACKAGES =+ "${PN}-smime" | 258 | PACKAGES =+ "${PN}-smime" |