summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-02-15 12:09:18 +0100
committerArmin Kuster <akuster808@gmail.com>2023-02-15 08:02:50 -0500
commit30f4c2b3ae182513b967185e06bc8409a0ee6092 (patch)
tree8549146968dccc7484bda094b9e9951fb99cb45c
parent5785e5ddd86cc1ce8add5936c020a166f65d8c88 (diff)
downloadmeta-openembedded-30f4c2b3ae182513b967185e06bc8409a0ee6092.tar.gz
mdns: use git fetcher
* https://opensource.apple.com/tarballs/mDNSResponder/mDNSResponder-${PV}.tar.gz is just redirect to unsafe github archives which are regenerated from time to time. * We do have src-uri-bad QA check which prevents to use github archives in SRC_URI since 2019: https://github.com/openembedded/openembedded-core/commit/21f84fcdd659544437fe393285c407e1e9432043 but this cannot catch such redirects, see: $ wget https://opensource.apple.com/tarballs/mDNSResponder/mDNSResponder-878.30.4.tar.gz --2023-01-31 10:06:02-- https://opensource.apple.com/tarballs/mDNSResponder/mDNSResponder-878.30.4.tar.gz Resolving opensource.apple.com (opensource.apple.com)... 17.253.73.203, 17.253.73.206, 2a01:b740:a26:f000::5, ... Connecting to opensource.apple.com (opensource.apple.com)|17.253.73.203|:443... connected. HTTP request sent, awaiting response... 302 Redirect Location: https://github.com/apple-oss-distributions/mDNSResponder/archive/refs/tags/mDNSResponder-878.30.4.tar.gz [following] --2023-01-31 10:06:02-- https://github.com/apple-oss-distributions/mDNSResponder/archive/refs/tags/mDNSResponder-878.30.4.tar.gz Resolving github.com (github.com)... 140.82.121.3 Connecting to github.com (github.com)|140.82.121.3|:443... connected. HTTP request sent, awaiting response... 302 Found Location: https://codeload.github.com/apple-oss-distributions/mDNSResponder/tar.gz/refs/tags/mDNSResponder-878.30.4 [following] --2023-01-31 10:06:02-- https://codeload.github.com/apple-oss-distributions/mDNSResponder/tar.gz/refs/tags/mDNSResponder-878.30.4 Resolving codeload.github.com (codeload.github.com)... 140.82.121.10 Connecting to codeload.github.com (codeload.github.com)|140.82.121.10|:443... connected. HTTP request sent, awaiting response... 200 OK Length: unspecified [application/x-gzip] Saving to: ?mDNSResponder-878.30.4.tar.gz? * The tarball was regenerated recently as discussed in: https://github.com/orgs/community/discussions/45830 * Use top-level directory in S to fix DEBUG_PREFIX_MAP usage like the version in master does, the only exception here is that there still was top-level Makefile (which fails to set VER with: Makefile:26: *** missing separator. Stop. so use the simple one like newer version in master) * it's already included in master as part of version upgrade in: https://github.com/openembedded/meta-openembedded/commit/ec96eb577bd518b89e2e7834bd569ba269df458f Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0001-Create-subroutine-for-cleaning-recent-interfaces.patch (renamed from meta-networking/recipes-protocols/mdns/files/0001-Create-subroutine-for-cleaning-recent-interfaces.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0001-dns-sd-Include-missing-headers.patch (renamed from meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0001-mdns-include-stddef.h-for-NULL.patch (renamed from meta-networking/recipes-protocols/mdns/files/0001-mdns-include-stddef.h-for-NULL.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0002-Create-subroutine-for-tearing-down-an-interface.patch (renamed from meta-networking/recipes-protocols/mdns/files/0002-Create-subroutine-for-tearing-down-an-interface.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0002-mdns-cross-compilation-fixes-for-bitbake.patch (renamed from meta-networking/recipes-protocols/mdns/files/0002-mdns-cross-compilation-fixes-for-bitbake.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0003-Track-interface-socket-family.patch (renamed from meta-networking/recipes-protocols/mdns/files/0003-Track-interface-socket-family.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0004-Use-list-for-changed-interfaces.patch (renamed from meta-networking/recipes-protocols/mdns/files/0004-Use-list-for-changed-interfaces.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0006-Remove-unneeded-function.patch (renamed from meta-networking/recipes-protocols/mdns/files/0006-Remove-unneeded-function.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0006-make-Add-top-level-Makefile.patch175
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0008-Mark-deleted-interfaces-as-being-changed.patch (renamed from meta-networking/recipes-protocols/mdns/files/0008-Mark-deleted-interfaces-as-being-changed.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0009-Fix-possible-NULL-dereference.patch (renamed from meta-networking/recipes-protocols/mdns/files/0009-Fix-possible-NULL-dereference.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0010-Handle-errors-from-socket-calls.patch (renamed from meta-networking/recipes-protocols/mdns/files/0010-Handle-errors-from-socket-calls.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/0011-Change-a-dynamic-allocation-to-file-scope-variable.patch (renamed from meta-networking/recipes-protocols/mdns/files/0011-Change-a-dynamic-allocation-to-file-scope-variable.patch)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns/mdns.service (renamed from meta-networking/recipes-protocols/mdns/files/mdns.service)0
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb44
15 files changed, 203 insertions, 16 deletions
diff --git a/meta-networking/recipes-protocols/mdns/files/0001-Create-subroutine-for-cleaning-recent-interfaces.patch b/meta-networking/recipes-protocols/mdns/mdns/0001-Create-subroutine-for-cleaning-recent-interfaces.patch
index f8efc1044..f8efc1044 100644
--- a/meta-networking/recipes-protocols/mdns/files/0001-Create-subroutine-for-cleaning-recent-interfaces.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0001-Create-subroutine-for-cleaning-recent-interfaces.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch b/meta-networking/recipes-protocols/mdns/mdns/0001-dns-sd-Include-missing-headers.patch
index c743b3edd..c743b3edd 100644
--- a/meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0001-dns-sd-Include-missing-headers.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0001-mdns-include-stddef.h-for-NULL.patch b/meta-networking/recipes-protocols/mdns/mdns/0001-mdns-include-stddef.h-for-NULL.patch
index c57ce8fa5..c57ce8fa5 100644
--- a/meta-networking/recipes-protocols/mdns/files/0001-mdns-include-stddef.h-for-NULL.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0001-mdns-include-stddef.h-for-NULL.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0002-Create-subroutine-for-tearing-down-an-interface.patch b/meta-networking/recipes-protocols/mdns/mdns/0002-Create-subroutine-for-tearing-down-an-interface.patch
index 21ba31849..21ba31849 100644
--- a/meta-networking/recipes-protocols/mdns/files/0002-Create-subroutine-for-tearing-down-an-interface.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0002-Create-subroutine-for-tearing-down-an-interface.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0002-mdns-cross-compilation-fixes-for-bitbake.patch b/meta-networking/recipes-protocols/mdns/mdns/0002-mdns-cross-compilation-fixes-for-bitbake.patch
index 33590ffc5..33590ffc5 100644
--- a/meta-networking/recipes-protocols/mdns/files/0002-mdns-cross-compilation-fixes-for-bitbake.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0002-mdns-cross-compilation-fixes-for-bitbake.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0003-Track-interface-socket-family.patch b/meta-networking/recipes-protocols/mdns/mdns/0003-Track-interface-socket-family.patch
index 8c0e6bf39..8c0e6bf39 100644
--- a/meta-networking/recipes-protocols/mdns/files/0003-Track-interface-socket-family.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0003-Track-interface-socket-family.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0004-Use-list-for-changed-interfaces.patch b/meta-networking/recipes-protocols/mdns/mdns/0004-Use-list-for-changed-interfaces.patch
index db3a63ea4..db3a63ea4 100644
--- a/meta-networking/recipes-protocols/mdns/files/0004-Use-list-for-changed-interfaces.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0004-Use-list-for-changed-interfaces.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0006-Remove-unneeded-function.patch b/meta-networking/recipes-protocols/mdns/mdns/0006-Remove-unneeded-function.patch
index b461a60df..b461a60df 100644
--- a/meta-networking/recipes-protocols/mdns/files/0006-Remove-unneeded-function.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0006-Remove-unneeded-function.patch
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0006-make-Add-top-level-Makefile.patch b/meta-networking/recipes-protocols/mdns/mdns/0006-make-Add-top-level-Makefile.patch
new file mode 100644
index 000000000..b7d9ad5bb
--- /dev/null
+++ b/meta-networking/recipes-protocols/mdns/mdns/0006-make-Add-top-level-Makefile.patch
@@ -0,0 +1,175 @@
1From 177abf68e5ac5f82c6261af63528f8b6160bca0f Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Tue, 6 Dec 2022 13:28:31 +0000
4Subject: [PATCH] make: Add top-level Makefile
5
6Simple top level Makefile that just delegates to mDNSPosix.
7
8Upstream-Status: Inappropriate [oe-specific]
9Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
10---
11 Makefile | 154 +------------------------------------------------------
12 1 file changed, 2 insertions(+), 152 deletions(-)
13
14diff --git a/Makefile b/Makefile
15index 8b6fa77..feb6ac6 100644
16--- a/Makefile
17+++ b/Makefile
18@@ -1,152 +1,2 @@
19-#
20-# Copyright (c) 2003-2018 Apple Inc. All rights reserved.
21-#
22-# Top level makefile for Build & Integration (B&I).
23-#
24-# This file is used to facilitate checking the mDNSResponder project directly from git and submitting to B&I at Apple.
25-#
26-# The various platform directories contain makefiles or projects specific to that platform.
27-#
28-# B&I builds must respect the following target:
29-# install:
30-# installsrc:
31-# installhdrs:
32-# installapi:
33-# clean:
34-#
35-
36-include $(MAKEFILEPATH)/pb_makefiles/platform.make
37-
38-MVERS = "mDNSResponder-1310.140.1"
39-
40-VER =
41-ifneq ($(strip $(GCC_VERSION)),)
42- VER = -- GCC_VERSION=$(GCC_VERSION)
43-endif
44-echo "VER = $(VER)"
45-
46-projectdir := $(SRCROOT)/mDNSMacOSX
47-buildsettings := OBJROOT=$(OBJROOT) SYMROOT=$(SYMROOT) DSTROOT=$(DSTROOT) MVERS=$(MVERS) SDKROOT=$(SDKROOT)
48-
49-.PHONY: install installSome installEmpty installExtras SystemLibraries installhdrs installapi installsrc java clean
50-
51-# Sanitizer support
52-# Disable Sanitizer instrumentation in LibSystem contributors. See rdar://problem/29952210.
53-UNSUPPORTED_SANITIZER_PROJECTS := mDNSResponderSystemLibraries mDNSResponderSystemLibraries_Sim
54-PROJECT_SUPPORTS_SANITIZERS := 1
55-ifneq ($(words $(filter $(UNSUPPORTED_SANITIZER_PROJECTS), $(RC_ProjectName))), 0)
56- PROJECT_SUPPORTS_SANITIZERS := 0
57-endif
58-ifeq ($(RC_ENABLE_ADDRESS_SANITIZATION),1)
59- ifeq ($(PROJECT_SUPPORTS_SANITIZERS),1)
60- $(info Enabling Address Sanitizer)
61- buildsettings += -enableAddressSanitizer YES
62- else
63- $(warning WARNING: Address Sanitizer not supported for project $(RC_ProjectName))
64- endif
65-endif
66-ifeq ($(RC_ENABLE_THREAD_SANITIZATION),1)
67- ifeq ($(PROJECT_SUPPORTS_SANITIZERS),1)
68- $(info Enabling Thread Sanitizer)
69- buildsettings += -enableThreadSanitizer YES
70- else
71- $(warning WARNING: Thread Sanitizer not supported for project $(RC_ProjectName))
72- endif
73-endif
74-ifeq ($(RC_ENABLE_UNDEFINED_BEHAVIOR_SANITIZATION),1)
75- ifeq ($(PROJECT_SUPPORTS_SANITIZERS),1)
76- $(info Enabling Undefined Behavior Sanitizer)
77- buildsettings += -enableUndefinedBehaviorSanitizer YES
78- else
79- $(warning WARNING: Undefined Behavior Sanitizer not supported for project $(RC_ProjectName))
80- endif
81-endif
82-
83-# B&I install build targets
84-#
85-# For the mDNSResponder build alias, the make target used by B&I depends on the platform:
86-#
87-# Platform Make Target
88-# -------- -----------
89-# osx install
90-# ios installSome
91-# atv installSome
92-# watch installSome
93-#
94-# For the mDNSResponderSystemLibraries and mDNSResponderSystemLibraries_sim build aliases, B&I uses the SystemLibraries
95-# target for all platforms.
96-
97-install:
98-ifeq ($(RC_ProjectName), mDNSResponderServices)
99-ifeq ($(RC_PROJECT_COMPILATION_PLATFORM), osx)
100- cd '$(projectdir)'; xcodebuild install $(buildsettings) -target 'Build Services-macOS' $(VER)
101-else
102- cd '$(projectdir)'; xcodebuild install $(buildsettings) -target 'Build Services' $(VER)
103-endif
104-else ifeq ($(RC_ProjectName), mDNSResponderServices_Sim)
105- mkdir -p $(DSTROOT)/AppleInternal
106-else
107- cd '$(projectdir)'; xcodebuild install $(buildsettings) $(VER)
108-endif
109-
110-installSome:
111- cd '$(projectdir)'; xcodebuild install $(buildsettings) $(VER)
112-
113-installEmpty:
114- mkdir -p $(DSTROOT)/AppleInternal
115-
116-installExtras:
117-ifeq ($(RC_PROJECT_COMPILATION_PLATFORM), osx)
118- cd '$(projectdir)'; xcodebuild install $(buildsettings) -target 'Build Extras-macOS' $(VER)
119-else ifeq ($(RC_PROJECT_COMPILATION_PLATFORM), ios)
120- cd '$(projectdir)'; xcodebuild install $(buildsettings) -target 'Build Extras-iOS' $(VER)
121-else ifeq ($(RC_PROJECT_COMPILATION_PLATFORM), atv)
122- cd '$(projectdir)'; xcodebuild install $(buildsettings) -target 'Build Extras-tvOS' $(VER)
123-else
124- cd '$(projectdir)'; xcodebuild install $(buildsettings) -target 'Build Extras' $(VER)
125-endif
126-
127-SystemLibraries:
128- cd '$(projectdir)'; xcodebuild install $(buildsettings) -target SystemLibraries $(VER)
129-
130-# B&I installhdrs build targets
131-
132-installhdrs::
133-ifeq ($(RC_ProjectName), mDNSResponderServices)
134-ifeq ($(RC_PROJECT_COMPILATION_PLATFORM), osx)
135- cd '$(projectdir)'; xcodebuild installhdrs $(buildsettings) -target 'Build Services-macOS' $(VER)
136-else
137- cd '$(projectdir)'; xcodebuild installhdrs $(buildsettings) -target 'Build Services' $(VER)
138-endif
139-else ifeq ($(RC_ProjectName), mDNSResponderServices_Sim)
140- mkdir -p $(DSTROOT)/AppleInternal
141-else ifneq ($(findstring SystemLibraries,$(RC_ProjectName)),)
142- cd '$(projectdir)'; xcodebuild installhdrs $(buildsettings) -target SystemLibraries $(VER)
143-endif
144-
145-# B&I installapi build targets
146-
147-installapi:
148-ifeq ($(RC_ProjectName), mDNSResponderServices)
149-ifeq ($(RC_PROJECT_COMPILATION_PLATFORM), osx)
150- cd '$(projectdir)'; xcodebuild installapi $(buildsettings) -target 'Build Services-macOS' $(VER)
151-else
152- cd '$(projectdir)'; xcodebuild installapi $(buildsettings) -target 'Build Services' $(VER)
153-endif
154-else ifeq ($(RC_ProjectName), mDNSResponderServices_Sim)
155- mkdir -p $(DSTROOT)/AppleInternal
156-else ifneq ($(findstring SystemLibraries,$(RC_ProjectName)),)
157- cd '$(projectdir)'; xcodebuild installapi $(buildsettings) -target SystemLibrariesDynamic $(VER)
158-endif
159-
160-# Misc. targets
161-
162-installsrc:
163- ditto . '$(SRCROOT)'
164- rm -rf '$(SRCROOT)/mDNSWindows' '$(SRCROOT)/Clients/FirefoxExtension'
165-
166-java:
167- cd '$(projectdir)'; xcodebuild install $(buildsettings) -target libjdns_sd.jnilib $(VER)
168-
169-clean::
170- echo clean
171+all clean:
172+ cd mDNSPosix && $(MAKE) $@
173--
1742.38.1
175
diff --git a/meta-networking/recipes-protocols/mdns/files/0008-Mark-deleted-interfaces-as-being-changed.patch b/meta-networking/recipes-protocols/mdns/mdns/0008-Mark-deleted-interfaces-as-being-changed.patch
index fdc5105cb..fdc5105cb 100644
--- a/meta-networking/recipes-protocols/mdns/files/0008-Mark-deleted-interfaces-as-being-changed.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0008-Mark-deleted-interfaces-as-being-changed.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0009-Fix-possible-NULL-dereference.patch b/meta-networking/recipes-protocols/mdns/mdns/0009-Fix-possible-NULL-dereference.patch
index 362d69768..362d69768 100644
--- a/meta-networking/recipes-protocols/mdns/files/0009-Fix-possible-NULL-dereference.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0009-Fix-possible-NULL-dereference.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0010-Handle-errors-from-socket-calls.patch b/meta-networking/recipes-protocols/mdns/mdns/0010-Handle-errors-from-socket-calls.patch
index b9b015727..b9b015727 100644
--- a/meta-networking/recipes-protocols/mdns/files/0010-Handle-errors-from-socket-calls.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0010-Handle-errors-from-socket-calls.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/0011-Change-a-dynamic-allocation-to-file-scope-variable.patch b/meta-networking/recipes-protocols/mdns/mdns/0011-Change-a-dynamic-allocation-to-file-scope-variable.patch
index d9adde04c..d9adde04c 100644
--- a/meta-networking/recipes-protocols/mdns/files/0011-Change-a-dynamic-allocation-to-file-scope-variable.patch
+++ b/meta-networking/recipes-protocols/mdns/mdns/0011-Change-a-dynamic-allocation-to-file-scope-variable.patch
diff --git a/meta-networking/recipes-protocols/mdns/files/mdns.service b/meta-networking/recipes-protocols/mdns/mdns/mdns.service
index 531d142dc..531d142dc 100644
--- a/meta-networking/recipes-protocols/mdns/files/mdns.service
+++ b/meta-networking/recipes-protocols/mdns/mdns/mdns.service
diff --git a/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb b/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
index 205dc929b..65f4847d8 100644
--- a/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
+++ b/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
@@ -2,28 +2,31 @@ SUMMARY = "Publishes & browses available services on a link according to the Zer
2DESCRIPTION = "Bonjour, also known as zero-configuration networking, enables automatic discovery of computers, devices, and services on IP networks." 2DESCRIPTION = "Bonjour, also known as zero-configuration networking, enables automatic discovery of computers, devices, and services on IP networks."
3HOMEPAGE = "http://developer.apple.com/networking/bonjour/" 3HOMEPAGE = "http://developer.apple.com/networking/bonjour/"
4LICENSE = "Apache-2.0 & BSD-3-Clause" 4LICENSE = "Apache-2.0 & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://../LICENSE;md5=31c50371921e0fb731003bbc665f29bf" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=31c50371921e0fb731003bbc665f29bf"
6 6
7DEPENDS:append:libc-musl = " musl-nscd" 7DEPENDS:append:libc-musl = " musl-nscd"
8 8
9RPROVIDES:${PN} += "libdns_sd.so" 9RPROVIDES:${PN} += "libdns_sd.so"
10 10
11SRC_URI = "https://opensource.apple.com/tarballs/mDNSResponder/mDNSResponder-${PV}.tar.gz \ 11# matches annotated tag mDNSResponder-1310.140.1
12SRCREV = "1d1de95b98fba2077d34c9d78b839a96aa0e1c77"
13BRANCH = "rel/mDNSResponder-1310"
14SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https;branch=${BRANCH} \
12 file://mdns.service \ 15 file://mdns.service \
13 file://0001-mdns-include-stddef.h-for-NULL.patch;patchdir=.. \ 16 file://0001-mdns-include-stddef.h-for-NULL.patch \
14 file://0002-mdns-cross-compilation-fixes-for-bitbake.patch;patchdir=.. \ 17 file://0002-mdns-cross-compilation-fixes-for-bitbake.patch \
15 file://0001-Create-subroutine-for-cleaning-recent-interfaces.patch;patchdir=.. \ 18 file://0001-Create-subroutine-for-cleaning-recent-interfaces.patch \
16 file://0002-Create-subroutine-for-tearing-down-an-interface.patch;patchdir=.. \ 19 file://0002-Create-subroutine-for-tearing-down-an-interface.patch \
17 file://0003-Track-interface-socket-family.patch;patchdir=.. \ 20 file://0003-Track-interface-socket-family.patch \
18 file://0004-Use-list-for-changed-interfaces.patch;patchdir=.. \ 21 file://0004-Use-list-for-changed-interfaces.patch \
19 file://0006-Remove-unneeded-function.patch;patchdir=.. \ 22 file://0006-Remove-unneeded-function.patch \
20 file://0008-Mark-deleted-interfaces-as-being-changed.patch;patchdir=.. \ 23 file://0008-Mark-deleted-interfaces-as-being-changed.patch \
21 file://0009-Fix-possible-NULL-dereference.patch;patchdir=.. \ 24 file://0009-Fix-possible-NULL-dereference.patch \
22 file://0010-Handle-errors-from-socket-calls.patch;patchdir=.. \ 25 file://0010-Handle-errors-from-socket-calls.patch \
23 file://0011-Change-a-dynamic-allocation-to-file-scope-variable.patch;patchdir=.. \ 26 file://0011-Change-a-dynamic-allocation-to-file-scope-variable.patch \
24 file://0001-dns-sd-Include-missing-headers.patch;patchdir=.. \ 27 file://0001-dns-sd-Include-missing-headers.patch \
28 file://0006-make-Add-top-level-Makefile.patch \
25 " 29 "
26SRC_URI[sha256sum] = "040f6495c18b9f0557bcf9e00cbcfc82b03405f5ba6963dc147730ca0ca90d6f"
27 30
28CVE_PRODUCT = "apple:mdnsresponder" 31CVE_PRODUCT = "apple:mdnsresponder"
29 32
@@ -42,13 +45,22 @@ CVE_CHECK_IGNORE += "CVE-2007-0613"
42 45
43PARALLEL_MAKE = "" 46PARALLEL_MAKE = ""
44 47
45S = "${WORKDIR}/mDNSResponder-${PV}/mDNSPosix" 48# We install a stub Makefile in the top directory so that the various checks
49# in base.bbclass pass their tests for a Makefile, this ensures (that amongst
50# other things) the sstate checks will clean the build directory when the
51# task hashes changes.
52#
53# We can't use the approach of setting ${S} to mDNSPosix as we need
54# DEBUG_PREFIX_MAP to cover files which come from the Clients directory too.
55S = "${WORKDIR}/git"
46 56
47EXTRA_OEMAKE += "os=linux DEBUG=0 'CC=${CC}' 'LD=${CCLD} ${LDFLAGS}'" 57EXTRA_OEMAKE += "os=linux DEBUG=0 'CC=${CC}' 'LD=${CCLD} ${LDFLAGS}'"
48 58
49TARGET_CC_ARCH += "${LDFLAGS}" 59TARGET_CC_ARCH += "${LDFLAGS}"
50 60
51do_install () { 61do_install () {
62 cd mDNSPosix
63
52 install -d ${D}${sbindir} 64 install -d ${D}${sbindir}
53 install -m 0755 build/prod/mdnsd ${D}${sbindir} 65 install -m 0755 build/prod/mdnsd ${D}${sbindir}
54 66