summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-05-05 16:32:53 +0200
committerArmin Kuster <akuster808@gmail.com>2016-05-13 22:59:33 -0700
commitea71aa8c99843bd76b87c6d8a585a3de41b75727 (patch)
tree72ea916a29734c6f1d07c1eff1bbaba59b8de518
parent0e063058cc3ae825a7ec9736a9a2dc44c2c96fb6 (diff)
downloadmeta-openembedded-ea71aa8c99843bd76b87c6d8a585a3de41b75727.tar.gz
poppler: add --std=c++11 to fix build with Qt 5.7
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch39
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.41.0.bb4
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch b/meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch
new file mode 100644
index 000000000..d5c34a6a0
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch
@@ -0,0 +1,39 @@
1From a8e3399487258e53df0fd4a79c570c8d71188bed Mon Sep 17 00:00:00 2001
2From: Takahiro Hashimoto <kenya888.en@gmail.com>
3Date: Wed, 27 Apr 2016 00:16:52 +0200
4Subject: [PATCH] Compile with C++11 compilers that don't define isinfinite
5
6Bug #94761
7---
8 poppler/SplashOutputDev.cc | 8 ++++++++
9 1 file changed, 8 insertions(+)
10
11diff --git a/poppler/SplashOutputDev.cc b/poppler/SplashOutputDev.cc
12index 13d090c..0e50702 100644
13--- a/poppler/SplashOutputDev.cc
14+++ b/poppler/SplashOutputDev.cc
15@@ -36,6 +36,7 @@
16 // Copyright (C) 2014 Richard PALO <richard@netbsd.org>
17 // Copyright (C) 2015 Tamas Szekeres <szekerest@gmail.com>
18 // Copyright (C) 2015 Kenji Uno <ku@digitaldolphins.jp>
19+// Copyright (C) 2016 Takahiro Hashimoto <kenya888.en@gmail.com>
20 //
21 // To see a description of the changes please see the Changelog file that
22 // came with your tarball or type make ChangeLog if you are building from git
23@@ -94,6 +95,13 @@ extern "C" int unlink(char *filename);
24 #endif
25 #endif
26
27+#if __cplusplus > 199711L
28+#include <cmath>
29+#ifndef isfinite
30+#define isfinite(x) std::isfinite(x)
31+#endif
32+#endif
33+
34 static inline void convertGfxColor(SplashColorPtr dest,
35 SplashColorMode colorMode,
36 GfxColorSpace *colorSpace,
37--
382.8.2
39
diff --git a/meta-oe/recipes-support/poppler/poppler_0.41.0.bb b/meta-oe/recipes-support/poppler/poppler_0.41.0.bb
index 432040846..f7cc07681 100644
--- a/meta-oe/recipes-support/poppler/poppler_0.41.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler_0.41.0.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5SRC_URI = " \ 5SRC_URI = " \
6 http://poppler.freedesktop.org/${BP}.tar.xz \ 6 http://poppler.freedesktop.org/${BP}.tar.xz \
7 file://0001-add-manadatory-options-to-find-qt4-qt5-moc.patch \ 7 file://0001-add-manadatory-options-to-find-qt4-qt5-moc.patch \
8 file://0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch \
8" 9"
9SRC_URI[md5sum] = "849a8bd6af5794efb961b70418414e5a" 10SRC_URI[md5sum] = "849a8bd6af5794efb961b70418414e5a"
10SRC_URI[sha256sum] = "420abaab63caed9e1ee28964a0ba216d1979506726164bc99ad5ade289192a1b" 11SRC_URI[sha256sum] = "420abaab63caed9e1ee28964a0ba216d1979506726164bc99ad5ade289192a1b"
@@ -22,6 +23,9 @@ PACKAGECONFIG[openjpeg] = "--enable-libopenjpeg=openjpeg2,--disable-libopenjpeg,
22PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase" 23PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase"
23PACKAGECONFIG[qt4e] = "--enable-poppler-qt4 --with-moc-qt4=${STAGING_BINDIR_NATIVE}/moc4,--disable-poppler-qt4,qt4-embedded" 24PACKAGECONFIG[qt4e] = "--enable-poppler-qt4 --with-moc-qt4=${STAGING_BINDIR_NATIVE}/moc4,--disable-poppler-qt4,qt4-embedded"
24 25
26# Needed for qt5
27CXXFLAGS += "--std=c++11"
28
25EXTRA_OECONF = "\ 29EXTRA_OECONF = "\
26 --enable-xpdf-headers \ 30 --enable-xpdf-headers \
27 --disable-gtk-test \ 31 --disable-gtk-test \