summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2016-06-28 04:19:58 -0400
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commitcb6d8e8fd222e5e4056769bc37127ff1ce2a6831 (patch)
tree5ddd4e690c10668af643d04d6bde55726160b0b3
parent7b1eab4a1693e78a7a498e636d0c818ef3f6425c (diff)
downloadmeta-openembedded-cb6d8e8fd222e5e4056769bc37127ff1ce2a6831.tar.gz
x11vnc: remove redundant RPATH to fix QA issue
The useless rpath caused oe QA issue: ... |ERROR: QA Issue: x11vnc: work/i586-poky-linux/x11vnc/0.9.13-r0/packages-split/ x11vnc/usr/bin/x11vnc contains probably-redundant RPATH /usr/lib [useless-rpaths] ... In oe build, it is unnecessary and redundant to pass "-R/usr/lib" to the linker. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit d209e32ffbcbbf419c3b5677777ac2e244bcebc1) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/x11vnc/files/remove-redundant-RPATH.patch86
-rw-r--r--meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb4
2 files changed, 89 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/x11vnc/files/remove-redundant-RPATH.patch b/meta-oe/recipes-graphics/x11vnc/files/remove-redundant-RPATH.patch
new file mode 100644
index 000000000..8e894bd8e
--- /dev/null
+++ b/meta-oe/recipes-graphics/x11vnc/files/remove-redundant-RPATH.patch
@@ -0,0 +1,86 @@
1From 7be055c13c7d0d640941830a3291af3b404928c1 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Mon, 27 Jun 2016 04:44:14 -0400
4Subject: [PATCH] configure.ac: remove redundant RPATH
5
6It caused oe QA issue:
7...
8|ERROR: QA Issue: x11vnc: work/i586-poky-linux/x11vnc/0.9.13-r0/packages-split/
9x11vnc/usr/bin/x11vnc contains probably-redundant RPATH /usr/lib [useless-rpaths]
10...
11
12Upstream-Status: Inappropriate [oe specific]
13
14Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
15---
16 configure.ac | 21 +++++----------------
17 1 file changed, 5 insertions(+), 16 deletions(-)
18
19diff --git a/configure.ac b/configure.ac
20index 6f664d0..f986686 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -330,10 +330,8 @@ if test "x$with_crypto" != "xno" -a "x$with_ssl" != "xno"; then
24 saved_LDFLAGS="$LDFLAGS"
25 CPPFLAGS="$CPPFLAGS -I$with_ssl/include"
26 LDFLAGS="$LDFLAGS -L$with_ssl/lib"
27- if test "x$ld_minus_R" = "xno"; then
28+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
29 :
30- elif test "x$GCC" = "xyes"; then
31- LDFLAGS="$LDFLAGS -Xlinker -R$with_ssl/lib"
32 else
33 LDFLAGS="$LDFLAGS -R$with_ssl/lib"
34 fi
35@@ -447,10 +445,8 @@ if test ! -z "$with_system_libvncserver" -a "x$with_system_libvncserver" != "xno
36 fi
37 if test "x$with_system_libvncserver" != "xyes"; then
38 rflag=""
39- if test "x$ld_minus_R" = "xno"; then
40+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
41 :
42- elif test "x$GCC" = "xyes"; then
43- rflag="-Xlinker -R$with_system_libvncserver/lib"
44 else
45 rflag="-R$with_system_libvncserver/lib"
46 fi
47@@ -484,10 +480,8 @@ new enough.
48 elif libvncserver-config --version 1>/dev/null 2>&1; then
49 rflag=""
50 rprefix=`libvncserver-config --prefix`
51- if test "x$ld_minus_R" = "xno"; then
52+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
53 :
54- elif test "x$GCC" = "xyes"; then
55- rflag=" -Xlinker -R$rprefix/lib "
56 else
57 rflag=" -R$rprefix/lib "
58 fi
59@@ -541,11 +535,8 @@ if test "x$with_jpeg" != "xno"; then
60 saved_LDFLAGS="$LDFLAGS"
61 CPPFLAGS="$CPPFLAGS -I$with_jpeg/include"
62 LDFLAGS="$LDFLAGS -L$with_jpeg/lib"
63- if test "x$ld_minus_R" = "xno"; then
64+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
65 :
66- elif test "x$GCC" = "xyes"; then
67- # this is not complete... in general a rat's nest.
68- LDFLAGS="$LDFLAGS -Xlinker -R$with_jpeg/lib"
69 else
70 LDFLAGS="$LDFLAGS -R$with_jpeg/lib"
71 fi
72@@ -590,10 +581,8 @@ if test "x$with_zlib" != "xno" -a "x$with_libz" != "xno"; then
73 saved_LDFLAGS="$LDFLAGS"
74 CPPFLAGS="$CPPFLAGS -I$with_zlib/include"
75 LDFLAGS="$LDFLAGS -L$with_zlib/lib"
76- if test "x$ld_minus_R" = "xno"; then
77+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
78 :
79- elif test "x$GCC" = "xyes"; then
80- LDFLAGS="$LDFLAGS -Xlinker -R$with_zlib/lib"
81 else
82 LDFLAGS="$LDFLAGS -R$with_zlib/lib"
83 fi
84--
852.8.1
86
diff --git a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
index 64c8a5d5d..98a0734bd 100644
--- a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
+++ b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
@@ -9,7 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f \
9 9
10SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/x11vnc/${PV}/x11vnc-${PV}.tar.gz\ 10SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/x11vnc/${PV}/x11vnc-${PV}.tar.gz\
11 file://starting-fix.patch \ 11 file://starting-fix.patch \
12 file://endian-fix.patch " 12 file://endian-fix.patch \
13 file://remove-redundant-RPATH.patch \
14"
13 15
14SRC_URI[md5sum] = "a372ec4fe8211221547b1c108cf56e4c" 16SRC_URI[md5sum] = "a372ec4fe8211221547b1c108cf56e4c"
15SRC_URI[sha256sum] = "f6829f2e629667a5284de62b080b13126a0736499fe47cdb447aedb07a59f13b" 17SRC_URI[sha256sum] = "f6829f2e629667a5284de62b080b13126a0736499fe47cdb447aedb07a59f13b"