summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederico Cadete <frederico.cadete@awtce.be>2016-06-22 17:29:35 +0200
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commit87e83981f4c6cb0c739510e34b0db3c3471db3e5 (patch)
treec60600c199979abd62c08cc32cc0644769451aeb
parentf87dd8d51685a5a346eaa50e8bf5130d050f50f2 (diff)
downloadmeta-openembedded-87e83981f4c6cb0c739510e34b0db3c3471db3e5.tar.gz
gtest: fix installation in multilib
The installation and pkgconfig patches have to be reworked to consider the install directories from OE. Signed-off-by: Frederico Cadete <frederico.cadete@awtce.be> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 377d67aa7cb902d4a512c3489482fb876b1ec4cd) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch32
-rw-r--r--meta-oe/recipes-test/gtest/gtest/0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch (renamed from meta-oe/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch)24
-rw-r--r--meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch39
-rw-r--r--meta-oe/recipes-test/gtest/gtest_1.7.0.bb4
4 files changed, 46 insertions, 53 deletions
diff --git a/meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch b/meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch
new file mode 100644
index 000000000..b8f5d6f30
--- /dev/null
+++ b/meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch
@@ -0,0 +1,32 @@
1From bdcbef7b8adde424ee29e7eddc3b0570cc336449 Mon Sep 17 00:00:00 2001
2From: Frederico Cadete <frederico.cadete@awtce.be>
3Date: Tue, 21 Jun 2016 10:55:38 +0200
4Subject: [PATCH 1/2] Add install command for libraries and headers
5
6Signed-off-by: Frederico Cadete <frederico.cadete@awtce.be>
7---
8 CMakeLists.txt | 8 ++++++++
9 1 file changed, 8 insertions(+)
10
11diff --git a/CMakeLists.txt b/CMakeLists.txt
12index 57470c8..e969648 100644
13--- a/CMakeLists.txt
14+++ b/CMakeLists.txt
15@@ -73,6 +73,14 @@ target_link_libraries(gtest_main gtest)
16
17 ########################################################################
18 #
19+# Install rules
20+install(TARGETS gtest gtest_main
21+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
22+install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest
23+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
24+
25+########################################################################
26+#
27 # Samples on how to link user tests with gtest or gtest_main.
28 #
29 # They are not built by default. To build them, set the
30--
312.5.0
32
diff --git a/meta-oe/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch b/meta-oe/recipes-test/gtest/gtest/0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
index 1ece136b6..7a19f726f 100644
--- a/meta-oe/recipes-test/gtest/gtest/CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
+++ b/meta-oe/recipes-test/gtest/gtest/0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch
@@ -1,7 +1,7 @@
1From d4b25ce723812faf78d8ee038b7cbed00cbba682 Mon Sep 17 00:00:00 2001 1From 89639e76d5ee039a55004e5e910d565e6e84ed35 Mon Sep 17 00:00:00 2001
2From: Rodrigo Caimi <caimi@datacom.ind.br> 2From: Rodrigo Caimi <caimi@datacom.ind.br>
3Date: Tue, 7 Oct 2014 15:37:10 -0300 3Date: Tue, 7 Oct 2014 15:37:10 -0300
4Subject: [PATCH] CMakeLists, gtest.pc.in: Add pkg-config support to gtest 4Subject: [PATCH 2/2] CMakeLists, gtest.pc.in: Add pkg-config support to gtest
5 1.7.0 5 1.7.0
6 6
7Signed-off-by: Rodrigo Caimi <caimi@datacom.ind.br> 7Signed-off-by: Rodrigo Caimi <caimi@datacom.ind.br>
@@ -12,7 +12,7 @@ Signed-off-by: Rodrigo Caimi <caimi@datacom.ind.br>
12 create mode 100644 gtest.pc.in 12 create mode 100644 gtest.pc.in
13 13
14diff --git a/CMakeLists.txt b/CMakeLists.txt 14diff --git a/CMakeLists.txt b/CMakeLists.txt
15index 281c4c2..e4354a8 100644 15index e969648..0038826 100644
16--- a/CMakeLists.txt 16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt 17+++ b/CMakeLists.txt
18@@ -29,6 +29,9 @@ if (COMMAND pre_project_set_up_hermetic_build) 18@@ -29,6 +29,9 @@ if (COMMAND pre_project_set_up_hermetic_build)
@@ -25,19 +25,19 @@ index 281c4c2..e4354a8 100644
25 ######################################################################## 25 ########################################################################
26 # 26 #
27 # Project-wide settings 27 # Project-wide settings
28@@ -75,6 +78,9 @@ target_link_libraries(gtest_main gtest) 28@@ -78,6 +81,9 @@ install(TARGETS gtest gtest_main
29 29 DESTINATION ${CMAKE_INSTALL_LIBDIR})
30 install(TARGETS gtest DESTINATION lib) 30 install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest
31 install(TARGETS gtest_main DESTINATION lib) 31 DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
32+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/gtest.pc" 32+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/gtest.pc"
33+ DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig/" 33+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig/"
34+) 34+)
35 35
36 ######################################################################## 36 ########################################################################
37 # 37 #
38diff --git a/gtest.pc.in b/gtest.pc.in 38diff --git a/gtest.pc.in b/gtest.pc.in
39new file mode 100644 39new file mode 100644
40index 0000000..57b1049 40index 0000000..52e622b
41--- /dev/null 41--- /dev/null
42+++ b/gtest.pc.in 42+++ b/gtest.pc.in
43@@ -0,0 +1,9 @@ 43@@ -0,0 +1,9 @@
@@ -46,10 +46,10 @@ index 0000000..57b1049
46+Description: Google's framework for writing C++ tests on a variety of platforms 46+Description: Google's framework for writing C++ tests on a variety of platforms
47+ 47+
48+prefix=@CMAKE_INSTALL_PREFIX@ 48+prefix=@CMAKE_INSTALL_PREFIX@
49+includedir=${prefix}/include 49+includedir=@CMAKE_INSTALL_INCLUDEDIR@
50+libdir=${prefix}/lib 50+libdir=@CMAKE_INSTALL_LIBDIR@
51+Cflags:-I${includedir}/gtest 51+Cflags:-I${includedir}/gtest
52+Libs: -L${libdir} -lgtest -lgtest_main 52+Libs: -L${libdir} -lgtest -lgtest_main
53-- 53--
541.9.1 542.5.0
55 55
diff --git a/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch b/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
deleted file mode 100644
index 0c160b02a..000000000
--- a/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 5318983562be6babeb5a6996e7dda4b31acfdba8 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Wed, 30 Jul 2014 16:49:53 -0300
4Subject: [PATCH] cmake: Add install command for libraries and headers
5Organization: O.S. Systems Software LTDA.
6
7Upstream-Status: Inappropriate [embedded specific]
8
9Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
10---
11 CMakeLists.txt | 5 +++++
12 1 file changed, 5 insertions(+)
13
14diff --git a/CMakeLists.txt b/CMakeLists.txt
15index 57470c8..281c4c2 100644
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -56,6 +56,8 @@ include_directories(
19 ${gtest_SOURCE_DIR}/include
20 ${gtest_SOURCE_DIR})
21
22+install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest DESTINATION include)
23+
24 # Where Google Test's libraries can be found.
25 link_directories(${gtest_BINARY_DIR}/src)
26
27@@ -71,6 +73,9 @@ cxx_library(gtest "${cxx_strict}" src/gtest-all.cc)
28 cxx_library(gtest_main "${cxx_strict}" src/gtest_main.cc)
29 target_link_libraries(gtest_main gtest)
30
31+install(TARGETS gtest DESTINATION lib)
32+install(TARGETS gtest_main DESTINATION lib)
33+
34 ########################################################################
35 #
36 # Samples on how to link user tests with gtest or gtest_main.
37--
381.9.1
39
diff --git a/meta-oe/recipes-test/gtest/gtest_1.7.0.bb b/meta-oe/recipes-test/gtest/gtest_1.7.0.bb
index edeeab692..5bacf6c80 100644
--- a/meta-oe/recipes-test/gtest/gtest_1.7.0.bb
+++ b/meta-oe/recipes-test/gtest/gtest_1.7.0.bb
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
6 6
7SRC_URI = "\ 7SRC_URI = "\
8 http://googletest.googlecode.com/files/${BPN}-${PV}.zip \ 8 http://googletest.googlecode.com/files/${BPN}-${PV}.zip \
9 file://cmake-Add-install-command-for-libraries-and-headers.patch \ 9 file://0001-Add-install-command-for-libraries-and-headers.patch \
10 file://CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch \ 10 file://0002-CMakeLists-gtest.pc.in-Add-pkg-config-support-to-gte.patch \
11" 11"
12 12
13SRC_URI[md5sum] = "2d6ec8ccdf5c46b05ba54a9fd1d130d7" 13SRC_URI[md5sum] = "2d6ec8ccdf5c46b05ba54a9fd1d130d7"