summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnn Thornton <ann.thornton@nxp.com>2016-05-04 17:03:41 -0500
committerArmin Kuster <akuster808@gmail.com>2016-05-13 23:01:12 -0700
commit84f69f338c3ccd351d24db7e99716d7c1db1c65d (patch)
tree4dd5625122c025d9790fc9cc949a006b29f2a18a
parente341fa03f0f62a78316de4e55ed437d426068832 (diff)
downloadmeta-openembedded-84f69f338c3ccd351d24db7e99716d7c1db1c65d.tar.gz
packagegroup-tools-bluetooth: Selects the tools appropriate for the version of bluez being used.
Signed-off-by: Ann Thornton <ann.thornton@nxp.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb43
1 files changed, 20 insertions, 23 deletions
diff --git a/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb b/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb
index bdab389bc..dde4599ac 100644
--- a/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb
+++ b/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb
@@ -5,36 +5,33 @@ LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ 5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7 7
8SUMMARY = "Set of Bluetooh related tools for inclusion on images" 8SUMMARY = "Set of Bluetooth related tools for inclusion in images"
9DESCRIPTION = "Add bluetooth tools based on the version of BlueZ in use.\ 9DESCRIPTION = "Includes bluetooth specific tools for this version of BlueZ.\
10The tools that have been tested and work the best are pulled in \ 10These tools are used at runtime. \
11automatically. The same packagegroup can be used in a recipe without \
12the need to know which version of BlueZ is in use. \
13Supports BlueZ4 and BlueZ5." 11Supports BlueZ4 and BlueZ5."
14 12
15inherit packagegroup 13inherit packagegroup
14inherit bluetooth
16 15
17BLUEZ4_INSTALL = " \ 16RDEPENDS_bluez4 = " \
18 obexftp \ 17 obexftp \
19" 18"
20 19
21BLUEZ5_INSTALL = " \ 20RDEPENDS_bluez5 = " \
22 bluez5-noinst-tools \ 21 bluez5-noinst-tools \
23 bluez5-obex \ 22 bluez5-obex \
24 bluez5-testtools \ 23 bluez5-testtools \
25 libasound-module-bluez \ 24 libasound-module-bluez \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', "pulseaudio-module-bluetooth-discover \ 25 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', \
27 pulseaudio-module-bluetooth-policy \ 26 'pulseaudio-module-bluetooth-discover \
28 pulseaudio-module-bluez5-discover \ 27 pulseaudio-module-bluetooth-policy \
29 pulseaudio-module-bluez5-device \ 28 pulseaudio-module-bluez5-discover \
30 pulseaudio-module-switch-on-connect \ 29 pulseaudio-module-bluez5-device \
31 pulseaudio-module-loopback", \ 30 pulseaudio-module-switch-on-connect \
32 '', d)} \ 31 pulseaudio-module-loopback', \
32 '', d)} \
33" 33"
34 34
35# Install either bluez4 or bluez5 if they are in distro. 35# Install bluez4 tools or bluez5 tools depending on what is specified in the distro.
36# Otherwise install nothing. 36# Otherwise install nothing.
37RDEPENDS_${PN} = " \ 37RDEPENDS_${PN} = "${RDEPENDS_${BLUEZ}}"
38 ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', '${BLUEZ5_INSTALL}', "", d)} \
39 ${@bb.utils.contains('DISTRO_FEATURES', 'bluez4', '${BLUEZ4_INSTALL}', "", d)} \
40"