summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-05-06 11:00:49 -0300
committerArmin Kuster <akuster808@gmail.com>2016-05-09 19:05:03 -0700
commit5e2bb87e66bfb712b9c25421f1d31a555a279e8a (patch)
treee933b67a25fd9d5ded778f7e5a8c84ddbe6cc954
parent9f34a8560b2010fbbbd7f9d9fb466a5315fba3d1 (diff)
downloadmeta-openembedded-5e2bb87e66bfb712b9c25421f1d31a555a279e8a.tar.gz
syslog-ng.inc: fix prerm script & class includes
The order of class includes is very important because it's the order in which classes are evaluated. Both update-rc.d and update-alternatives write to the prerm script, so the class order decides the script code ordering. As they are now, prerm is: #!/bin/sh update-alternatives --remove syslog-init /etc/init.d/syslog.syslog-ng if [ -z "$D" ]; then /etc/init.d/syslog stop fi This causes errors because when syslog-ng is the only alternative it is removed and then the script tries to stop it (No such file or directory) but even if there are other alternatives, the script tries to stop something other than syslog-ng which was removed. By reversing the include order, prerm gets generated correctly and it tries to stop syslog-ng before removing it: if [ -z "$D" ]; then /etc/init.d/syslog stop fi update-alternatives --remove syslog-init /etc/init.d/syslog.syslog-ng Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index 382dc5e30..4e0f697bc 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -22,7 +22,7 @@ SRC_URI = "http://www.balabit.com/downloads/files/syslog-ng/sources/${PV}/source
22 file://configure.ac-add-option-enable-thread-tls-to-manage-.patch \ 22 file://configure.ac-add-option-enable-thread-tls-to-manage-.patch \
23" 23"
24 24
25inherit autotools systemd pkgconfig update-rc.d update-alternatives 25inherit autotools systemd pkgconfig update-alternatives update-rc.d
26 26
27EXTRA_OECONF = " \ 27EXTRA_OECONF = " \
28 --enable-dynamic-linking \ 28 --enable-dynamic-linking \