summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-05-23 21:30:34 -0700
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:39 -0700
commit4ee1c29420952a7c9fed847946b923eba35880b2 (patch)
treeb8b77d3106e18eed3ac3034eec6137c053015e0c
parent7166a2daecfbb4528fa410670adcc7f241715bd5 (diff)
downloadmeta-openembedded-4ee1c29420952a7c9fed847946b923eba35880b2.tar.gz
netkit-rsh: fix build issue.
glibc deprecate union wait and remove support from wait functions https://sourceware.org/ml/libc-alpha/2016-02/msg00342.html change rlogin.c accordingly Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> (cherry picked from commit 62e3df2ddbeff9f2293027af6f159260cd2ab134) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-netkit/netkit-rsh/netkit-rsh/fixup_wait3_api_change.patch34
-rw-r--r--meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh/fixup_wait3_api_change.patch b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh/fixup_wait3_api_change.patch
new file mode 100644
index 000000000..cd6df62fb
--- /dev/null
+++ b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh/fixup_wait3_api_change.patch
@@ -0,0 +1,34 @@
1Fix build issue do to Deprecate union wait and remove support from wait functions [BZ #19613]
2
3| rlogin.c: In function 'catch_child':
4| rlogin.c:463:13: error: storage size of 'status' isn't known
5| union wait status;
6
7https://sourceware.org/ml/libc-alpha/2016-02/msg00342.html
8
9Upstream-Status: Inappropriate [ no upstream maintaner ]
10
11Signed-off-by Armin Kuster <akuster@mvista.com>
12
13Index: netkit-rsh-0.17/rlogin/rlogin.c
14===================================================================
15--- netkit-rsh-0.17.orig/rlogin/rlogin.c
16+++ netkit-rsh-0.17/rlogin/rlogin.c
17@@ -460,7 +460,7 @@ writeroob(int ignore)
18 void
19 catch_child(int ignore)
20 {
21- union wait status;
22+ int status;
23 int pid;
24
25 (void)ignore;
26@@ -471,7 +471,7 @@ catch_child(int ignore)
27 return;
28 /* if the child (reader) dies, just quit */
29 if (pid < 0 || (pid == childpid && !WIFSTOPPED(status)))
30- done((int)(status.w_termsig | status.w_retcode));
31+ done((int)(WTERMSIG(status) | WEXITSTATUS(status)));
32 }
33 /* NOTREACHED */
34 }
diff --git a/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb
index e29369c49..44a8e0ab3 100644
--- a/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb
+++ b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb
@@ -15,6 +15,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/n/netkit-rsh/netkit-rsh_${PV}.orig.tar.gz;name=
15 file://rsh.xinetd.netkit \ 15 file://rsh.xinetd.netkit \
16 file://netkit-rsh-0.17-rexec-ipv6.patch \ 16 file://netkit-rsh-0.17-rexec-ipv6.patch \
17 file://fix-host-variable.patch \ 17 file://fix-host-variable.patch \
18 file://fixup_wait3_api_change.patch \
18" 19"
19 20
20SRC_URI[archive.md5sum] = "65f5f28e2fe22d9ad8b17bb9a10df096" 21SRC_URI[archive.md5sum] = "65f5f28e2fe22d9ad8b17bb9a10df096"