summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-05-05 16:03:45 +0200
committerArmin Kuster <akuster808@gmail.com>2016-05-09 19:05:04 -0700
commit4a5b269b20da44704cf76d50a3335315802a0a67 (patch)
tree06684eba40bc7c175cd5d1a7aa724963c3dcbb30
parent6bcf20d71bb7d0659734cf8fd15079e4d24e8a81 (diff)
downloadmeta-openembedded-4a5b269b20da44704cf76d50a3335315802a0a67.tar.gz
pidgin: add PACKAGECONFIGs
* disable gstreamer and vv, because gstreamer 0.10 is in meta-multimedia now * disable farsight2/farstream, because farsight2 is blacklisted * don't enable X11 support without x11 in DISTRO_FEATURES * allow to disable all UI, useful for DISTROs who want just the purple libraries like LuneOS Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb31
1 files changed, 23 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb b/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb
index 9133c1ce2..ac0871fb4 100644
--- a/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb
+++ b/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "multi-protocol instant messaging client"
2SECTION = "x11/network" 2SECTION = "x11/network"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" 4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5DEPENDS = "python startup-notification avahi gtk+ ncurses gnutls virtual/libintl gstreamer dbus intltool-native farsight2 libidn libxml2 gconf dbus-glib" 5DEPENDS = "python virtual/libintl intltool-native libxml2 gconf"
6 6
7inherit autotools gettext pkgconfig gconf perlnative 7inherit autotools gettext pkgconfig gconf perlnative
8 8
@@ -16,18 +16,33 @@ SRC_URI = "\
16SRC_URI[md5sum] = "14e0f5cfb2ed065e4dc80391a806ac76" 16SRC_URI[md5sum] = "14e0f5cfb2ed065e4dc80391a806ac76"
17SRC_URI[sha256sum] = "2c7523f0fefe89749c03b2b738ab9f7bd186da435be4762f1487eee31e77ffdd" 17SRC_URI[sha256sum] = "2c7523f0fefe89749c03b2b738ab9f7bd186da435be4762f1487eee31e77ffdd"
18 18
19PACKAGECONFIG ??= "gnutls consoleui avahi dbus idn \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtk startup-notification', '', d)} \
21"
22PACKAGECONFIG[farsight2] = "--enable-farstream,--disable-farstream,farsight2"
23# --disable-gstreamer compile without GStreamer audio support
24# --disable-gstreamer-video
25# compile without GStreamer 1.0 Video Overlay support
26# --disable-gstreamer-interfaces
27# compile without GStreamer 0.10 interface support
28# --with-gstreamer=<version>
29# compile with GStreamer 0.10 or 1.0 interface
30PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
31PACKAGECONFIG[vv] = "--enable-vv,--disable-vv,gstreamer"
32PACKAGECONFIG[idn] = "--enable-idn,--disable-idn,libidn"
33PACKAGECONFIG[gtk] = "--enable-gtkui,--disable-gtkui,gtk+"
34PACKAGECONFIG[x11] = "--with-x=yes --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--with-x=no,virtual/libx11"
35PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
36PACKAGECONFIG[consoleui] = "--enable-consoleui --with-ncurses-headers=${STAGING_INCDIR},--disable-consoleui,ncurses"
37PACKAGECONFIG[gnutls] = "--enable-gnutls --with-gnutls-includes=${STAGING_INCDIR} --with-gnutls-libs=${STAGING_LIBDIR},--disable-gnutls,gnutls"
38PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
39PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
40
19EXTRA_OECONF = " \ 41EXTRA_OECONF = " \
20 --enable-vv \
21 --disable-perl \ 42 --disable-perl \
22 --disable-tcl \ 43 --disable-tcl \
23 --disable-gevolution \ 44 --disable-gevolution \
24 --disable-schemas-install \ 45 --disable-schemas-install \
25 --x-includes=${STAGING_INCDIR} \
26 --x-libraries=${STAGING_LIBDIR} \
27 --enable-gnutls=yes \
28 --with-ncurses-headers=${STAGING_INCDIR} \
29 --with-gnutls-includes=${STAGING_INCDIR} \
30 --with-gnutls-libs=${STAGING_LIBDIR} \
31 --disable-gtkspell \ 46 --disable-gtkspell \
32 --disable-meanwhile \ 47 --disable-meanwhile \
33 --disable-nm \ 48 --disable-nm \