summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2016-07-05 10:04:44 +0800
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commit3f073fc227e52cfd73a3d18508f74f0511ca738a (patch)
tree64faef76a51f6305d3e8f470c5e6cad639f36227
parentcb6d8e8fd222e5e4056769bc37127ff1ce2a6831 (diff)
downloadmeta-openembedded-3f073fc227e52cfd73a3d18508f74f0511ca738a.tar.gz
gtksourceview2: fix build with gcc6
Fix build error: ../../gtksourceview-2.10.5/gtksourceview/gtksourceprintcompositor.c: In function 'strdup_strftime': ../../gtksourceview-2.10.5/gtksourceview/gtksourceprintcompositor.c:1951:3: error: format not a string literal, format string not checked [-Werror=format-nonliteral] tmplen = strftime (tmpbuf, tmpbufsize, locale_format, tm); ^~~~~~ A wrapper for strftime() would compile failed with -Werror=format-nonliteral in newer GCC. See GCC bug: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=39438 Since most of the strdup_strftime function code is taken from GLib's g_date_strftime() in gdate.c which already had a fix: https://bugzilla.gnome.org/show_bug.cgi?id=761550 So this patch refers the glib fixes: https://git.gnome.org/browse/glib/commit/?id=0817af40e8c74c721c30f6ef482b1f53d12044c7 https://git.gnome.org/browse/glib/commit/?id=8cdbc7fb2c8c876902e457abe46ee18a0b134486 Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit ca363445b80b47f3e0c18cb9d96b9463ce86b913) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gtksourceview/gtksourceview2/suppress-string-format-literal-warning.patch33
-rw-r--r--meta-gnome/recipes-gnome/gtksourceview/gtksourceview2_2.10.5.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2/suppress-string-format-literal-warning.patch b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2/suppress-string-format-literal-warning.patch
new file mode 100644
index 000000000..f9ae07763
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2/suppress-string-format-literal-warning.patch
@@ -0,0 +1,33 @@
1Fix build error with gcc6:
2../../gtksourceview-2.10.5/gtksourceview/gtksourceprintcompositor.c: In function 'strdup_strftime':
3../../gtksourceview-2.10.5/gtksourceview/gtksourceprintcompositor.c:1951:3: error: format not a string literal, format string not checked [-Werror=format-nonliteral]
4 tmplen = strftime (tmpbuf, tmpbufsize, locale_format, tm);
5 ^~~~~~
6
7Patch Reference:
8https://git.gnome.org/browse/glib/commit/?id=0817af40e8c74c721c30f6ef482b1f53d12044c7
9https://git.gnome.org/browse/glib/commit/?id=8cdbc7fb2c8c876902e457abe46ee18a0b134486
10
11Upstream-Status: Pending
12Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
13
14diff -Nurp gtksourceview-2.10.5.orig/gtksourceview/gtksourceprintcompositor.c gtksourceview-2.10.5/gtksourceview/gtksourceprintcompositor.c
15--- gtksourceview-2.10.5.orig/gtksourceview/gtksourceprintcompositor.c 2016-07-01 13:11:43.631173762 +0800
16+++ gtksourceview-2.10.5/gtksourceview/gtksourceprintcompositor.c 2016-07-04 13:54:18.223726343 +0800
17@@ -1913,6 +1913,8 @@ setup_pango_layouts (GtkSourcePrintCompo
18 * GLIB - Library of useful routines for C programming
19 * Copyright (C) 1995-1997 Peter Mattis, Spencer Kimball and Josh MacDonald */
20
21+#pragma GCC diagnostic push
22+#pragma GCC diagnostic ignored "-Wformat-nonliteral"
23 static gchar *
24 strdup_strftime (const gchar *format, const struct tm *tm)
25 {
26@@ -1982,6 +1984,7 @@ strdup_strftime (const gchar *format, co
27
28 return convbuf;
29 }
30+#pragma GCC diagnostic pop
31
32 static gchar *
33 evaluate_format_string (GtkSourcePrintCompositor *compositor,
diff --git a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2_2.10.5.bb b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2_2.10.5.bb
index c745e345a..14ef7262b 100644
--- a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2_2.10.5.bb
+++ b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2_2.10.5.bb
@@ -15,6 +15,7 @@ inherit gnomebase lib_package gettext
15# overrule SRC_URI from gnome.conf 15# overrule SRC_URI from gnome.conf
16SRC_URI = "${GNOME_MIRROR}/${PNAME}/${@gnome_verdir("${PV}")}/${PNAME}-${PV}.tar.bz2;name=archive \ 16SRC_URI = "${GNOME_MIRROR}/${PNAME}/${@gnome_verdir("${PV}")}/${PNAME}-${PV}.tar.bz2;name=archive \
17 file://gtk-doc.make \ 17 file://gtk-doc.make \
18 file://suppress-string-format-literal-warning.patch \
18" 19"
19SRC_URI[archive.md5sum] = "1219ad1694df136f126507466aeb41aa" 20SRC_URI[archive.md5sum] = "1219ad1694df136f126507466aeb41aa"
20SRC_URI[archive.sha256sum] = "c585773743b1df8a04b1be7f7d90eecdf22681490d6810be54c81a7ae152191e" 21SRC_URI[archive.sha256sum] = "c585773743b1df8a04b1be7f7d90eecdf22681490d6810be54c81a7ae152191e"