summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnn Thornton <ann.thornton@nxp.com>2016-05-06 11:00:55 -0300
committerArmin Kuster <akuster808@gmail.com>2016-05-09 19:05:03 -0700
commit25b22fb75b066799672241928b8afb0b76ff3512 (patch)
tree20c0b88fb87ee335b48b648baf93223709096330
parentd4b1497f8c0d9eb288045c3a03c24ac851624c26 (diff)
downloadmeta-openembedded-25b22fb75b066799672241928b8afb0b76ff3512.tar.gz
packagegroup-tools-bluetooth.bb: Selects the tools appropriate for the version of bluez being used.
Signed-off-by: Ann Thornton <ann.thornton@nxp.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb b/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb
new file mode 100644
index 000000000..bdab389bc
--- /dev/null
+++ b/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb
@@ -0,0 +1,40 @@
1# Copyright (C) 2014-2015 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8SUMMARY = "Set of Bluetooh related tools for inclusion on images"
9DESCRIPTION = "Add bluetooth tools based on the version of BlueZ in use.\
10The tools that have been tested and work the best are pulled in \
11automatically. The same packagegroup can be used in a recipe without \
12the need to know which version of BlueZ is in use. \
13Supports BlueZ4 and BlueZ5."
14
15inherit packagegroup
16
17BLUEZ4_INSTALL = " \
18 obexftp \
19"
20
21BLUEZ5_INSTALL = " \
22 bluez5-noinst-tools \
23 bluez5-obex \
24 bluez5-testtools \
25 libasound-module-bluez \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', "pulseaudio-module-bluetooth-discover \
27 pulseaudio-module-bluetooth-policy \
28 pulseaudio-module-bluez5-discover \
29 pulseaudio-module-bluez5-device \
30 pulseaudio-module-switch-on-connect \
31 pulseaudio-module-loopback", \
32 '', d)} \
33"
34
35# Install either bluez4 or bluez5 if they are in distro.
36# Otherwise install nothing.
37RDEPENDS_${PN} = " \
38 ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', '${BLUEZ5_INSTALL}', "", d)} \
39 ${@bb.utils.contains('DISTRO_FEATURES', 'bluez4', '${BLUEZ4_INSTALL}', "", d)} \
40"