summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoran Cengic <cengic@gmail.com>2016-04-13 21:15:35 +0200
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:03 -0700
commit19284f3c09e702928cbf2ebc4811568d7caa9bec (patch)
tree7429c6170db103060bd66d56dfbf73ae227ef58b
parent70a46baf872e6f164b23b81fd4a074f84fc6537f (diff)
downloadmeta-openembedded-19284f3c09e702928cbf2ebc4811568d7caa9bec.tar.gz
crash: add cross package
This patch adds the cross package for the crash recipe. I've built and tested crash-cross for ARM on x86_64 host only. The way to pass GDB_CONF_FLAGS and --target to GDB build without removing -m32 from CFLAGS is awkward but that is what I could come up with, without changing the patch files included with the recipe or breaking target and native builds. Anyone got any ideas on how to better do this? Thanks, Goran Signed-off-by: Goran Cengic <cengic@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-kernel/crash/crash_7.1.3.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash_7.1.3.bb b/meta-oe/recipes-kernel/crash/crash_7.1.3.bb
index d057300f4..b787f0266 100644
--- a/meta-oe/recipes-kernel/crash/crash_7.1.3.bb
+++ b/meta-oe/recipes-kernel/crash/crash_7.1.3.bb
@@ -32,7 +32,7 @@ SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5
32 32
33inherit gettext 33inherit gettext
34 34
35BBCLASSEXTEND = "native" 35BBCLASSEXTEND = "native cross"
36 36
37# crash 7.1.3 and before don't support mips64 37# crash 7.1.3 and before don't support mips64
38COMPATIBLE_HOST = "^(?!mips64).*" 38COMPATIBLE_HOST = "^(?!mips64).*"
@@ -42,7 +42,21 @@ EXTRA_OEMAKE = 'RPMPKG="${PV}" \
42 GDB_HOST="${BUILD_SYS}" \ 42 GDB_HOST="${BUILD_SYS}" \
43 GDB_MAKE_JOBS="${PARALLEL_MAKE}" \ 43 GDB_MAKE_JOBS="${PARALLEL_MAKE}" \
44 ' 44 '
45
46EXTRA_OEMAKE_class-cross = 'RPMPKG="${PV}" \
47 GDB_TARGET="${BUILD_SYS} \
48 \${GDB_CONF_FLAGS} \
49 --target=${TARGET_SYS}" \
50 GDB_HOST="${BUILD_SYS}" \
51 GDB_MAKE_JOBS="${PARALLEL_MAKE}" \
52 '
53
45EXTRA_OEMAKE_append_class-native = " LDFLAGS='${BUILD_LDFLAGS}'" 54EXTRA_OEMAKE_append_class-native = " LDFLAGS='${BUILD_LDFLAGS}'"
55EXTRA_OEMAKE_append_class-cross = " LDFLAGS='${BUILD_LDFLAGS}'"
56
57REMOVE_M32 = "sed -i -e 's/#define TARGET_CFLAGS_ARM_ON_X86_64.*/#define TARGET_CFLAGS_ARM_ON_X86_64\t\"TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64\"/g' ${S}/configure.c"
58
59REMOVE_M32_class-cross = ""
46 60
47do_configure() { 61do_configure() {
48 : 62 :
@@ -60,7 +74,7 @@ do_compile_prepend() {
60 esac 74 esac
61 75
62 sed -i s/FORCE_DEFINE_ARCH/"${ARCH}"/g ${S}/configure.c 76 sed -i s/FORCE_DEFINE_ARCH/"${ARCH}"/g ${S}/configure.c
63 sed -i -e 's/#define TARGET_CFLAGS_ARM_ON_X86_64.*/#define TARGET_CFLAGS_ARM_ON_X86_64\t\"TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64\"/g' ${S}/configure.c 77 ${REMOVE_M32}
64 sed -i 's/&gt;/>/g' ${S}/Makefile 78 sed -i 's/&gt;/>/g' ${S}/Makefile
65} 79}
66 80
@@ -85,8 +99,13 @@ do_install_class-native () {
85 oe_runmake DESTDIR=${D}${STAGING_DIR_NATIVE} install 99 oe_runmake DESTDIR=${D}${STAGING_DIR_NATIVE} install
86} 100}
87 101
102do_install_class-cross () {
103 install -m 0755 ${S}/crash ${D}/${bindir}
104}
105
88RDEPENDS_${PN} += "liblzma" 106RDEPENDS_${PN} += "liblzma"
89RDEPENDS_${PN}_class-native = "" 107RDEPENDS_${PN}_class-native = ""
108RDEPENDS_${PN}_class-cross = ""
90 109
91# Causes gcc to get stuck and eat all available memory in qemuarm builds 110# Causes gcc to get stuck and eat all available memory in qemuarm builds
92# jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - 111# jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o -