summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-03-24 17:47:46 +0100
committerArmin Kuster <akuster808@gmail.com>2021-04-07 08:55:15 -0700
commitff5ae4c168eb0be0456926112ad956b945748dc0 (patch)
tree0028e6178f7b9c825f0fee2904c24f715977a1d7
parent997c27d55eac670afdce07aac1cdfeb181d07ee6 (diff)
downloadmeta-openembedded-ff5ae4c168eb0be0456926112ad956b945748dc0.tar.gz
ceres-solver: prevent fetching git hook during do_configure
* today I've found 2 jenkins jobs stuck way too long sitting in this do_configure Bitbake still alive (5000s) Bitbake still alive (10000s) Bitbake still alive (15000s) Bitbake still alive (20000s) Bitbake still alive (25000s) Bitbake still alive (30000s) ... manually killed, the CMake ... ERROR: ceres-solver-1.14.0-r0 do_configure: Execution of 'ceres-solver/1.14.0-r0/temp/run.do_configure.39438' failed with exit code 143: ... | -- Detected Ceres being used as a git submodule, adding commit hook for Gerrit to: ceres-solver/1.14.0-r0/git/.git | ceres-solver/1.14.0-r0/temp/run.do_configure.39438: line 213: 39485 Terminated cmake -G 'Ninja' -DCMAKE_MAKE_PROGRAM=ninja ... I've seen it with dunfell and gatesgarth, but master has the same ADD_GERRIT_COMMIT_HOOK function (just in newer ceres-solver release), so probably needs the same. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/ceres-solver/ceres-solver_1.14.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ceres-solver/ceres-solver_1.14.0.bb b/meta-oe/recipes-support/ceres-solver/ceres-solver_1.14.0.bb
index ac463038a..105610be5 100644
--- a/meta-oe/recipes-support/ceres-solver/ceres-solver_1.14.0.bb
+++ b/meta-oe/recipes-support/ceres-solver/ceres-solver_1.14.0.bb
@@ -13,6 +13,14 @@ S = "${WORKDIR}/git"
13 13
14inherit cmake 14inherit cmake
15 15
16do_configure_prepend() {
17 # otherwise https://github.com/ceres-solver/ceres-solver/blob/0b748597889f460764f6c980a00c6f502caa3875/cmake/AddGerritCommitHook.cmake#L68
18 # will try to fetch https://ceres-solver-review.googlesource.com/tools/hooks/commit-msg durind do_configure
19 # which sometimes gets stuck (as there is no TIMEOUT set in DOWNLOAD)
20 # and we really don't need Gerrit's Change-Id tags when just building this
21 touch ${S}/.git/hooks/commit-msg
22}
23
16# We don't want path to eigen3 in ceres-solver RSS to be 24# We don't want path to eigen3 in ceres-solver RSS to be
17# used by components which use CeresConfig.cmake from their 25# used by components which use CeresConfig.cmake from their
18# own RSS 26# own RSS