summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-05-18 16:07:59 +0800
committerArmin Kuster <akuster808@gmail.com>2021-05-22 16:13:38 -0700
commit8ac16502753b72fd1df1d88d5773ab5077d868b8 (patch)
tree2ced2a1c77714963fd328d63fa1c121f64b56393
parent29953069d9d9c2868d831492ccec7b171403ac04 (diff)
downloadmeta-openembedded-8ac16502753b72fd1df1d88d5773ab5077d868b8.tar.gz
exiv2: Fix CVE-2021-29470
References https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29470 The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Upstream-Status: Accepted [https://github.com/Exiv2/exiv2/pull/1581/commits/6628a69c036df2aa036290e6cd71767c159c79ed] CVE: CVE-2021-29470 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit bb1400efda77a7289ca20782172bfbe1f457f161) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/exiv2/exiv2/CVE-2021-29470.patch32
-rw-r--r--meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/exiv2/exiv2/CVE-2021-29470.patch b/meta-oe/recipes-support/exiv2/exiv2/CVE-2021-29470.patch
new file mode 100644
index 000000000..eedf9d79a
--- /dev/null
+++ b/meta-oe/recipes-support/exiv2/exiv2/CVE-2021-29470.patch
@@ -0,0 +1,32 @@
1From 6628a69c036df2aa036290e6cd71767c159c79ed Mon Sep 17 00:00:00 2001
2From: Kevin Backhouse <kevinbackhouse@github.com>
3Date: Wed, 21 Apr 2021 12:06:04 +0100
4Subject: [PATCH] Add more bounds checks in Jp2Image::encodeJp2Header
5---
6 src/jp2image.cpp | 3 +++
7 1 file changed, 3 insertions(+)
8
9diff --git a/src/jp2image.cpp b/src/jp2image.cpp
10index b424225..349a9f0 100644
11--- a/src/jp2image.cpp
12+++ b/src/jp2image.cpp
13@@ -645,13 +645,16 @@ static void boxes_check(size_t b,size_t m)
14 DataBuf output(boxBuf.size_ + iccProfile_.size_ + 100); // allocate sufficient space
15 long outlen = sizeof(Jp2BoxHeader) ; // now many bytes have we written to output?
16 long inlen = sizeof(Jp2BoxHeader) ; // how many bytes have we read from boxBuf?
17+ enforce(sizeof(Jp2BoxHeader) <= static_cast<size_t>(output.size_), Exiv2::kerCorruptedMetadata);
18 Jp2BoxHeader* pBox = (Jp2BoxHeader*) boxBuf.pData_;
19 uint32_t length = getLong((byte*)&pBox->length, bigEndian);
20+ enforce(length <= static_cast<size_t>(output.size_), Exiv2::kerCorruptedMetadata);
21 uint32_t count = sizeof (Jp2BoxHeader);
22 char* p = (char*) boxBuf.pData_;
23 bool bWroteColor = false ;
24
25 while ( count < length || !bWroteColor ) {
26+ enforce(sizeof(Jp2BoxHeader) <= length - count, Exiv2::kerCorruptedMetadata);
27 Jp2BoxHeader* pSubBox = (Jp2BoxHeader*) (p+count) ;
28
29 // copy data. pointer could be into a memory mapped file which we will decode!
30--
312.25.1
32
diff --git a/meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb b/meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb
index 024f4c794..2419bab35 100644
--- a/meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb
+++ b/meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb
@@ -14,6 +14,7 @@ SRC_URI += "file://0001-Use-compiler-fcf-protection-only-if-compiler-arch-su.pat
14 file://CVE-2021-29458.patch \ 14 file://CVE-2021-29458.patch \
15 file://CVE-2021-29463.patch \ 15 file://CVE-2021-29463.patch \
16 file://CVE-2021-29464.patch \ 16 file://CVE-2021-29464.patch \
17 file://CVE-2021-29470.patch \
17 file://CVE-2021-3482.patch" 18 file://CVE-2021-3482.patch"
18 19
19S = "${WORKDIR}/${BPN}-${PV}-Source" 20S = "${WORKDIR}/${BPN}-${PV}-Source"