summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-17 10:09:21 +0100
committerArmin Kuster <akuster808@gmail.com>2023-11-17 10:48:51 -0500
commitd6684037772a6e1ad548dac7aebf288b281e7a14 (patch)
tree5d46deeb096e6ffd91758e2ea286816f265b2b94
parente94b264db994d8cc2f1ccad08e35878ed4450f9c (diff)
downloadmeta-openembedded-d6684037772a6e1ad548dac7aebf288b281e7a14.tar.gz
meta-perl: Drop broken BBCLASSEXTEND variants
The command "bitbake universe -c fetch" currently throws a ton of warnings as there are many 'impossible' dependencies. In some cases these variants may never have worked and were just added by copy and paste of recipes. In some cases they once clearly did work but became broken somewhere along the way. Users may also be carrying local bbappend files which add further BBCLASSEXTEND. Having universe fetch work without warnings is desireable so clean up the broken variants. Anyone actually needing something dropped here can propose adding it and the correct functional dependencies back quite easily. This also then ensures we're not carrying or fixing things nobody uses. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 79e0a9d237343ad0af0a40128494155ccaa131ec) Backported: * Adapted paths to follow PV changes * Adapted modified recipes to the ones generating warnings Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb2
-rw-r--r--meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.074.bb2
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-dns-perl_1.33.bb2
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.68.bb2
-rw-r--r--meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb2
5 files changed, 1 insertions, 9 deletions
diff --git a/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb b/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb
index 5db0bb426..5c3701f16 100644
--- a/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb
+++ b/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb
@@ -38,4 +38,4 @@ S = "${WORKDIR}/Config-AutoConf-${PV}"
38 38
39inherit cpan ptest-perl 39inherit cpan ptest-perl
40 40
41BBCLASSEXTEND = "native nativesdk" 41BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.074.bb b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.074.bb
index 6249fd1d7..6e04e40dc 100644
--- a/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.074.bb
+++ b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.074.bb
@@ -42,5 +42,3 @@ do_install_ptest () {
42 cp -r ${B}/t ${D}${PTEST_PATH} 42 cp -r ${B}/t ${D}${PTEST_PATH}
43 cp -r ${B}/certs ${D}${PTEST_PATH} 43 cp -r ${B}/certs ${D}${PTEST_PATH}
44} 44}
45
46BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.33.bb b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.33.bb
index 2c7d793a7..c768d64e3 100644
--- a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.33.bb
+++ b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.33.bb
@@ -61,5 +61,3 @@ python __anonymous () {
61 raise bb.parse.SkipRecipe("incompatible with %s C library" % 61 raise bb.parse.SkipRecipe("incompatible with %s C library" %
62 d.getVar('TCLIBC')) 62 d.getVar('TCLIBC'))
63} 63}
64
65BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.68.bb b/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.68.bb
index dcc5ea88b..a77381dce 100644
--- a/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.68.bb
+++ b/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.68.bb
@@ -41,5 +41,3 @@ RDEPENDS:${PN}-ptest += " \
41 perl-module-perlio \ 41 perl-module-perlio \
42 perl-module-test-more \ 42 perl-module-test-more \
43" 43"
44
45BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb b/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb
index c568ade99..01261d547 100644
--- a/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb
+++ b/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb
@@ -36,5 +36,3 @@ S = "${WORKDIR}/Unix-Statgrab-${PV}"
36export LD = "${CCLD}" 36export LD = "${CCLD}"
37 37
38inherit cpan pkgconfig ptest-perl 38inherit cpan pkgconfig ptest-perl
39
40BBCLASSEXTEND = "native"