summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-17 10:17:33 +0100
committerArmin Kuster <akuster808@gmail.com>2023-11-17 10:49:04 -0500
commitc6b90f27a4c13d70df498e800b50db234d1a62a0 (patch)
tree4edfaf473febf7bb29159fbe2ae68e5484ce907b
parent1580553d0a9e23f4fb8474ddc7cd4c4f8b8ae0f8 (diff)
downloadmeta-openembedded-c6b90f27a4c13d70df498e800b50db234d1a62a0.tar.gz
meta-oe: Drop broken BBCLASSEXTEND variants
The command "bitbake universe -c fetch" currently throws a ton of warnings as there are many 'impossible' dependencies. In some cases these variants may never have worked and were just added by copy and paste of recipes. In some cases they once clearly did work but became broken somewhere along the way. Users may also be carrying local bbappend files which add further BBCLASSEXTEND. Having universe fetch work without warnings is desireable so clean up the broken variants. Anyone actually needing something dropped here can propose adding it and the correct functional dependencies back quite easily. This also then ensures we're not carrying or fixing things nobody uses. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 9962d57f7c235873de0a0bb192b5f56747762fc7) Backport: * Updated paths to follow PV changes * Adapted modified recipes to the ones generating warnings Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/ser2net/ser2net_4.3.5.bb2
-rw-r--r--meta-oe/recipes-connectivity/zeromq/czmq_4.2.1.bb2
-rw-r--r--meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb2
-rw-r--r--meta-oe/recipes-devtools/unifex/unifex_git.bb2
-rw-r--r--meta-oe/recipes-graphics/openjpeg/openjpeg_2.4.0.bb2
-rw-r--r--meta-oe/recipes-graphics/xorg-app/xkbutils_1.0.4.bb2
-rw-r--r--meta-oe/recipes-graphics/xorg-app/xsetroot_1.1.2.bb1
7 files changed, 2 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/ser2net/ser2net_4.3.5.bb b/meta-oe/recipes-connectivity/ser2net/ser2net_4.3.5.bb
index 79d54038e..a33265063 100644
--- a/meta-oe/recipes-connectivity/ser2net/ser2net_4.3.5.bb
+++ b/meta-oe/recipes-connectivity/ser2net/ser2net_4.3.5.bb
@@ -14,5 +14,3 @@ SRC_URI[sha256sum] = "848c4fe863806e506832f1ee85b8b68258f06eb19dad43dbeee16a2cfe
14UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/ser2net/files/ser2net" 14UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/ser2net/files/ser2net"
15 15
16inherit autotools pkgconfig 16inherit autotools pkgconfig
17
18BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-connectivity/zeromq/czmq_4.2.1.bb b/meta-oe/recipes-connectivity/zeromq/czmq_4.2.1.bb
index 86fde7ccf..ce9d758d9 100644
--- a/meta-oe/recipes-connectivity/zeromq/czmq_4.2.1.bb
+++ b/meta-oe/recipes-connectivity/zeromq/czmq_4.2.1.bb
@@ -30,8 +30,6 @@ PACKAGECONFIG[nss] = "-DCZMQ_WITH_NSS=ON,-DCZMQ_WITH_NSS=OFF,nss"
30PACKAGECONFIG[systemd] = "-DCZMQ_WITH_SYSTEMD=ON,-DCZMQ_WITH_SYSTEMD=OFF,systemd" 30PACKAGECONFIG[systemd] = "-DCZMQ_WITH_SYSTEMD=ON,-DCZMQ_WITH_SYSTEMD=OFF,systemd"
31PACKAGECONFIG[uuid] = "-DCZMQ_WITH_UUID=ON,-DCZMQ_WITH_UUID=OFF,util-linux" 31PACKAGECONFIG[uuid] = "-DCZMQ_WITH_UUID=ON,-DCZMQ_WITH_UUID=OFF,util-linux"
32 32
33BBCLASSEXTEND = "nativesdk"
34
35do_install:append() { 33do_install:append() {
36 mkdir -p ${D}/${includedir}/${BPN} 34 mkdir -p ${D}/${includedir}/${BPN}
37 mv ${D}/${includedir}/sha1.h ${D}/${includedir}/${BPN}/. 35 mv ${D}/${includedir}/sha1.h ${D}/${includedir}/${BPN}/.
diff --git a/meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb b/meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb
index 29937e26d..be2c0f539 100644
--- a/meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb
+++ b/meta-oe/recipes-devtools/heaptrack/heaptrack_1.2.0.bb
@@ -29,4 +29,4 @@ EXTRA_OECMAKE += "-DHEAPTRACK_BUILD_GUI=OFF"
29COMPATIBLE_HOST:riscv32 = "null" 29COMPATIBLE_HOST:riscv32 = "null"
30COMPATIBLE_HOST:riscv64 = "null" 30COMPATIBLE_HOST:riscv64 = "null"
31 31
32BBCLASSEXTEND = "native nativesdk" 32BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-devtools/unifex/unifex_git.bb b/meta-oe/recipes-devtools/unifex/unifex_git.bb
index 85fe39b6d..f55d7e32c 100644
--- a/meta-oe/recipes-devtools/unifex/unifex_git.bb
+++ b/meta-oe/recipes-devtools/unifex/unifex_git.bb
@@ -20,5 +20,3 @@ EXTRA_OECMAKE += " \
20 -DCMAKE_CXX_STANDARD=20 \ 20 -DCMAKE_CXX_STANDARD=20 \
21 -DUNIFEX_BUILD_EXAMPLES=OFF \ 21 -DUNIFEX_BUILD_EXAMPLES=OFF \
22 " 22 "
23
24BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-graphics/openjpeg/openjpeg_2.4.0.bb b/meta-oe/recipes-graphics/openjpeg/openjpeg_2.4.0.bb
index 42d2b4efb..1c090fdea 100644
--- a/meta-oe/recipes-graphics/openjpeg/openjpeg_2.4.0.bb
+++ b/meta-oe/recipes-graphics/openjpeg/openjpeg_2.4.0.bb
@@ -26,4 +26,4 @@ EXTRA_OECMAKE += "-DOPENJPEG_INSTALL_LIB_DIR=${@d.getVar('baselib').replace('/',
26 26
27FILES:${PN} += "${libdir}/openjpeg*" 27FILES:${PN} += "${libdir}/openjpeg*"
28 28
29BBCLASSEXTEND = "native nativesdk" 29BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-graphics/xorg-app/xkbutils_1.0.4.bb b/meta-oe/recipes-graphics/xorg-app/xkbutils_1.0.4.bb
index 6a05e98e3..d394b33de 100644
--- a/meta-oe/recipes-graphics/xorg-app/xkbutils_1.0.4.bb
+++ b/meta-oe/recipes-graphics/xorg-app/xkbutils_1.0.4.bb
@@ -13,7 +13,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=64322fab5239f5c8d97cf6e0e14f1c62"
13 13
14DEPENDS += "libxaw libxkbfile" 14DEPENDS += "libxaw libxkbfile"
15 15
16BBCLASSEXTEND = "native"
17
18SRC_URI[md5sum] = "502b14843f610af977dffc6cbf2102d5" 16SRC_URI[md5sum] = "502b14843f610af977dffc6cbf2102d5"
19SRC_URI[sha256sum] = "d2a18ab90275e8bca028773c44264d2266dab70853db4321bdbc18da75148130" 17SRC_URI[sha256sum] = "d2a18ab90275e8bca028773c44264d2266dab70853db4321bdbc18da75148130"
diff --git a/meta-oe/recipes-graphics/xorg-app/xsetroot_1.1.2.bb b/meta-oe/recipes-graphics/xorg-app/xsetroot_1.1.2.bb
index 30a1e089e..a9a8acf05 100644
--- a/meta-oe/recipes-graphics/xorg-app/xsetroot_1.1.2.bb
+++ b/meta-oe/recipes-graphics/xorg-app/xsetroot_1.1.2.bb
@@ -8,7 +8,6 @@ LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=6ea29dbee22324787c061f039e0529de" 8LIC_FILES_CHKSUM = "file://COPYING;md5=6ea29dbee22324787c061f039e0529de"
9 9
10DEPENDS += "xbitmaps libxcursor" 10DEPENDS += "xbitmaps libxcursor"
11BBCLASSEXTEND = "native"
12 11
13SRC_URI[md5sum] = "5fe769c8777a6e873ed1305e4ce2c353" 12SRC_URI[md5sum] = "5fe769c8777a6e873ed1305e4ce2c353"
14SRC_URI[sha256sum] = "10c442ba23591fb5470cea477a0aa5f679371f4f879c8387a1d9d05637ae417c" 13SRC_URI[sha256sum] = "10c442ba23591fb5470cea477a0aa5f679371f4f879c8387a1d9d05637ae417c"