summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-17 10:18:24 +0100
committerArmin Kuster <akuster808@gmail.com>2023-11-18 10:03:15 -0500
commit32c6598ed32b209df1b436d880a2a66d09902d3a (patch)
tree77a98afd753937eb6b7228daee826c33f1369e86
parenta3df85aa41edaa2b6c9b83635ac89f0a6785699b (diff)
downloadmeta-openembedded-32c6598ed32b209df1b436d880a2a66d09902d3a.tar.gz
meta-python: Drop broken BBCLASSEXTEND variants
The command "bitbake universe -c fetch" currently throws a ton of warnings as there are many 'impossible' dependencies. In some cases these variants may never have worked and were just added by copy and paste of recipes. In some cases they once clearly did work but became broken somewhere along the way. Users may also be carrying local bbappend files which add further BBCLASSEXTEND. Having universe fetch work without warnings is desireable so clean up the broken variants. Anyone actually needing something dropped here can propose adding it and the correct functional dependencies back quite easily. This also then ensures we're not carrying or fixing things nobody uses. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit d4aa17dc436beb96a804860bc6d18cf72283709e) Backport: * Adapted paths to follow PV changes * Adapted modified recipes to the ones generating warnings Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.5.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-autobahn_22.3.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyudev_0.23.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-snappy_0.6.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-txaio_22.2.1.bb2
-rw-r--r--meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.0.0.bb2
7 files changed, 1 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.5.bb b/meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.5.bb
index c86ec092a..871eb7cae 100644
--- a/meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.5.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.5.bb
@@ -11,5 +11,3 @@ RDEPENDS:${PN} += " \
11 ${PYTHON_PN}-jinja2 \ 11 ${PYTHON_PN}-jinja2 \
12 ${PYTHON_PN}-aiohttp \ 12 ${PYTHON_PN}-aiohttp \
13" 13"
14
15BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-autobahn_22.3.2.bb b/meta-python/recipes-devtools/python/python3-autobahn_22.3.2.bb
index 78514a412..afb798bd7 100644
--- a/meta-python/recipes-devtools/python/python3-autobahn_22.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-autobahn_22.3.2.bb
@@ -19,5 +19,3 @@ RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-txaio \ 19 ${PYTHON_PN}-txaio \
20 ${PYTHON_PN}-six \ 20 ${PYTHON_PN}-six \
21" 21"
22
23BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyudev_0.23.2.bb b/meta-python/recipes-devtools/python/python3-pyudev_0.23.2.bb
index 4c4c959eb..035e14951 100644
--- a/meta-python/recipes-devtools/python/python3-pyudev_0.23.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyudev_0.23.2.bb
@@ -21,4 +21,4 @@ RDEPENDS:${PN} = "\
21 libudev \ 21 libudev \
22" 22"
23 23
24BBCLASSEXTEND = "native nativesdk" 24BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb
index d9465af08..ecc15499c 100644
--- a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb
@@ -16,5 +16,3 @@ RDEPENDS:${PN} += " \
16 ${PYTHON_PN}-pyserial \ 16 ${PYTHON_PN}-pyserial \
17 ${PYTHON_PN}-robotframework \ 17 ${PYTHON_PN}-robotframework \
18" 18"
19
20BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-snappy_0.6.1.bb b/meta-python/recipes-devtools/python/python3-snappy_0.6.1.bb
index 8a30f7cb7..bd0979d0b 100644
--- a/meta-python/recipes-devtools/python/python3-snappy_0.6.1.bb
+++ b/meta-python/recipes-devtools/python/python3-snappy_0.6.1.bb
@@ -11,5 +11,3 @@ inherit pypi setuptools3
11PYPI_PACKAGE = "python-snappy" 11PYPI_PACKAGE = "python-snappy"
12 12
13RDEPENDS:${PN} += "snappy" 13RDEPENDS:${PN} += "snappy"
14
15BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-txaio_22.2.1.bb b/meta-python/recipes-devtools/python/python3-txaio_22.2.1.bb
index e2102695e..50f14b17f 100644
--- a/meta-python/recipes-devtools/python/python3-txaio_22.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-txaio_22.2.1.bb
@@ -10,5 +10,3 @@ inherit pypi setuptools3
10RDEPENDS:${PN} += " \ 10RDEPENDS:${PN} += " \
11 ${PYTHON_PN}-twisted \ 11 ${PYTHON_PN}-twisted \
12" 12"
13
14BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.0.0.bb b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.0.0.bb
index 3a9f0ad6f..976dd12d5 100644
--- a/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.0.0.bb
+++ b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.0.0.bb
@@ -35,5 +35,3 @@ RDEPENDS:${PN}:class-target += "\
35 ${PYTHON_PN}-nocaselist \ 35 ${PYTHON_PN}-nocaselist \
36 ${PYTHON_PN}-custom-inherit \ 36 ${PYTHON_PN}-custom-inherit \
37" 37"
38
39BBCLASSEXTEND = "native"