summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2016-02-23 13:45:32 -0500
committerArmin Kuster <akuster808@gmail.com>2016-04-17 12:51:53 -0700
commitf1dc4078e1bf2942218ccc2fae23db2a72afef38 (patch)
tree0f0a0b4d8a6fecbb58230cd255e0113693fd7b1c
parent70ed0a32c5b858f3ae91c2f1e7c9efd66e9a13ca (diff)
downloadmeta-openembedded-f1dc4078e1bf2942218ccc2fae23db2a72afef38.tar.gz
log4cpp: Fix build system path in pkgconfig file QA failure.
* Must remove path from pc.in and stop configure.in from regenerating the file. * Also included some changes requested in earlier review that arrived late. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/log4cpp/files/fix-pc.patch20
-rw-r--r--meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb8
2 files changed, 25 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/log4cpp/files/fix-pc.patch b/meta-oe/recipes-support/log4cpp/files/fix-pc.patch
new file mode 100644
index 000000000..b8fb42e5f
--- /dev/null
+++ b/meta-oe/recipes-support/log4cpp/files/fix-pc.patch
@@ -0,0 +1,20 @@
1diff -Nurd ./log4cpp.orig/configure.in ./log4cpp/configure.in
2--- ./log4cpp.orig/configure.in 2009-09-07 16:57:46.000000000 -0400
3+++ ./log4cpp/configure.in 2016-02-23 12:57:11.567240018 -0500
4@@ -130,7 +130,6 @@
5 # ----------------------------------------------------------------------------
6
7 AC_CONFIG_LIBCONFIG_IN([log4cpp])
8-AC_CONFIG_PKGCONFIG_IN([log4cpp], [C++ library for flexible logging, modeled after Log4j])
9
10 AC_CONFIG_FILES([
11 Makefile
12diff -Nurd ./log4cpp.orig/log4cpp.pc.in ./log4cpp/log4cpp.pc.in
13--- ./log4cpp.orig/log4cpp.pc.in 2004-01-27 05:24:25.000000000 -0500
14+++ ./log4cpp/log4cpp.pc.in 2016-02-22 15:06:55.769327491 -0500
15@@ -7,4 +7,4 @@
16 Description: C++ library for flexible logging, modeled after Log4j
17 Version: @VERSION@
18 Libs: -L${libdir} @log4cpp_libs@
19-Cflags: -I${includedir} @log4cpp_cflags@
20+Cflags: -I${includedir}
diff --git a/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb b/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
index a54304416..c7bf288fa 100644
--- a/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
+++ b/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
@@ -6,9 +6,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
6SRC_URI[md5sum] = "1e173df8ee97205f412ff84aa93b8fbe" 6SRC_URI[md5sum] = "1e173df8ee97205f412ff84aa93b8fbe"
7SRC_URI[sha256sum] = "35abf332630a6809c969276b1d60b90c81a95daf24c86cfd7866ffef72f9bed0" 7SRC_URI[sha256sum] = "35abf332630a6809c969276b1d60b90c81a95daf24c86cfd7866ffef72f9bed0"
8 8
9SRC_URI = "http://downloads.sourceforge.net/${BPN}/${BP}.tar.gz" 9SRC_URI = "http://downloads.sourceforge.net/${BPN}/${BP}.tar.gz \
10 file://fix-pc.patch;striplevel=2 \
11 "
10 12
11S="${WORKDIR}/${BPN}" 13S = "${WORKDIR}/${BPN}"
12 14
13inherit autotools pkgconfig 15inherit autotools pkgconfig
14 16
@@ -17,5 +19,5 @@ EXTRA_OECONF = "\
17 --enable-dot=no \ 19 --enable-dot=no \
18 --enable-html-docs=no \ 20 --enable-html-docs=no \
19 --enable-latex-docs=no \ 21 --enable-latex-docs=no \
20 LDFLAGS=-lpthread \ 22 LDFLAGS=-pthread \
21" 23"