summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Rehsack <rehsack@gmail.com>2015-11-12 17:17:25 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-16 21:57:47 +0100
commitdeb13634e955b9a1452fb1813e7af1ec916550f5 (patch)
tree08adbf7590f90e899a17ba26469fd0aab24958e5
parent9dfa0687309c6a69e2adc93cc34c74e642bce37c (diff)
downloadmeta-openembedded-deb13634e955b9a1452fb1813e7af1ec916550f5.tar.gz
samba: fix dependencies and QA issues
Fix remaining QA issues (dependency-wise) like WARNING: QA Issue: samba rdepends on libacl, but it isn't a build dependency? [build-deps] WARNING: QA Issue: samba rdepends on libavahi-client, but it isn't a build dependency? [build-deps] broken perl library path, having a default PACKAGECONFIG, but allow user-defined one and rely on PACKAGECONFIG instead of DISTRO_FEATURES. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/samba/samba_4.1.12.bb41
1 files changed, 30 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/samba/samba_4.1.12.bb b/meta-oe/recipes-connectivity/samba/samba_4.1.12.bb
index af2cc1fdf..04df8a3ce 100644
--- a/meta-oe/recipes-connectivity/samba/samba_4.1.12.bb
+++ b/meta-oe/recipes-connectivity/samba/samba_4.1.12.bb
@@ -38,26 +38,40 @@ SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \
38SRC_URI[md5sum] = "232016d7581a1ba11e991ec2674553c4" 38SRC_URI[md5sum] = "232016d7581a1ba11e991ec2674553c4"
39SRC_URI[sha256sum] = "033604674936bf5c77d7df299b0626052b84a41505a6a6afe902f6274fc29898" 39SRC_URI[sha256sum] = "033604674936bf5c77d7df299b0626052b84a41505a6a6afe902f6274fc29898"
40 40
41inherit systemd waf-samba 41inherit systemd waf-samba cpan-base perlnative
42 42
43DEPENDS += "readline virtual/libiconv zlib popt talloc libtdb libtevent libldb krb5 ctdb cups" 43DEPENDS += "readline virtual/libiconv zlib popt talloc libtdb libtevent libldb krb5 ctdb"
44RDEPENDS_${PN} += "openldap"
45 44
46PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" 45SYSVINITTYPE_linuxstdbase = "lsb"
47PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 46SYSVINITTYPE = "sysv"
48 47
49PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" 48PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
49 ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', '${SYSVINITTYPE}', '', d)} \
50 ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
51 ${@base_contains('DISTRO_FEATURES', 'zeroconf', 'zeroconf', '', d)} \
52 acl aio cups ldap \
53"
54
55RDEPENDS_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'lsb', 'lsb', '', d)}"
56
57PACKAGECONFIG[acl] = "--with-acl-support,---without-acl-support,acl"
58PACKAGECONFIG[aio] = "--with-aio-support,---without-aio-support,libaio"
50PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin" 59PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin"
60PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam"
61PACKAGECONFIG[lsb] = ",,lsb"
62PACKAGECONFIG[cups] = "--enable-cups,--disable-cups,cups"
63PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
51PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd" 64PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd"
65PACKAGECONFIG[zeroconf] = "--enable-avahi,--disable-avahi,avahi"
52 66
53SAMBA4_IDMAP_MODULES="idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2" 67SAMBA4_IDMAP_MODULES="idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2"
54SAMBA4_PDB_MODULES="pdb_tdbsam,pdb_ldap,pdb_ads,pdb_smbpasswd,pdb_wbc_sam,pdb_samba4" 68SAMBA4_PDB_MODULES="pdb_tdbsam,${@bb.utils.contains('PACKAGECONFIG', 'ldap', 'pdb_ldap,', '', d)}pdb_ads,pdb_smbpasswd,pdb_wbc_sam,pdb_samba4"
55SAMBA4_AUTH_MODULES="auth_unix,auth_wbc,auth_server,auth_netlogond,auth_script,auth_samba4" 69SAMBA4_AUTH_MODULES="auth_unix,auth_wbc,auth_server,auth_netlogond,auth_script,auth_samba4"
56SAMBA4_MODULES="${SAMBA4_IDMAP_MODULES},${SAMBA4_PDB_MODULES},${SAMBA4_AUTH_MODULES}" 70SAMBA4_MODULES="${SAMBA4_IDMAP_MODULES},${SAMBA4_PDB_MODULES},${SAMBA4_AUTH_MODULES}"
57 71
58SAMBA4_LIBS="heimdal,!zlib,!popt,!talloc,!pytalloc,!pytalloc-util,!tevent,!pytevent,!tdb,!pytdb,!ldb,!pyldb" 72SAMBA4_LIBS="heimdal,!zlib,!popt,!talloc,!pytalloc,!pytalloc-util,!tevent,!pytevent,!tdb,!pytdb,!ldb,!pyldb"
59 73
60PERL_VERNDORLIB="${datadir}/perl5/vendor_perl/" 74PERL_VERNDORLIB="${libdir}/perl5/vendor_perl/${PERLVERSION}"
61 75
62EXTRA_OECONF += "--enable-fhs \ 76EXTRA_OECONF += "--enable-fhs \
63 --with-piddir=${localstatedir}/run \ 77 --with-piddir=${localstatedir}/run \
@@ -85,7 +99,7 @@ LDFLAGS += "-Wl,-z,relro,-z,now"
85do_install_append() { 99do_install_append() {
86 rmdir --ignore-fail-on-non-empty "${D}/${localstatedir}/run" 100 rmdir --ignore-fail-on-non-empty "${D}/${localstatedir}/run"
87 101
88 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 102 if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then
89 install -d ${D}${systemd_unitdir}/system 103 install -d ${D}${systemd_unitdir}/system
90 for i in nmb smb winbind; do 104 for i in nmb smb winbind; do
91 install -m 0644 packaging/systemd/$i.service ${D}${systemd_unitdir}/system 105 install -m 0644 packaging/systemd/$i.service ${D}${systemd_unitdir}/system
@@ -97,11 +111,16 @@ do_install_append() {
97 install -d ${D}${sysconfdir}/tmpfiles.d 111 install -d ${D}${sysconfdir}/tmpfiles.d
98 echo "d ${localstatedir}/log/samba 0755 root root -" \ 112 echo "d ${localstatedir}/log/samba 0755 root root -" \
99 > ${D}${sysconfdir}/tmpfiles.d/99-${BPN}.conf 113 > ${D}${sysconfdir}/tmpfiles.d/99-${BPN}.conf
100 elif ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 114 elif ${@bb.utils.contains('PACKAGECONFIG', 'lsb', 'true', 'false', d)}; then
101 install -d ${D}${sysconfdir}/init.d 115 install -d ${D}${sysconfdir}/init.d
102 install -m 0755 packaging/LSB/samba.sh ${D}${sysconfdir}/init.d 116 install -m 0755 packaging/LSB/samba.sh ${D}${sysconfdir}/init.d
103 update-rc.d -r ${D} samba.sh start 20 3 5 . 117 update-rc.d -r ${D} samba.sh start 20 3 5 .
104 update-rc.d -r ${D} samba.sh start 20 0 1 6 . 118 update-rc.d -r ${D} samba.sh start 20 0 1 6 .
119 elif ${@bb.utils.contains('PACKAGECONFIG', 'lsb', 'true', 'false', d)}; then
120 install -d ${D}${sysconfdir}/init.d
121 install -m 0755 packaging/sysv/samba.init ${D}${sysconfdir}/init.d/samba.sh
122 update-rc.d -r ${D} samba.sh start 20 3 5 .
123 update-rc.d -r ${D} samba.sh start 20 0 1 6 .
105 fi 124 fi
106 125
107 install -d ${D}${sysconfdir}/samba 126 install -d ${D}${sysconfdir}/samba
@@ -160,4 +179,4 @@ FILES_${PN}-python-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.d
160 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/dcerpc/.debug/* \ 179 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/dcerpc/.debug/* \
161 " 180 "
162 181
163FILES_${PN}-pidl = "${datadir}/perl5/vendor_perl/*" 182FILES_${PN}-pidl = "${bindir}/pidl ${PERL_VERNDORLIB}/*"