diff options
author | Ben Shelton <ben.shelton@ni.com> | 2014-08-15 10:00:31 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-21 21:35:06 +0200 |
commit | db6489c2faea6d51e1dd45d627e722b978511130 (patch) | |
tree | fd1c7269dc4c06ea03c00e6d846cd19fcbb60b7c | |
parent | e4edce9d5639643cb218806eaed0825f40f449bb (diff) | |
download | meta-openembedded-db6489c2faea6d51e1dd45d627e722b978511130.tar.gz |
cgdb: add recipe
cgdb is a lightweight ncurses-based interface to gdb that provides
syntax highlighting, visual breakpoints, and other features.
Signed-off-by: Ben Shelton <ben.shelton@ni.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/cgdb/cgdb/configfix.patch | 40 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/cgdb/cgdb_0.6.7.bb | 16 |
2 files changed, 56 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb/configfix.patch b/meta-oe/recipes-devtools/cgdb/cgdb/configfix.patch new file mode 100644 index 000000000..25b13862b --- /dev/null +++ b/meta-oe/recipes-devtools/cgdb/cgdb/configfix.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | diff -rupN cgdb-0.6.7-OLD/configure.in cgdb-0.6.7/configure.in | ||
2 | --- cgdb-0.6.7-OLD/configure.in 2013-01-14 05:31:53.000000000 -0600 | ||
3 | +++ cgdb-0.6.7/configure.in 2014-05-08 13:18:13.864632180 -0500 | ||
4 | @@ -65,8 +65,9 @@ AC_CHECK_HEADERS([getopt.h], | ||
5 | [AC_DEFINE(HAVE_GETOPT_H, 1, have getopt_long)]) | ||
6 | |||
7 | dnl determine if /dev/ptmx is available for pseudo terminals | ||
8 | -AC_CHECK_FILE([/dev/ptmx], | ||
9 | - [AC_DEFINE(HAVE_DEV_PTMX, 1, have /dev/ptmx)]) | ||
10 | +dnl AC_CHECK_FILE([/dev/ptmx], | ||
11 | +dnl [AC_DEFINE(HAVE_DEV_PTMX, 1, have /dev/ptmx)]) | ||
12 | +AC_DEFINE(HAVE_DEV_PTMX, 1, have /dev/ptmx) | ||
13 | |||
14 | dnl Checks for typedefs, structures, and compiler characteristics. | ||
15 | AC_C_CONST | ||
16 | @@ -167,15 +168,15 @@ fi | ||
17 | |||
18 | dnl Make sure there is a version of readline that CGDB supports. | ||
19 | dnl Simply putting 5.1* -> 5.9* just to take into accout future versions. | ||
20 | -RL_LIB_READLINE_VERSION | ||
21 | -case "$ac_cv_rl_version" in | ||
22 | -5.1*|5.2*|5.3*|5.4*|5.5*|5.6*|5.7*|5.8*|5.9*|6*|7*|8*|9*) ;; | ||
23 | -*) AC_MSG_ERROR([CGDB requires GNU readline 5.1 or greater to link. | ||
24 | - If you used --with-readline instead of using the system readline library, | ||
25 | - make sure to set the correct readline library on the linker search path | ||
26 | - via LD_LIBRARY_PATH or some other facility.]) | ||
27 | - ;; | ||
28 | -esac | ||
29 | +dnl RL_LIB_READLINE_VERSION | ||
30 | +dnl case "$ac_cv_rl_version" in | ||
31 | +dnl 5.1*|5.2*|5.3*|5.4*|5.5*|5.6*|5.7*|5.8*|5.9*|6*|7*|8*|9*) ;; | ||
32 | +dnl *) AC_MSG_ERROR([CGDB requires GNU readline 5.1 or greater to link. | ||
33 | +dnl If you used --with-readline instead of using the system readline library, | ||
34 | +dnl make sure to set the correct readline library on the linker search path | ||
35 | +dnl via LD_LIBRARY_PATH or some other facility.]) | ||
36 | +dnl ;; | ||
37 | +dnl esac | ||
38 | |||
39 | dnl This will DEFINE the readline headers. | ||
40 | RL_LIB_READLINE_INCLUDES | ||
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb_0.6.7.bb b/meta-oe/recipes-devtools/cgdb/cgdb_0.6.7.bb new file mode 100644 index 000000000..26b2782f0 --- /dev/null +++ b/meta-oe/recipes-devtools/cgdb/cgdb_0.6.7.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "curses-based interface to gdb" | ||
2 | HOMEPAGE = "http://cgdb.github.io/" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
6 | DEPENDS = "readline ncurses gdb" | ||
7 | |||
8 | SRC_URI = "http://cgdb.me/files/cgdb-${PV}.tar.gz \ | ||
9 | file://configfix.patch" | ||
10 | SRC_URI[md5sum] = "e2d9a973d2683faf8130a82703bf6a31" | ||
11 | SRC_URI[sha256sum] = "074ed31d1e827a04574add8c27d391447d75313e85ff938005d8ec939499fda9" | ||
12 | |||
13 | EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR} --with-ncurses=${STAGING_LIBDIR}" | ||
14 | |||
15 | inherit autotools | ||
16 | |||