summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Borzecki <maciej.borzecki@open-rnd.pl>2016-01-06 12:37:16 +0100
committerArmin Kuster <akuster808@gmail.com>2016-02-06 16:56:47 -0800
commitc70f2be562e453899ecf53eef8a0ce61eea3d05f (patch)
tree965e895f17c19133dc56d4b22663c9636f2d057b
parent8e06bcef6793a7c2265e18afe13d8d7b381dbbd8 (diff)
downloadmeta-openembedded-c70f2be562e453899ecf53eef8a0ce61eea3d05f.tar.gz
mozjs: fix linking issues on i586
When building for qemux86 on a x86 host, there's a possibility that the build will try to link with incorrect libraries. Due to problematic -rpath-link the linker may try to use host libraries if they are present and are arch compatible. Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs/0010-fix-cross-compilation-on-i586-targets.patch46
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb1
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs/0010-fix-cross-compilation-on-i586-targets.patch b/meta-oe/recipes-extended/mozjs/mozjs/0010-fix-cross-compilation-on-i586-targets.patch
new file mode 100644
index 000000000..6432e1fb7
--- /dev/null
+++ b/meta-oe/recipes-extended/mozjs/mozjs/0010-fix-cross-compilation-on-i586-targets.patch
@@ -0,0 +1,46 @@
1From a452138a1dd274bfad381a701729783360dc86fb Mon Sep 17 00:00:00 2001
2From: Maciej Borzecki <maciej.borzecki@open-rnd.pl>
3Date: Tue, 5 Jan 2016 22:04:17 +0100
4Subject: [PATCH] fix cross compilation on i586 targets
5
6Remove offending -Wl,-rpath-link that may cause host libraries to be picked
7during linking. The patch applies a fix to configure.in. So as not to
8regenerate configure, similar fix is applied there.
9
10Upstream-Status: Inappropriate [embedded specific]
11
12Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl>
13---
14 js/src/configure | 2 +-
15 js/src/configure.in | 2 +-
16 2 files changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/js/src/configure b/js/src/configure
19index d019b0fdba44233596541de94307010d85a8e32e..5aa40f757a3dbb7d6887175046f44212c15c2eac 100755
20--- a/js/src/configure
21+++ b/js/src/configure
22@@ -5555,7 +5555,7 @@ TARGET_MD_ARCH=unix
23 DIRENT_INO=d_ino
24 MOZ_USER_DIR=".mozilla"
25
26-MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin -Wl,-rpath-link,$(prefix)/lib'
27+MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin'
28
29 MOZ_COMPONENT_NSPR_LIBS='-L$(LIBXUL_DIST)/bin $(NSPR_LIBS)'
30
31diff --git a/js/src/configure.in b/js/src/configure.in
32index 0673aca12f6d83035549ade2a4a83906bf91f0f0..39b22724f9535ac1a6dba04658c91e4ef667fc47 100644
33--- a/js/src/configure.in
34+++ b/js/src/configure.in
35@@ -919,7 +919,7 @@ TARGET_MD_ARCH=unix
36 DIRENT_INO=d_ino
37 MOZ_USER_DIR=".mozilla"
38
39-MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin -Wl,-rpath-link,$(prefix)/lib'
40+MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin'
41
42 MOZ_COMPONENT_NSPR_LIBS='-L$(LIBXUL_DIST)/bin $(NSPR_LIBS)'
43
44--
452.5.0
46
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index bb7170749..be4b50b8e 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -13,6 +13,7 @@ SRC_URI = " \
13 file://0001-regenerate-configure.patch;patchdir=../../ \ 13 file://0001-regenerate-configure.patch;patchdir=../../ \
14 file://fix-the-compile-error-of-powerpc64.patch;patchdir=../../ \ 14 file://fix-the-compile-error-of-powerpc64.patch;patchdir=../../ \
15 file://fix_milestone_compile_issue.patch \ 15 file://fix_milestone_compile_issue.patch \
16 file://0010-fix-cross-compilation-on-i586-targets.patch;patchdir=../../ \
16 " 17 "
17 18
18SRC_URI[md5sum] = "20b6f8f1140ef6e47daa3b16965c9202" 19SRC_URI[md5sum] = "20b6f8f1140ef6e47daa3b16965c9202"