summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-11-20 15:39:48 +0800
committerArmin Kuster <akuster808@gmail.com>2015-12-20 14:27:45 -0800
commit9fc5f4b83188da24270097d1675557c3c3b95f4f (patch)
tree737eaf174aa5b3e46721ea14395c05ec3bc24e87
parent456eb95308e5c79209bf75acb7e064b37670f46b (diff)
downloadmeta-openembedded-9fc5f4b83188da24270097d1675557c3c3b95f4f.tar.gz
apache2: fix host-user-contaminated warnings
It shows warnings when build apache2 such as: | WARNING: QA Issue: apache2: /apache2-dev/usr/share/apache2/icons/small/movie.gif | is owned by uid 1785, which is the same as the user running bitbake. | This may be due to host contamination [host-user-contaminated] Set the owner and group to root to fix it. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb
index b62fd8c28..48c448ebd 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb
@@ -95,6 +95,8 @@ do_install_append() {
95 install -m 0644 ${WORKDIR}/apache2.service ${D}${systemd_unitdir}/system 95 install -m 0644 ${WORKDIR}/apache2.service ${D}${systemd_unitdir}/system
96 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/apache2.service 96 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/apache2.service
97 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' ${D}${systemd_unitdir}/system/apache2.service 97 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' ${D}${systemd_unitdir}/system/apache2.service
98
99 chown -R root:root ${D}
98} 100}
99 101
100do_install_append_class-target() { 102do_install_append_class-target() {