summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2014-12-17 10:04:54 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-19 20:10:57 +0100
commit9fb32353e45f357e15c7326b78cb90ba3b7e3f96 (patch)
treeb83840d63fbd08c48ff3b42708af49e743851042
parent5fb87a31b92911cbfbdcf24080fa83c20e67c5d5 (diff)
downloadmeta-openembedded-9fb32353e45f357e15c7326b78cb90ba3b7e3f96.tar.gz
mcelog: add new recipe
mcelog daemon accounts memory and some other errors in various ways. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_1.04.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog_1.04.bb b/meta-oe/recipes-support/mcelog/mcelog_1.04.bb
new file mode 100644
index 000000000..ceadf7a0a
--- /dev/null
+++ b/meta-oe/recipes-support/mcelog/mcelog_1.04.bb
@@ -0,0 +1,28 @@
1SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "http://mcelog.org/"
6SECTION = "System Environment/Base"
7DEPENDS += "bash"
8SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git"
9SRC_URI[md5sum] = "a06761ad5fed8596238b5a5ea76ed662"
10SRC_URI[sha256sum] = "519390825ec5a0545a7ed48717ef7c7480bb8b9bce68d63a58a52f4e4e275e0f"
11SRCREV = "9de4924e751346df6e2d40ae1007b40ea1915e2b"
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://README;md5=3eb76ca64fa07ad53ebb0ebb5b4c8ede"
14
15S = "${WORKDIR}/git"
16
17do_install() {
18 install -d ${D}/${sbindir}
19 install -m 0755 ${S}/mcelog ${D}/${sbindir}
20 install -d ${D}/${mandir}/man8
21 install -m 0644 ${S}/mcelog.8 ${D}/${mandir}/man8/
22 install -d ${D}/etc/cron.hourly
23 install -m 0755 ${S}/mcelog.cron ${D}/etc/cron.hourly/
24}
25
26COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
27
28RDEPENDS_${PN} = "bash"