summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-01-31 21:11:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-23 23:21:14 +0100
commit9234bcb0d30e66db7b8fcfd867086185649ecbae (patch)
treefaddf5d0a24254d5e6121f92aa83b901c14ff450
parent29a37034c1205cd468815be33c69dcb560e77b67 (diff)
downloadmeta-openembedded-9234bcb0d30e66db7b8fcfd867086185649ecbae.tar.gz
python-efl: upgrade from separate recipes to shared python-efl-1.8.1
* python-ecore, python-edbus, python-edje, python-elementary, python-emotion, python-evas are now built from single source tree * announcements: 1.8.0: http://sourceforge.net/mailarchive/message.php?msg_id=31728838 1.8.1: http://sourceforge.net/mailarchive/message.php?msg_id=31862842 * be aware that upgrade-path wont probably work correctly and that you have to manually cleanup your sysroots before migrating to new shared efl recipe, for details see https://bugzilla.yoctoproject.org/show_bug.cgi?id=4102 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore_1.7.0.bb5
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore_svn.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus.inc50
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb3
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_svn.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-edje.inc6
-rw-r--r--meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch38
-rw-r--r--meta-efl/recipes-devtools/python/python-edje_1.7.0.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-edje_svn.bb10
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc36
-rw-r--r--meta-efl/recipes-devtools/python/python-efl_1.8.1.bb4
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary_1.7.0.bb5
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary_svn.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion_1.7.0.bb5
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion_svn.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-evas.inc4
-rw-r--r--meta-efl/recipes-devtools/python/python-evas_1.7.0.bb5
-rw-r--r--meta-efl/recipes-devtools/python/python-evas_svn.bb8
21 files changed, 63 insertions, 169 deletions
diff --git a/meta-efl/recipes-devtools/python/python-ecore.inc b/meta-efl/recipes-devtools/python/python-ecore.inc
deleted file mode 100644
index 79aaeeccd..000000000
--- a/meta-efl/recipes-devtools/python/python-ecore.inc
+++ /dev/null
@@ -1,5 +0,0 @@
1require python-efl.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "python-evas ecore"
5RDEPENDS_${PN} += "python-evas"
diff --git a/meta-efl/recipes-devtools/python/python-ecore_1.7.0.bb b/meta-efl/recipes-devtools/python/python-ecore_1.7.0.bb
deleted file mode 100644
index 17b713717..000000000
--- a/meta-efl/recipes-devtools/python/python-ecore_1.7.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3
4SRC_URI[md5sum] = "15dd908b71d09ef30f7e758739f3b6fd"
5SRC_URI[sha256sum] = "45d374ffab243b561718897e4eac9aadc1e7ce6e34321a3e728a5f6d07d1e9b6"
diff --git a/meta-efl/recipes-devtools/python/python-ecore_svn.bb b/meta-efl/recipes-devtools/python/python-ecore_svn.bb
deleted file mode 100644
index d551073ce..000000000
--- a/meta-efl/recipes-devtools/python/python-ecore_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCREV = "${EFL_SRCREV}"
4PV = "1.7.0+svnr${SRCPV}"
5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc
index 86ae77343..1d8098f60 100644
--- a/meta-efl/recipes-devtools/python/python-edbus.inc
+++ b/meta-efl/recipes-devtools/python/python-edbus.inc
@@ -1,6 +1,50 @@
1require python-efl.inc 1DESCRIPTION = "${PN} bindings"
2LICENSE = "LGPLv2.1" 2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" 3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "edbus python-dbus" 4AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
5RDEPENDS_${PN} += "python-dbus" 5# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
6# we need to build pyrex otherwise cython doesn't get called to build
7# the extension modules.
8DEPENDS = "python-cython-native python-pyrex-native python-numeric eina edbus python-dbus"
9RDEPENDS_${PN} += "python-lang python-dbus"
10
11# necessary to let the call for python-config succeed
12export BUILD_SYS
13export HOST_SYS
14
15inherit e-base autotools pkgconfig distutils-base
16
6SRCNAME = "python-e_dbus" 17SRCNAME = "python-e_dbus"
18SRCVER = "${PV}"
19
20SRC_URI = "\
21 ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \
22"
23S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
24
25
26do_configure_prepend() {
27 # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
28 sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
29}
30
31do_install_append() {
32 if [ -e examples ]; then
33 for i in `find examples -name "*.edc"`; do
34 cd ${S}/`dirname $i`
35 echo "Generating .edj file for $i..."
36 edje_cc `basename $i`
37 echo "Removing sources in this directory..."
38 rm -f *.edc *.png *.ttf *.jpeg
39 done
40 cd ${S}
41 install -d ${D}${datadir}/${PN}/
42 cp -a examples ${D}${datadir}/${PN}/
43 find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
44 fi
45}
46
47FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
48
49PACKAGES += "${PN}-examples"
50FILES_${PN}-examples = "${datadir}/${PN}/examples"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb b/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
index 562846931..9e5ff0a02 100644
--- a/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
+++ b/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
@@ -1,5 +1,6 @@
1require ${BPN}.inc 1require ${BPN}.inc
2PR = "${INC_PR}.0" 2
3PR = "r1"
3 4
4SRC_URI[md5sum] = "40b479444bb06147429a276127981890" 5SRC_URI[md5sum] = "40b479444bb06147429a276127981890"
5SRC_URI[sha256sum] = "78e5ca334ee25185748660b4e612f984f4d3bced018f062278701429868f117b" 6SRC_URI[sha256sum] = "78e5ca334ee25185748660b4e612f984f4d3bced018f062278701429868f117b"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_svn.bb b/meta-efl/recipes-devtools/python/python-edbus_svn.bb
deleted file mode 100644
index d551073ce..000000000
--- a/meta-efl/recipes-devtools/python/python-edbus_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCREV = "${EFL_SRCREV}"
4PV = "1.7.0+svnr${SRCPV}"
5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-edje.inc b/meta-efl/recipes-devtools/python/python-edje.inc
deleted file mode 100644
index 2e2e1f2b7..000000000
--- a/meta-efl/recipes-devtools/python/python-edje.inc
+++ /dev/null
@@ -1,6 +0,0 @@
1require python-efl.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "edje python-evas evas"
5RDEPENDS_${PN} += "python-evas"
6EXTRA_OECONF += "--disable-examples"
diff --git a/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch b/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch
deleted file mode 100644
index 3b0cdc627..000000000
--- a/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From fa12a33b5a3c0e86231ca84967d9eff456e5f314 Mon Sep 17 00:00:00 2001
2From: Jan Luebbe <jluebbe@debian.org>
3Date: Sat, 9 Aug 2008 18:30:04 +0200
4Subject: [PATCH] fix unicode conversion
5
6---
7 edje/edje.c_edje_object.pxi | 11 +++++++----
8 1 files changed, 7 insertions(+), 4 deletions(-)
9
10diff --git a/edje/edje.c_edje_object.pxi b/edje/edje.c_edje_object.pxi
11index 0f4da68..21c237e 100644
12--- a/edje/edje.c_edje_object.pxi
13+++ b/edje/edje.c_edje_object.pxi
14@@ -415,17 +415,20 @@
15 else:
16 raise TypeError("func must be callable or None")
17
18- def part_text_set(self, char *part, char *text):
19- edje_object_part_text_set(self.obj, part, text)
20+ def part_text_set(self, char *part, text):
21+ cdef char *s
22+ u = text.encode("utf8")
23+ s = u
24+ edje_object_part_text_set(self.obj, part, s)
25
26 def part_text_get(self, char *part):
27- "@rtype: str"
28+ "@rtype: unicode"
29 cdef const_char_ptr s
30 s = edje_object_part_text_get(self.obj, part)
31 if s == NULL:
32 return None
33 else:
34- return s
35+ return s.decode("utf8")
36
37 def part_text_select_all(self, char *part):
38 edje_object_part_text_select_all(self.obj, part)
diff --git a/meta-efl/recipes-devtools/python/python-edje_1.7.0.bb b/meta-efl/recipes-devtools/python/python-edje_1.7.0.bb
deleted file mode 100644
index 9a30ad435..000000000
--- a/meta-efl/recipes-devtools/python/python-edje_1.7.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRC_URI += "file://0001-fix-unicode-conversion.patch"
4
5SRC_URI[md5sum] = "1e0d7a4a4504298caaad0cee476e4edb"
6SRC_URI[sha256sum] = "b1eb7be4dea099752c587baa4747d8100de6cead256ffea22a6cc0e88c4e8786"
diff --git a/meta-efl/recipes-devtools/python/python-edje_svn.bb b/meta-efl/recipes-devtools/python/python-edje_svn.bb
deleted file mode 100644
index eca8b7586..000000000
--- a/meta-efl/recipes-devtools/python/python-edje_svn.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCREV = "${EFL_SRCREV}"
4PV = "1.7.0+svnr${SRCPV}"
5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
9
10SRC_URI += "file://0001-fix-unicode-conversion.patch"
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
index b622c40d9..c608bac7c 100644
--- a/meta-efl/recipes-devtools/python/python-efl.inc
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -1,48 +1,32 @@
1DESCRIPTION = "${PN} bindings" 1DESCRIPTION = "${PN} bindings"
2LICENSE = "BSD" 2
3LICENSE = "LGPLv3.0"
4LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02"
5# there is also GPLv3.0 in COPYING;md5=d32239bcb673463ab874e80d47fae504 but no file seems to use that
6
3AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>" 7AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
4# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython, 8# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
5# we need to build pyrex otherwise cython doesn't get called to build 9# we need to build pyrex otherwise cython doesn't get called to build
6# the extension modules. 10# the extension modules.
7DEPENDS = "python-cython-native python-pyrex-native python-numeric eina" 11DEPENDS = "python-cython-native python-pyrex-native python-numeric eina"
8RDEPENDS_${PN} += "python-lang" 12RDEPENDS_${PN} += "python-lang"
9INC_PR = "r1" 13
14PROVIDES = "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas"
15RPROVIDES_${PN} += "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas"
10 16
11# necessary to let the call for python-config succeed 17# necessary to let the call for python-config succeed
12export BUILD_SYS 18export BUILD_SYS
13export HOST_SYS 19export HOST_SYS
14 20
15inherit e-base autotools pkgconfig distutils-base 21inherit e-base distutils pkgconfig
16 22
17SRCVER = "${PV}" 23SRCVER = "${PV}"
18 24
19SRC_URI = "\ 25SRC_URI = "\
20 ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \ 26 ${E_RELEASES}/bindings/python/${SRCNAME}-${SRCVER}.tar.gz \
21" 27"
22S = "${WORKDIR}/${SRCNAME}-${SRCVER}" 28S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
23 29
24
25do_configure_prepend() {
26 # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
27 sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
28}
29
30do_install_append() {
31 if [ -e examples ]; then
32 for i in `find examples -name "*.edc"`; do
33 cd ${S}/`dirname $i`
34 echo "Generating .edj file for $i..."
35 edje_cc `basename $i`
36 echo "Removing sources in this directory..."
37 rm -f *.edc *.png *.ttf *.jpeg
38 done
39 cd ${S}
40 install -d ${D}${datadir}/${PN}/
41 cp -a examples ${D}${datadir}/${PN}/
42 find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
43 fi
44}
45
46FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug" 30FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
47 31
48PACKAGES += "${PN}-examples" 32PACKAGES += "${PN}-examples"
diff --git a/meta-efl/recipes-devtools/python/python-efl_1.8.1.bb b/meta-efl/recipes-devtools/python/python-efl_1.8.1.bb
new file mode 100644
index 000000000..15009f699
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-efl_1.8.1.bb
@@ -0,0 +1,4 @@
1require ${BPN}.inc
2
3SRC_URI[md5sum] = "ca71f501c7e0479f15d2746380b0f81d"
4SRC_URI[sha256sum] = "90ea20d0a90448fd1dcd56210bf34cb9a78905852d83620617bf164f1cef5edc"
diff --git a/meta-efl/recipes-devtools/python/python-elementary.inc b/meta-efl/recipes-devtools/python/python-elementary.inc
deleted file mode 100644
index 3f1d123c3..000000000
--- a/meta-efl/recipes-devtools/python/python-elementary.inc
+++ /dev/null
@@ -1,5 +0,0 @@
1require python-efl.inc
2LICENSE = "LGPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
4DEPENDS += "elementary python-evas"
5RDEPENDS_${PN} += "python-evas python-ecore python-edje"
diff --git a/meta-efl/recipes-devtools/python/python-elementary_1.7.0.bb b/meta-efl/recipes-devtools/python/python-elementary_1.7.0.bb
deleted file mode 100644
index 625c09df2..000000000
--- a/meta-efl/recipes-devtools/python/python-elementary_1.7.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3
4SRC_URI[md5sum] = "38c8b2ac508ab4e1d12f1557a12169c9"
5SRC_URI[sha256sum] = "63052f8428d725599a0a2765fe48a21e695c66599ec1dcce0a909db440d2216b"
diff --git a/meta-efl/recipes-devtools/python/python-elementary_svn.bb b/meta-efl/recipes-devtools/python/python-elementary_svn.bb
deleted file mode 100644
index d551073ce..000000000
--- a/meta-efl/recipes-devtools/python/python-elementary_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCREV = "${EFL_SRCREV}"
4PV = "1.7.0+svnr${SRCPV}"
5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-emotion.inc b/meta-efl/recipes-devtools/python/python-emotion.inc
deleted file mode 100644
index ac64676f0..000000000
--- a/meta-efl/recipes-devtools/python/python-emotion.inc
+++ /dev/null
@@ -1,5 +0,0 @@
1require python-efl.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "emotion python-evas"
5RDEPENDS_${PN} += "python-ecore"
diff --git a/meta-efl/recipes-devtools/python/python-emotion_1.7.0.bb b/meta-efl/recipes-devtools/python/python-emotion_1.7.0.bb
deleted file mode 100644
index 01e675147..000000000
--- a/meta-efl/recipes-devtools/python/python-emotion_1.7.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3
4SRC_URI[md5sum] = "ac7197ce2617a87fad3dd134a98ad01f"
5SRC_URI[sha256sum] = "ac2910c0e3e861dfc07253b825dc038baa1a3e6ce7d5b362122ad51127e20e91"
diff --git a/meta-efl/recipes-devtools/python/python-emotion_svn.bb b/meta-efl/recipes-devtools/python/python-emotion_svn.bb
deleted file mode 100644
index d551073ce..000000000
--- a/meta-efl/recipes-devtools/python/python-emotion_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCREV = "${EFL_SRCREV}"
4PV = "1.7.0+svnr${SRCPV}"
5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-evas.inc b/meta-efl/recipes-devtools/python/python-evas.inc
deleted file mode 100644
index 3211b1441..000000000
--- a/meta-efl/recipes-devtools/python/python-evas.inc
+++ /dev/null
@@ -1,4 +0,0 @@
1require python-efl.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "evas"
diff --git a/meta-efl/recipes-devtools/python/python-evas_1.7.0.bb b/meta-efl/recipes-devtools/python/python-evas_1.7.0.bb
deleted file mode 100644
index 62219d8c2..000000000
--- a/meta-efl/recipes-devtools/python/python-evas_1.7.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3
4SRC_URI[md5sum] = "c3fda2025171f5e3d2bc224e8bae88e5"
5SRC_URI[sha256sum] = "bc00ea23d4d3e9d6448c8a24f918f577cf3c2b25636f36b76b2ed2e3a74d42f5"
diff --git a/meta-efl/recipes-devtools/python/python-evas_svn.bb b/meta-efl/recipes-devtools/python/python-evas_svn.bb
deleted file mode 100644
index d551073ce..000000000
--- a/meta-efl/recipes-devtools/python/python-evas_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCREV = "${EFL_SRCREV}"
4PV = "1.7.0+svnr${SRCPV}"
5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"